Anonymous login for guests configurations

I edit the /etc/prosody/prosody.cfg.lua** and add bellow lines after admins object;

admins = {}
component_ports = { 5347 }
component_interface = “0.0.0.0”

change

c2s_require_encryption=true

to

c2s_require_encryption=false

and check the end of file if file has the line;

Include “conf.d/*.cfg.lua”

then editfing /etc/prosody/conf.avail/MY_DOMAIN.cfg.lua and add above lines with your issuers and audiences;

asap_accepted_issuers = { “YOUR_APP_ID”, “smash” } asap_accepted_audiences = { “YOUR_APP_ID”, “smash” }

then add

`VirtualHost “YOUR_DOMAIN”
           authentication = “token”;
           app_id = “YOUR_APP_ID”; — application identifier
            app_secret = “YOUR_SECRET”; — application secret known only to your token`

then enable the prosody module mod_presence_identity in your config.

modules_enabled = { “presence_identity” }

And enable room name token verification plugin in your MUC component config section:

Component “conference.MY_DOMAIN” “muc” modules_enabled = { “token_verification” }

And setup guest domain

`VirtualHost “guest.MY_DOMAIN”
                   authentication = “token”;
                   app_id = “YOUR_APP_ID”;
                   app_secret = “YOUR_SECRET”;
                   c2s_require_encryption = false;
                   allow_empty_token = true;`

then Enable Anonymous Domain in Jitsi Meet Config

/etc/jitsi/meet/YOUR_DOMAIN-config.js and edit as:

var config = {
     hosts: {
         // When using authentication, domain for guest users.
         anonymousdomain: ‘guest.jitmeet.example.com’,
},
enableUserRolesBasedOnToken: true,
}

in /etc/jitsi/jicofo/config as:

JICOFO_HOST=YOUR_DOMAIN

Edit /etc/jitsi/jicofo/sip-communicator.properties as;

org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.YOUR_DOMAIN org.jitsi.jicofo.auth.URL=XMPP:YOUR_DOMAIN org.jitsi.jicofo.auth.DISABLE_AUTOLOGIN=true

Edit Video Bridge config file;

nano /etc/jitsi/videobridge/config

In the config file set your JWB_HOST parameter as;

JVB_HOST=YOUR_DOMAIN

Also in the config, add a new paramater AUTHBIND as;

AUTHBIND=yes

guest failed to enter the room when I use the invitation link without a token, get oops couldn`t connect to the conference, any help, please

if I use the invitation link with a token can access the room as a second moderator I want to make any guest enter room with only one click on the invitation link.

Add this to the main virtual host

This is supposed to be used with secure domain setup, not with tokens.

if I added this to the main virtual host I will allow any user to create a room without token which I don`t want to allow , I need to make only user with token can create room and guest enter the room after host create it without token.

can explain to me why anonymousdomain only supposed to be used with secure domain setup, not with tokens?
and it is supposed to be used with my own SQL DB

This is how it was designed to work. There is no such option for jwt at the moment, if the combination of both used to work, it was a coincidence, we have never been testing that combination…

okay ,
what if I add token to guest with

 "moderator": false,

and for host

  "moderator": true,

as it supported here

This is only for jaas and is implemented in the backend modules that are specific for jaas.
There are similar modules in jitsi-contrib project, but I’m not familiar with those.