Android Settings don't honor subdirectory on private URL server?

Hi there!
This is my first post so I hope not to break many netiquettes here :slight_smile:
So I installed jitsi on my private server thanks to the many resources out there, great job!

I have this setup:
On the server, the docker containers provided in the github repo by the docker-compose.yaml file.
The jitsi URL is not in the domains’ root but in a subfolder, like h ttps://myprivateserver.com/jitsi, so I had to tune a couple of values in config.js to make it point to the proper paths. I have other webservices running so that’s the reason I didn’t put jitsi on the top.

When using a PC browser everything goes fine. However, I configure the Android app settings to point to https://myprivateserver.com/jitsi. Then, when I want to create a room from Android called test, it won’t notice the trailing jitsi bit at all. Logcat shows this:
JitsiMeetSDK: [features/base/lib-jitsi-meet] Failed to load config from https://myprivateserver.com/config.js?room=test.

And the Android app’s UI shows the scary “reconnect” message.

Weirdly enough, if I set the server’s URL to the root one, h ttps://myprivateserver.com; and then I create a room called “jitsi/test”, I can establish a communication and it works perfectly fine.

I saw from other posts here and there to modify the react/features/app/components/AbstractApp.js file but I just want to be sure to do that before recompiling the Android app.

Any clue on that? Thanks for your help :slight_smile:

1 Like

I am having the exact same problem.
Would like a fix as well :slight_smile:

I have the same problem. Is there any solution without recompiling?
Thank you in advance!