Android no sound no video

hi,

i have setup my own jitsi server on my home pc, and am looking to use it over android devices, where connection is establishing between 2 android devices but without sound and with blank screen, where the following is my setup along with some observations (please note am new and not very familiar what jvb and jicofo do):

Setup procedure:

  • i have edited my wifi router and port forwarded the required ports tcp 80,443, udp 10000:20000 to my pc, i also used some online tool to check opened ports and it worked.

  • installed debian 10 fresh installation and included debian 9 sources list to have Java version 8.

  • install java 8: apt install openjdk-8-jre-headless -y

  • install nginx
    apt install nginx -y
    systemctl start nginx
    systemctl enable nginx

  • install jitsi:
    apt install gnupg2 -y
    wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | apt-key add -
    echo ‘deb https://download.jitsi.org stable/’ >> /etc/apt/sources.list.d/jitsi-stable.list
    apt update
    apt install jitsi-meet -y
    ** i entered my own sub-domain host and selected generate lets encrypt certificate

  • here, i found that there is a process called jvb which reserve port 443 in which avoid nginx to reserve 443 so i killed this process and restarted nginx:
    lsof -i :443
    kill
    systemctl start nginx

  • install lets encrypt ssl certificate:
    /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

  • reboot system

Some Observations:

  • after reboot, i have the following ports listening along with the listening process:
    nginx 80, 443
    jvb 4443
    jicofo 8888

  • if i stop nginx and restart jvb then jvb port will be 443, then if i start nginx it wont start telling port 443 is in use, so i stop jvb and start nginx first then start jvb so jvb will take port 4443.

  • i port forwarded also ports 4443 and 8888 in my wifi router where then when i try to connect the devices i receive an error message of failed connection and a retry timer will start to count down, so i removed 4443 and 8888 from port forwarding.

  • in terms of ssl certificate, i can open the url successfully in chrome (my browser does not tell invalid ssl, its valid)

  • i have a static public IP at home.

  • i tried all scenarios from the devices whether to connect to same wifi or using mobile data.

will you help me in this, thanks.

You need to forward and the port for media https://jitsi.org/qi#advanced-configuration

it worked 100%, editing “/etc/jitsi/videobridge/sip-communicator.properties” adding those couple of lines:

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>

many thanks

is <Local.IP.Address> literally your local lan IP of the server?

yes, something like 192.168.1.xx

1 Like

hay man
jitsi has just two secret for install
1- configure NAT
2- install Valid SSL for your web server and jitsi