Android jitsi sdk

What SDK version are you using? We removed BaseReactView in the latest, so please update to 6.0.0 and try again.

2022-07-15 18:30:30.786 32201-32201/com.org.chaingram E/MyCrash: at org.jitsi.meet.sdk.JitsiMeetView.(JitsiMeetView.java:101)
… 29 more
Caused by: java.lang.ClassNotFoundException: Didn’t find class “com.facebook.infer.annotation.Assertions” on path: DexPathList[[zip file “/system/framework/org.apache.http.legacy.boot.jar”, zip file “/data/app/com.org.chaingram-dLDSy3fTBSkYoH55yk6g5Q==/base.apk”],nativeLibraryDirectories=[/data/app/com.org.chaingram-dLDSy3fTBSkYoH55yk6g5Q==/lib/arm64, /data/app/com.org.chaingram-dLDSy3fTBSkYoH55yk6g5Q==/base.apk!/lib/arm64-v8a, /system/lib64, /system/vendor/lib64]]
at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:134)
at java.lang.ClassLoader.loadClass(ClassLoader.java:379)
at java.lang.ClassLoader.loadClass(ClassLoader.java:312)
… 33 more

I still have problems updating to 6.0.0

Caused by: java.lang.ClassNotFoundException: Didn’t find class “com.brentvatne.react.ReactVideoPackage”. --version 6.0.0

Caused by: java.lang.ClassNotFoundException: Didn’t find class “com.brentvatne.react.ReactVideoPackage”. --version 6.0.0。
Can you help me?

Are you using ProGuard? Have you set out rules?

No, but the above problem is solved. This is because the previously downloaded dependency library is incomplete. grateful

1 Like

jitsimeeting sdk version 6.0.0 The vivo mobile phone system crashes after connecting to the video

There is no way for anyone to help you without a backtrace or any crash information.