Android app speaker volume very low

There is a thing in Android called ConnectionServie. It basically allows apps to integrate with the system dialer. This integrates better with system calling. For example, you’ll get a message if you get an incoming call, beause you are already in a call.

In addition, CS (ConnectionService) greatly simplifies device management.

However, not all the glitter is gold. Manufacturers provide their own implementation of TelecomService, which is used under the hood by CS and sometimes there are bugs, pretty much like this one.

What the PR I made does (thanks a lot for validating the fix!) is fall-back to the non-CS case. If you ever put a SIM card on that device CS will start to work and you’ll not notice a thing, that’s the idea at least :slight_smile:

Thanks for the explanation!
in non-CS case, how does the jitsi use speaker and mic ? via webrtc ?

WebRTC is used in both cases, but we have some code for managing devices depending on the call type. This is what we do for non-CS devices:


I find a new bug. the fix works well with the debug build. but on a release build (signed APK), problem still reproduce.

What the… that doesn’t make sense :-/ Can you share the logcat output again? Also, this fix should evailable on the latest Jitsi Meet beta. Any chance you could give that a try?

signed_app_log.txt (150.0 KB)

I don’t see all logs in there :-/ From that output, looks like the requested audio mode by Jitsi is applied on the system, I don’t see it falling back… also, the generic driver is being used, so no connection services.

hmmm… I have disabled the call-integration and now all is working. I will leave it for now. When I have time I will continue debug it.

Were you referring to 19.3.1 or later ?

19.5 (the next release) contains a fix for this. You can join the beta as I mentioned here: Android app speaker volume very low


I was having the same issue but with the Microphone (same exact device).

Using 19.4.1 the advanced config was there, we disabled the option for Call integration and now it works as expected. Thank you!