Android App doesn't seem to take port into account

So I’ve installed Jitsi on my own server and it works wonderfully! But now when I try to use the Android App it immediately tells me that it’s unable to connect.

The server runs a valid SSL certificate and a normal browser shows this! When I use logcat on my Android device it says (Domain name Obfuscated):
Failed to load config from
Now this is odd as I configured the url to be, as it runs on a different port (behind NAT). Now everything else works fine but the app doesn’t seem to take the port into account.

Does anyone have eperience with this issue?
Thanks in advance!

@MaatjeBroccoli maybe you want give @Sander 's hint about a try?
Helped my with my solved and maybe similar issue SOLVED: Android immediately disconnects, always

I’ve got for my immediate disconnect issue the probably same error in logcat “failed to load config…”, but I can at least confirm that in my logcat the android app definitively connects at, including the port reference.

1 Like

That seemed to work! I’m at a loss as to why the correct port wasn’t logged :S but thanks anyways!

For people whose certificate chain is incorrect as well but are having trouble configuring this, your /etc/jitsi/meet/ file needs to have the Bundle file from your CA. If you don’t have one you can concatenate your crt file and chain file like this:
cat certificate.crt certficate.chain > certifcate.bundle

This fixed it for me!

Thanks for the response!