Android 7 clients disconnected

Hi everyone,

my customer uses Jitsi app on an Android 7 phone. They can use the meet.jit.si no problem. But on their own installation they get an error (I’m translating from german):

You’ve been disconnected. Check your network connection. Connecting in [ x ] seconds…

In the jvb.log I see:

2020-04-14 11:03:14.914 WARNING: [56172] [confId=5d804ff382d6af4 epId=079a5ab8 gid=ff53fd stats_id=Dayna-RBs conf_name=test2] AbstractEndpointMessageTransport.onClientEndpointMessage#219: Unable to find endpoint b836f429 to send EndpointMessage

2020-04-14 11:03:15.398 WARNING: [56172] [confId=5d804ff382d6af4 epId=5548ee73 gid=ff53fd stats_id=Talon-wC9 conf_name=test2] AbstractEndpointMessageTransport.onClientEndpointMessage#219: Unable to find endpoint b836f429 to send EndpointMessage

They have tried with Wifi and without (LTE/4G) but the error remains the same. Other clients (PC with Chrome/Firefox, Android 10) do work. Any advice?

I’m having a similar issue. I have installed the docker Jitsi meet server and I’m able to connect through web browsers with no problem. I can connect using the mobile client on Android 8, but I’ve tried 3 different devices with Android 7 and it won’t work, even though it works fine in the mobile web browser in desktop mode. I get an error in the Jitsi client saying:

You have been disconnected. You may want to check your network connection. Reconnecting in xx sec…

I’m using 20.2.3 build 202030.
I’ve checked my Let’s Encrypt certificate at https://whatsmychaincert.com and it is successful.
I also tried updating my web/config.js BOSH url to the full address instead of relative, but no change.