Always disconnects---how to troubleshoot?

Fresh install on ManjaroLinux using yay. Compilation stopped requesting to set JAVA_HOME. I used

export JAVA_HOME=/usr/lib/jvm/java-14-openjdk

and it compiled without problem.
I followed the ArchLinux guide changing only the web configuration as the server uses Apache and not Ngix, but I can not connect. It always says Disconnected and retries in 15 sec again and again. Maybe I did not setup correctly Apache? The site works:

I try to look at the logs at /var/log/jicofo/ and /var/log/jitsi-videobridge/ but they are empty. No files there. And no prosody.log in /var/log/. The meet.math.aegean.gr-error_log file shows no errors.

How to start debugging this issue? Thank you.

image
Your apache config has a problem.

That was quick. Thank you. However the manual installation instructions here:


talk only for Ngix and not Apache. I wonder why is this? Would it be so difficult to include the correct Apache configuration? Or it is somewhere I missed it?
In any case let me post the two relative configuration files:

Parts of these files where automatically created by certbot. It did not work immediately so some other parts I found googling around.
Thanks for any suggestion.

I found the file ~/.cache/yay/jitsi-meet/src/jitsi-meet-stable-jitsi-meet_4857/doc/debian/jitsi-meet/jitsi-meet.example-apache
which I used to setup the vhost for jitsi.

When I use this and restart apache it exits. The command
systemctl status httpd

gives

Invalid command ‘ProxyPreserveHost’, perhaps misspelled or defined by a module not included in the server configuration

“Google” says that I need to run

a2enmod proxy

But after this there is no improvement. It still produces the same error (Invalid command ‘ProxyPreserveHost’). So some other module is needed for this command to be understood. Which one?

My new files are as above in

flagged as -new

I loaded mod_proxy.so
Now apache starts but the meet.math.aegean.gr gives

Access forbidden!

What else is needed?

OK I added

Require all granted

and now I get inside the room. But camera does not open and mic does not open.

Hmmm why it is so difficult?

Maybe provide some logs from the js console.

On any debian based distro you need one apt command, a DNS entry pointed to the server, do the port forwarding and that’s it, it is a matter of few minutes.

Yes I admit you are right. I have successfully installed it on Ubuntu18. Maybe Manjaro/Arch is not so easy. Anyway… you mean the console on chrome or something else? Indeed the chrome console shows errors:

#################
strophe.umd.js:5123 POST https://meet.math.aegean.gr/http-bind?room=test 500 (Internal Server Error)
Logger.js:154 2020-10-22T05:47:28.412Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: request id 1.1 error 500 happened
at Object.r.Strophe.log (strophe.util.js:89)
at Object.error (strophe.umd.js:1392)
at P.Bosh._onRequestStateChange (strophe.umd.js:5017)
Logger.js:154 2020-10-22T05:47:28.416Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: request id 1.1 error 500 happened
Logger.js:154 2020-10-22T05:47:28.419Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: request errored, status: 500, number of errors: 1
Logger.js:154 2020-10-22T05:47:28.441Z [modules/RTC/RTCUtils.js] onUserMediaSuccess
strophe.umd.js:5123 POST https://meet.math.aegean.gr/http-bind?room=test 500 (Internal Server Error)
Logger.js:154 2020-10-22T05:47:28.482Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: request id 2.2 error 500 happened
at Object.r.Strophe.log (strophe.util.js:89)
at Object.error (strophe.umd.js:1392)
at P.Bosh._onRequestStateChange (strophe.umd.js:5017)
Logger.js:154 2020-10-22T05:47:28.487Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: request id 2.2 error 500 happened
Logger.js:154 2020-10-22T05:47:28.492Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: request errored, status: 500, number of errors: 2
Logger.js:154 2020-10-22T05:47:29.545Z [features/base/redux] <Object.persistState>: redux state persisted. 638eac61fddc2d93d002f21b4a55bbc2 -> 7673dd4b4e88b47892f3e87d2e309049
strophe.umd.js:5123 POST https://meet.math.aegean.gr/http-bind?room=test 500 (Internal Server Error)
Logger.js:154 2020-10-22T05:47:36.661Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: request id 3.3 error 500 happened
at Object.r.Strophe.log (strophe.util.js:89)
at Object.error (strophe.umd.js:1392)
at P.Bosh._onRequestStateChange (strophe.umd.js:5017)
Logger.js:154 2020-10-22T05:47:36.664Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: request id 3.3 error 500 happened
Logger.js:154 2020-10-22T05:47:36.667Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: request errored, status: 500, number of
#################

This means there are errors in prosody, check those.

Problem is there is no prosody.log and prosody.err even if I enable them in the config. Anyway, I changed daemonize to false and change log to console. Stopped prosody with systemctl and started with
/usr/bin/prosodyctl start
This showed that it expected to find certificates in /etc/prosody/certs although the VirtualHost in prosody.cfg.lua clearly states /var/lib/prosody/ So I removed the empty /etc/prosody/certs directory and linked to /var/lib/prosody/ with
ln -s /var/lib/prosody/ /etc/prosody/certs/
killed prosody and start it again with /usr/bin/prosodyctl start

Now the certificates are found but there are still a couple of errors:

  1. portmanager error Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281

  2. datamanager debug cannot obtain information from file ‘/var/lib/prosody/meet%2emath%2eaegean%2egr/pubsub_nodes’: No such file or directory

The system behaves the same way. My webcam lights up, but no video appears to the server.
I copy the prosody.cfg.lua to
https://myria.math.aegean.gr/tmp/ with the passwords replaced.

So we’ve reached a dead end. OK. I will completely remove all related packages and configuration and try to install again from scratch, this time using the -bin packages from AUR which are the debian packages. And reconfigure. Maybe the debian packages work better as it was easy to install a working jitsi on Ubuntu.

Nope. I removed the packages. Re-install the -bin packages which are the Debian ones, reconfigured everything from scratch but… it has exactly the same issues. Maybe it is an Arch/Manjaro problem. I will try to ask their community.