Alone in the room


#1

Hi guys,

I managed to install jitsi meet on debian and the last command I used was from “https://jitsi.org/downloads/” was the following: apt-get -y install jitsi-meet. From there I followed the instruction including the installation of the let’s encrypt.

Now as I test my first meeting using two computers A & B(same wifi network), users could not see each other. Computer A create the room and when computer B joins, there is a message popping from the bottom left of the computer A indicating that computer B have joined but that’s about it, there is no audio nor video nor avatar of computer A. same to computer B.

The other thing I noticed is that the chat is not working, when you try to send any message in chat nothing happen.

However, when you try to refresh the browser either from Com A or B, each user see the info(Avatar, message showing that the other user has joined) of the other user for only 2-3 seconds and all disappear again.

Is there an older version that is table and working correctly or is there anything else maybe that I had to install?
How do I know which version is my installation?
How do I fix this?

Best regards,
Thebe


#2

Did u open the ports in the server? U need to open port 4443/tcp and 10000/udp and also do u have a firewall in ur client side?? Is ur p2p enabled or disabled? Where is the console log, jicofo log and prosody log? Not enough information!!


#3

Hi Tanvir,

Yes, port 443/tcp and 10000udp is open as shown from this link: http://storage.vplaya.com/3.png

do you mean antivirus firewall on pc? if so then kindly note that I just turned it off and this time I tested with one pc and one a mobile phone and the results were as follows:

On pc, only notification popped up to say the phone has joined but still nothing else(avatar etc) was showing. But the smart phone app was able to show the avatar of the computer.

I do not know what is p2p, could kindly give an indication where I should get it.

It will also be highly appreciated if you can advise on how to get the logs.

Best regards,
Thebe


#4

Open the javascript console in the browser, normally this is the first step of debugging a problem. In chrome it is under View->Developer, I think.
Do you see any error there?


#5

U opened tcp10000 which is not right u supposed to open udp 10000 and tcp 443 & 4443


#6

Im not sure on goofle xloud, whether the machine have their public address as locally configured address, but if not the case you also need to do some jvb configuration: https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#advanced-configuration


#7

I will check that out thank you.


#8

Im not if I understand what you mean by public address… are you asking if in google cloud domain can be accessible to public?


#9

10000/tcp is got nothing to do with jitsi, I have an application using that port. At this stage im not sure why do you mention 10000/udp again because I have circled that in red from the image I attached in the link to show that its open. Ok Ill go ahead and open port 4443 as well.


#10

If you have an application using port udp 10000 this will be a problem. This is the default port used for udp communication.
You need to add to jvb config for example:
org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT=10001 and then make sure you forward to the machine the traffic for port 10001.

For the public address I mean that you need to do some configuration if non of the network interfaces on that machine does not have the public address configured.
For example this is the case when using aws, on the vm you only have some private address, and the machine (jvb) does not know about the public address and you only configure that in some console like the Google Cloud Platform console you use.
You can check that when on the machine execute ifconfig do you see the public address there? If not follow the advanced config from the quick-install guide and configure public and private address in jvb and restart jvb.


#11

The application is not using 10000/udp, it is using 10000/tcp… is that still a problem? If so then Ill change its port to something else.

As for the public address I’m a bit lost because I still dont understand the public address you are reffering to. All I know is that google compute engine is like any other dedicated server where you setup your own firewall. Ive been using it only for installing and hosting wordpress and Im also used to install cpanel to manage domains that I host and i would open cpanel ports without issues. So for google, they dont block anything as the firewall setting is in my hand and I have a static Ip for the server with root access.


#12

JVB uses 10000 udp. I know somebody was reporting problems using it with some webmin …

Did you check the ipconfig thing I purposed, what is the result, do you see your public address there?

All of the web apps you use are agnostic about the public address, the public address is used only on a network level, where JVB needs to use it in application level.
JVB needs to know its public address in order to add it to the candidates which later be used by the clients, and they will use that address to send media through. If the ip address is not locally configured (which is the case in most services which provides VMs like aws) there is no way for JVB to auto-detect it, so you need to configure it as described in the quick-install guide.
Just check whether you see your public address locally configured while ssh-ed on the machine.


#13

Thanks Damencho,

Yes I am also using 10000tcp for webmin. So ill change that port to avoid any conflict.

By public address, do you mean a domain name I used to replace the Ip?


#14

The public ip address. This is the ip address you will see when you execute ping your.domain.com where your.domain.com is the one you used to install jitsi-meet and which you write in the browser to acces your deployment.


#15

Hi Damencho,

Thanks for clarity on public address. Yes during the setup I did specify the domain(meet.vplaya.com) to be used by jitsi.

So far here are the changes I made:

  1. I changed the webmin port from 10000 to 10001
  2. I opened the 4443 port as well

the port 443 is still open and the udp is still on 10000-20000

Now after making this changes, jitsi is now promising though there is only one new glitch that showed up.
the improvement that I noticed is that as soon as you create a room you now get a message saying that you are a moderator and also the chat is now functional as expected.

About the new glitch: creating the room has no issues, however as soon as anyone try to join you in the room, either from pc or mobile app, both sites crushes and reload itself after countdown error message

You can view the error from this link: http://storage.vplaya.com/snapsho.png

You are also welcome to create a room at meet.vplaya.com to see the error directly

Best regards,
Thebe


#16

The actual error is CONFERENCE FAILED: conference.videobridgeNotAvailable. Check why JVB is not running or not connected.


#17

Hi Damencho

I tried to change the jvb folder permission to 7555 with no luck to my problem

I then I searched around, found and followed this link: https://github.com/jitsi/jitsi-meet/issues/2184

So I looked at the following files:

/etc/jitsi/jicofo/config - you can download here config

/etc/prosody/conf.d/yourdomain.cfg.lua - you can download here- meet.vplaya.com.cfg.lua

I am not what to change but I am willing to tweak anything you may suggest.

Your advise will be highly appreciated

Best regards,
Thebe


#18

Delete your jvb log, resyart jvb and then upload your log, so I can take a look.


#19

Hi Damian, I’ll do so in a hours time as I’m at the gym. Thank you. :slight_smile:


#20

I’ve searched inside jvb fold for the log with no luck, my I kindly ask where do I find this log?
After deleting it, where do I get the other log file to upload as you suggest?

Apologies if these are dumb questions, I am new to jitsi.