Allowing '@' in username for dovecot authentication?

I have resolved a number of issues but one remains. I need usernames to be passed to the dovecot authentication module with a domain included, such as ‘user@example.com’
I have found that only usernames without an ‘@’ symbol are allowed through. It’s not even getting to the authentication subsystem. Any tips appreciated.
Thanks,
Michael

According to mod_auth_dovecot codes, it’s needed to set realm and to enable auth_append_host.

I didn’t try it.

Hey thanks!
That helped me figure things out
It works, but you have to not put ‘user@hostname’ in the authentication field. That does not even send the auth request out.
You have to set realm and the boolean for append.
Problem is, then you are limited to the one realm. I have several domains- So what I want to do is modify the module to accept the domain put in to the authentication dialogue as realm and append realm only when no domain is appended.

Any pointers on what I have to modify to get that to work?
I don’t mind having to do some coding… I am new to this software though. I am C++ and Java programmer and new to LUA …
Thanks again!