Allow trailing slash in urls

Hi,

is there any way to allow trailing slash in Jitsi urls?

for instance : https://mysite.org/room1234/

Thanks by advance for your help.

Why ? What problem are you trying to address with this ?

If you let the trailing slash you are back to the welcom page

just try https://meet.jit.si/1234/ whereas without the last slash you access your room.

I added this in mysite nginx conf after server name :

rewrite ^/(.*)/$ /$1 permanent;

seems to work but I hope it won’t break anything else.

1 Like

I still don’t know why you want to do that.

Ohh,

I understand now your question.

We have an apache redirect that always put trailing slash.
I asked on stackoverflow how to remove them but I had no answer.
That’s why I ask this.

I will add the last message.

If you don’t know how to handle a GET request, you should look at NGINX.
Or rather on his config.
/etc/nginx/sites-enabled/your.domain.conf

Add these lines after other localhost, to process the request with a slash at the end.

location ~ /$ {

rewrite ^/(.*)/$ /$1 permanent;

}

Thanks and good luck.

1 Like