Allow moderators only with JWT token to skip Lobby

Hi all,

I’ve just updated to the latest version of Jitsi meet:

jitsi-meet/stable,now 2.0.6433-1 all [installed]
jitsi-meet-prosody/stable,now 1.0.5415-1 all [installed,automatic]
jitsi-meet-tokens/stable,now 1.0.5415-1 all [installed]
jitsi-meet-turnserver/stable,now 1.0.5415-1 all [installed,automatic]
jitsi-meet-web/stable,now 1.0.5415-1 all [installed,automatic]
jitsi-meet-web-config/stable,now 1.0.5415-1 all [installed,automatic]
jitsi-videobridge2/stable,now 2.1-570-gb802be83-1 all [installed,automatic]

and a strange behaviour happen. Users with JWT token that are trying to open a conference go through the lobby page, whereas in the previous version they were sent directly into the call (as it should be and I want it to be).
Has something changed? Are there new parameter to allow users with JWT token to bypass the lobby page and make only the guests go through it?

Thanks,

Gianluca

IIRC a participant cannot skip the lobby page although she has a token in my old setups too and this seems right to me. A participant should not connect to a private session although she has a token.

The strange thing is that with the previous version I had (I think 5142) the lobby was skipped by the users that were creating the room (through rocketchat that generates a link that embeds the JWT token) and the guest always went through the lobby.
Now it seems this has changed and lobby appears for everyone, even the moderator who is creating the room for the first time.
Are there any parameters to skip it?

I don’t have much experince in lobby and I never use it on production but AFAIK there is no such a parameter

Thanks @emrah. I wonder why, then, before upgrading it worked the way I wanted… @damencho do you have any idea?

How can the lobby appear for the person who is trying to create the meeting? Someone has to explicitly enable the lobby feature after creating a meeting unless the lobby has been programmatically customized to be automatically enabled on meeting creation. If so, this is not a Jitsi default and you should look at the customization.