Allow Controlled Entry - Notifications covering active Mic/Video at Entry

When entering a Jitsi videocall in a desktop browser, one is immediately admitted with the mic and video activated, and promptly one is battling with de-activating popup messages. For unknown design reasons, those popups tend to cover the mic/audio buttons.

While waiting for several popups to disappear one by one, the audience is inconvenienced by background noise or audio-loop (when using a second device on the call). It would certainly be user-friendly is one could actively prevent background noise disruptions by new joiners on a call.

  1. How can a user de-activate mic/video buttons on entry by default?

  2. How can a user avoid notifications from covering the mic/video buttons?

Thanks

Welcome to the forum!

I’m assuming you’re using the public instance of Jitsi at meet.jit.si. You can do all mic and video checks before entering a meeting. There’s a pre-login page (where you enter your username - and password, if required). While on that page, you can opt to disable your mic and video, so that way, you enter the meeting muted. This setting is saved in your browser cache so it stays that way for every Jitsi meeting you join till you clear out the cache.

1 Like

Hello Freddie, thank you. Yes, using Jitsi Meet in Chrome, Safari, Brave, Edge on different machines or smartphones.

The Settings that are accessible on the main page are allowing me to choose which devices to use for camera, mic, audio output, as well as the profile name and email, and language. But no default settings for mic/video nor is there a (pre-)login screen.

I realise now that the group I am using Jitsi with is self-hosting Jitsi. Would their server have any settings that could allow users to control their entry into a call and/or to customise popups so that they avoid overlapping the buttons?

AH, yes - if self-hosting, the admin can do all that. It sounds like they’ve disabled the pre-join page. This is what it looks like:

If they didn’t specifically disable it, then the meeting host can choose to enable it once they get into the meeting by going to Settings (from the three vertical dots on the lower right corner), then going to the “More” tab and enabling the pre-meeting screen:

Screen Shot 2021-01-05 at 1.30.38 PM

As per notifications covering your buttons, that’s unusual. Normally, those notifications show up in the lower-left corner of your screen which is an appreciable distance from your mic and camera control buttons (in the center). Maybe your screen is minimized? But again, in a self-hosted Jitsi instance, many of those notifications can be disabled.

I recommend checking out this user guide for an explanation of Jitsi’s functionalities - Comprehensive Jitsi User Guide

1 Like

Thank you, Freddie! Your kind answers are very useful.

Yes, I am using the screen at a width of 600 - 800 pixels depending on what is being discussed on the call while using or answering to messages on other platforms on the same machine.

When logging off from a call of 5-30+ people, I must close the browser or browser tab instead of pushing the red button, because the disconnect notifications that are firing at the end of a call are preventing access to my disconnect button.

I shall study the guide and get in touch with the self-host admin to make some tweaks to the notifications location. It should not conflict with important action buttons. Hopefully, we can also disable the entry-sound wooosh which can be distracting when there is in/outgoing traffic of attendees while someone is talking.

Thanks again!

You’re most welcome! Yes, all those concerns are addressable and those features are configurable.

Happy Jitsi-ing! :smiley:

1 Like