All meeting users are getting Black Screen when an mobile device is joining Jitsi meeting in our server

I follow the installation steps as shown in the quick-install.md

and I have also done the following configurations:

  • using Let’s Encrypt certificate
  • added to the file /etc/jitsi/videobridge/sip-communicator.properties for machine behind NAT (NAT_HARVESTER_LOCAL_ADDRESS & NAT_HARVESTER_PUBLIC_ADDRESS) and commented STUN_MAPPING_HARVESTER_ADDRESSES
  • edit /etc/systemd/system.conf
    DefaultLimitNOFILE=65000
    DefaultLimitNPROC=65000
    DefaultTasksMax=65000

At first all laptop users are able to login to the web conference using Google Chrome, everything is good, however all of us are getting black screen once an Android device has joined the conference (IPhone 7 and above are good except IPhone 6). Everything works properly on meet.jit.si for same device. Appreciate if someone could suggest us a solution for this issue. JitsiMeetJS.version 960eea3c50.

On the other hand, when I tried to install the earlier version (as shown below), no such problem, all mobile users are good (both Android and IOS)
apt-get install jitsi-meet-prosody=1.0.3216-1 jitsi-videobridge=1109-1 jitsi-meet=1.0.3548-1 jicofo=1.0-458-1 jitsi-meet-web=1.0.3216-1 jitsi-meet-web-config=1.0.3216-1 -y

1 Like

If you join with 3 desktop participants, does it work?

Hi Damian,

Yes, it works for 4-5 desktop users or more.

Best regards,

James

That is strange!

I have the same problem after update.
downgraded it and started working again

thx

Are those “mobile” devices iPhones?

Damn Apple

I think I am having this issue.

I’m still learning all of this. What is the best way of downgrading, so I can test?

Thanks

You can try the following 2 versions which are working for me (however these 2 versions have less feature compare to the latest one):

apt-get install jitsi-meet-prosody=1.0.3216-1 jitsi-videobridge=1109-1 jitsi-meet=1.0.3548-1 jicofo=1.0-458-1 jitsi-meet-web=1.0.3216-1 jitsi-meet-web-config=1.0.3216-1 -y

OR

apt-get install jitsi-meet-prosody=1.0.3729-1 jitsi-videobridge=1126-1 jitsi-meet=1.0.4101-1 jicofo=1.0-508-1 jitsi-meet-web=1.0.3729-1 jitsi-meet-web-config=1.0.3729-1 -y

Hi all, I am having the same issue. Installation of Production Jitsi server was done Apr.23.2020 on Ubuntu Server 18.04.04 LTS.

Any other suggestions? I rather not downgrade.
I can share our URL in private message if needed.

Thank you in advance.

I was able to figure this out. To add to this issue the other error was that when sharing a screen in a computer/laptop (no mobile) meeting the other participants would see an icon of a screen vs the initials like you always see when the video is off (on the center of the screen)

I added these lines from this guide as it has been recommended before on these forums:

I’ve seen this guide so many times but what was confusing is that it says this “…configure itself automatically on boot” so I ignored it but then, later on, checked it once quickly but didn’t look hard enough for the specific lines. Finally yesterday I went in and checked again this time paying actual attention and they were not there. So i added them and boom it’s done. works great :slight_smile: thank you Jitsi Team for building such an amazing software for us to use and enjoy :slight_smile:

Next step is adding sip for landline conference calling

FYI i also turned off my P2P a while back when was trying to figure this out and now its still off. not sure if that will make any difference if i turn it back on.

Can anyone point to me if this was solve? I am also having exact problem. Desktop or laptop no issue, but mobile devices no video and keep on connecting/disconnecting and a message saying “Unfortunately, something went wrong. Were trying blah blah bal, … reconnecting.”

me too… has anyone managed to find a solution to the mobile connecting with no audio or video and then disconnecting with problem?

I’m having this issue with Iphone safari browser users only!
all others - PC and android devices work fine.

going through the jvb logs i found that the jvb tries to return to the iphone’s local ip address - the one behind the service providers NAT address on the client side… 10.X.X.X and not the external cell provider… with PCs or android devices running chrome - the client ip address is the correct external side.

at first i thought it was a problem with the sip.properties NAT configs - but that was all setup correctly. this issue accurse even when i add a local hosted turn server based on coturn… all works fine except for safari web interface…

I then did another test… connecting to the jitsi server from a wifi AP added to the DC internal lan - and then averything worked fine.

i have no idea why iphone safari web interface has this NAT issue - on the client side…

any help would be greatly appreciated.