Al configurar "prejoinConfig", Jibri no funciona (no graba, no streaming)

Hola:

Muchas gracias por compartir sus experiencias, resultan de gran ayuda para todos nosotros quienes somos novatos. Como bien sabemos, Jitsi Meet + Jibri es muy útil. Personalmente lo utilizo en las reuniones de mi trabajo (institución sin fines de lucro).

Vamos al punto. Una vez instalado todo en nuestro servidor (Dell i7 (8 nucleos) + 16 Gb. RAM - Ubuntu Server 20.04 lts - Jitsi Meet + Jibri), al configurar en /etc/jitsi/meet/xxx.xxx.xx-config.js la función “prejoinConfig” (Configs for prejoin page), Jibri queda fuera de la sala virtual y no funciona.

// Configs for prejoin page.
prejoinConfig: {
// // When ‘true’, it shows an intermediate page before joining, where the user can configure their devices.
// // This replaces prejoinPageEnabled.
enabled: true,
// // List of buttons to hide from the extra join options dropdown.
// hideExtraJoinButtons: [‘no-audio’, ‘by-phone’]
},

Jibri no funciona (no graba, no streaming), porque queda fuera de la sala virtual de reuniones, es decir, no puede ingresar a la misma.

La solución es configurar “prejoinPageEnabled” y no “prejoinConfig”.

prejoinPageEnabled: true,

De esta forma, previamente cada usuario se identifica e ingresa y Jibri también se encuentra presente en la sala virtual, funcionando correctamente.

Ojalá esta información les sea de utilidad.

Bienvenido a la comunidad y gracias por compartir.

¿Qué pasa si lo configura así:

prejoinConfig: {
enabled: true
},

Creo que debería funcionar. Tiene una coma después del valor de la bandera en su configuración, por eso no funcionó para usted.

Hola Freddie.

Muchas gracias por la bienvenida y también, por contestar rápidamente mi comentario. Hice la prueba como indicas, sin embargo, la situación se mantiene. La sintaxis de la variable (bandera) considera la coma (,), pero aún eliminándola, el problema persiste.

prejoinConfig: {
enabled: true
},

Una vez que ingresas a la sala virtual, luego del “prejoin page” (ingresando el nombre), al intentar grabar o streaming, jibri no funciona. No genera ninguna acción (monitoreo con htop). Es como si no estuviera en la sala. Cambio a la variable (bandera) a " prejoinPageEnabled: true," y funciona perfectamente. Tal vez Jibri reconoce esta variable (bandera) más antigua, ingresando a la sala, no así con la nueva variable (bandera), que reemplaza a la anterior, pero que cumple exactamente la misma función.

Muchas gracias por la atención.

Interesante. Lo comprobaré más tarde en mi implementación de prueba. Gracias por denunciarlo.