After updating problem for joining annonymous guest on Jitsi Meet API with JWT

Hello,
I deployed jitsi meet in my own server with iframe API about a month ago and it was working quite well till yesterday. Today I updated my deployment to jitsi meet 2.0.8044. The problems started after update.

Currently after hosting the meeting, guest participants joining in the room does not see the moderator, nor the moderator sees him. If I host the meeting with disabling authentication, it works without problem. Recording also is not working while using JWT. The console is showing “AbstractStartRecordingDialog.js:365 Uncaught TypeError: Cannot read properties of undefined (reading ‘startRecording’)”.

Currently running
jitsi-meet 2.0.8044
jitsi-meet-prosody 1.0.6776
jitsi-meet-tokens 1.0.6776
jitsi-meet-web 1.0.6776
jitsi-videobridge2 2.2-61

jicofo config
jicofo {
authentication: {
enabled: true
type: JWT
login-url: conference.mydomain.com
}

xmpp: {
client: {
client-proxy: "focus.conference "
xmpp-domain: "conference "
domain: "auth.conference "
username: “focus”
password: “XXXX”
}
trusted-domains: [ "recording " ]
}
bridge: {
brewery-jid: "JvbBrewery@internal. auth. conference "
}

jibri {
brewery-jid = "JibriBrewery@internal. auth. conference "
pending-timeout = 90 seconds
}
}

prosody config:

VirtualHost "conference "
authentication = “token”;
app_id = “my-app-id”;
app_secret = “my-app-secret”;
allow_empty_token = true;

ssl = {
key = “/etc/prosody/certs/conference. key”;
certificate = “/etc/prosody/certs/conference. crt”;
}
av_moderation_component = "avmoderation. conference "
speakerstats_component = "speakerstats. conference "
conference_duration_component = "conferenceduration.conference "
end_conference_component = "endconference.conference "
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
“speakerstats”;
“external_services”;
“conference_duration”;
“end_conference”;
“muc_lobby_rooms”;
“muc_breakout_rooms”;
“av_moderation”;
“room_metadata”;
“token_verification”;
}
c2s_require_encryption = false
lobby_muc = "lobby.conference "
breakout_rooms_muc = "breakout.conference "
room_metadata_component = "metadata.conference "
main_muc = "conference.conference "

VirtualHost "guest.conference "
authentication = “anonymous”
c2s_require_encryption = false
modules_enabled = {
“bosh”;
“pubsub”;
“ping”;
“speakerstats”;
“turncredentials”;
“conference_duration”;
}
I had to cut mydomain.com from the configs as a new user cannot post more than 2 links.
Need the help from the forum. Thanks in advance.

Jibri’s recorder account should be in admins list in conference component.

Since you have already enabled allow_empty_token, you don’t need the guest virtualhost in prosody and enabled auth in jicofo

Thanks for your prompt reply.
Should I add jibri recorder in this section?

Component “conference.conference.mydomain.com” “muc”
restrict_room_creation = true
storage = “memory”
modules_enabled = {
“muc_meeting_id”;
“muc_domain_mapper”;
“polls”;
“token_verification”;
“muc_rate_limit”;
}
admins = { “focus@auth.conference.mydomain.com” }
muc_room_locking = false
muc_room_default_public_jids = true

Correct