After tuturia like install (without nginx or apache) no response on 443

Did the default install as in the tutorial video (thus with apache or nginx). But looks like something went wrong with the ssl installation.

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:5347          0.0.0.0:*               LISTEN      8915/lua5.1
tcp        0      0 0.0.0.0:5222            0.0.0.0:*               LISTEN      8915/lua5.1
tcp        0      0 0.0.0.0:5269            0.0.0.0:*               LISTEN      8915/lua5.1
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      1330/sshd
tcp        0      0 0.0.0.0:5280            0.0.0.0:*               LISTEN      8915/lua5.1
tcp        0      0 0.0.0.0:5281            0.0.0.0:*               LISTEN      8915/lua5.1
tcp        0      0 127.0.0.1:5347          127.0.0.1:37472         ESTABLISHED 8915/lua5.1
tcp        0    296 192.168.122.74:22       192.168.122.22:46150    ESTABLISHED 1687/sshd: marc [pr
tcp        0      0 127.0.0.1:5347          127.0.0.1:37470         ESTABLISHED 8915/lua5.1
tcp        0      0 127.0.0.1:5222          127.0.0.1:53526         ESTABLISHED 8915/lua5.1
tcp6       0      0 ::1:5347                :::*                    LISTEN      8915/lua5.1
tcp6       0      0 :::5222                 :::*                    LISTEN      8915/lua5.1
tcp6       0      0 :::5269                 :::*                    LISTEN      8915/lua5.1
tcp6       0      0 :::22                   :::*                    LISTEN      1330/sshd
tcp6       0      0 :::8888                 :::*                    LISTEN      6201/java
tcp6       0      0 192.168.122.74:443      :::*                    LISTEN      6028/java
tcp6       0      0 :::5280                 :::*                    LISTEN      8915/lua5.1
tcp6       0      0 :::5281                 :::*                    LISTEN      8915/lua5.1
tcp6       0      0 127.0.0.1:37472         127.0.0.1:5347          ESTABLISHED 6028/java
tcp6       0      0 127.0.0.1:53526         127.0.0.1:5222          ESTABLISHED 6201/java
tcp6       0      0 192.168.122.74:443      192.168.122.42:16680    TIME_WAIT   -
tcp6       0      0 127.0.0.1:37470         127.0.0.1:5347          ESTABLISHED 6201/java

lynx

Looking up 192.168.122.74
Making HTTPS connection to 192.168.122.74
Alert!: Unable to make secure connection to remote host.

lynx: Can't access startfile https://192.168.122.74/

Also test with openssl fails

root@meet:/var/log/jitsi# openssl s_client -connect 192.168.122.74:443 -tls1_2
CONNECTED(00000003)


140139101935256:error:1409E0E5:SSL routines:ssl3_write_bytes:ssl handshake failure:s3_pkt.c:656:
---
no peer certificate available
---
No client certificate CA names sent
---
SSL handshake has read 0 bytes and written 0 bytes
---
New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
    Protocol  : TLSv1.2
    Cipher    : 0000
    Session-ID:
    Session-ID-ctx:
    Master-Key:
    Key-Arg   : None
    PSK identity: None
    PSK identity hint: None
    SRP username: None
    Start Time: 1585091111
    Timeout   : 7200 (sec)
    Verify return code: 0 (ok)

How to fix this? Maybe just revert back temporary to :80?