After reading all the related topics I can't add more than 2 people to a conference

Hi there!!!

first of all thank you so much for such a wonderful work as jitsi, moreover in these turmoil times.

I have installed Jitsi in a debian 10 server at my domestic network in an Intel NUC hardware, set the certificates, and get it to work with two people, however ( and it seems I am not the only one) as soon as other invitee enters the room video and audio drops.

Before starting a topic I have been reading all the topics related and tried everything I found here, trying to add the advanced configuration for NAT with the internal and public address , set the jvb host values, forwarded the ports (including 5347), add host and hostname,
Changed:

// requireDisplayName: true,

to

requireDisplayName: true,

Added:

org.jitsi.jicofo.auth.URL=XMPP:jitsi.external-domain.com

nano /etc/jitsi/videobridge/sip-communicator.properties

Added:

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=internal.IP

org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=public.IP

and after more than 10 hours trying different changes I have seen here, I thought it might be a good idea to ask for help :)))

This is how everything looks like now

  • hosts and hostnames

    root@dappnodelbh:/etc# cat hosts
    127.0.0.1 localhost
    127.0.1.1 dappnodelbh.shelpin.com dappnodelbh
    ::1 localhost ip6-localhost ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    127.0.0.1 localhost seeya.noncentralconf. com (added spaces in links because of restrictions for new users)

    The following lines are desirable for IPv6 capable hosts

    ::1 localhost ip6-localhost ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters

root@dappnodelbh:/etc# cat hostname

dappnodelbh

seeya.noncentralconf. com

root@dappnodelbh:/etc#

  • jvb sip.communicator

org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.seeya.noncentralconf. com/.*

I changed this one after including the advanced NAT config because it seem to be preventing even the 2 people conference to crash (kicks out both)

  • Videobridge config file

root@dappnodelbh:/etc/jitsi/videobridge# cat config

Jitsi Videobridge settings

sets the XMPP domain (default: none)

JVB_HOSTNAME=seeya.noncentralconf. com

sets the hostname of the XMPP server (default: domain if set, localhost otherwise)

JVB_HOST=

sets the port of the XMPP server (default: 5275)

JVB_PORT=5347

sets the shared secret used to authenticate to the XMPP server

JVB_SECRET=XXXXXXX

extra options to pass to the JVB daemon

JVB_OPTS=""

adds java system props that are passed to jvb (default are for home and logging config file)

JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=videobridge -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/videobridge/logging.properties"

root@dappnodelbh:/etc/jitsi/videobridge#

I also removed after trying --apis=xmpp,rest from the JVB opts as it also seemed to make it crash for 2 people calls.

  • Jicofo config file

Jitsi Conference Focus settings

sets the host name of the XMPP server

JICOFO_HOST=localhost

sets the XMPP domain (default: none)

JICOFO_HOSTNAME=seeya.noncentralconf. com

sets the secret used to authenticate as an XMPP component

JICOFO_SECRET=XXXXXXX

sets the port to use for the XMPP component connection

JICOFO_PORT=5347

sets the XMPP domain name to use for XMPP user logins

JICOFO_AUTH_DOMAIN=auth.seeya.noncentralconf. com

sets the username to use for XMPP user logins

JICOFO_AUTH_USER=focus

sets the password to use for XMPP user logins

JICOFO_AUTH_PASSWORD=XXXXXX

extra options to pass to the jicofo daemon

JICOFO_OPTS=""

adds java system props that are passed to jicofo (default are for home and logging config file)

JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties"

  • jicofo sip communicator properties

org.jitsi.jicofo.auth.URL=XMPP:seeya.noncentralconf. com

  • How chrome://webrtc looks like

Any help about what could be happening or any direction of anything that is not correctly configured in the screenshots sent would be highly appreciated.

Thanks!!!

Your jvb is not advertising your public address:


Latest stable should autodiscover those, the previous one required manual setting private and public address.

1 Like

Thanks a lot @damencho !! My problem with adding the lines mentioned in the advanced configuration with the internal and public address in the jvb sip.communicator file is that rather than losing audio / video when a third participant joins, even two participants, get immediately disconnected… I will keep trying, I do not have a tech background , just love to improve my skills installing for yself software that I love following tutorials and throwing stones to whatever issue I find because of my limited tech knowledge until I make it work… I will try again. Thank you so much for your hyperfast response!! I will add again the private and public address in these lines and restart jvb and jicofo and see what happens.

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>

I added back the two lines above mentioned with my public and internal address, restarted prosody,jvb and jicofo and still the same , then I made a reinstall to get the latest stable version and check if it worked and still the same, added the --apis=xmpp,restvalue in the JVB_OPTS and tried to restart prosody , jvb and jicofo… but jvb cant be restarted , I got this message … root@dappnodelbh:/etc/jitsi/videobridge# service jitsi-videobridge restart Failed to restart jitsi-videobridge.service: Unit jitsi-videobridge.service is masked. then restarted jicofo…but still when the third participant comes in audio and video comes out…i am considering uninstalling it and start from scracht… but I am not sure if the ssl certificate gets also deleted and I have to generate a new one or I can select the option Select an existing certificate and use the one I got in the first (this) installation…still if you think that I might help you find something i will wait to uninstall it and will be happy to help if you think there is anything to debug. Thanks!!

How did you add the address:
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<192.16.0.0> or org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=192.16.0.0.
The first one is wrong.

1 Like

First one… :see_no_evil:…Thanks a lot @damencho … that was probably all the problem.I have done it but multiconf is still not working, probably because I have not retarted jvb, only prosody and jicofo… is there any way to restart the service in the latest stable release? when doing it with service jitsi-videobridge restart it says that the restart fails because of the service being masked.Thanks a lot for your patience with this newbie. <3

service jitsi-videobridge2 restart

1 Like

Thanks!! You just caught me keeping on trying :)))

I just got the third user in!!! after 4 days and countless hours, I got it thanks to your invaluable help!!! I am so f…g happy adn grateful now!! <3

1 Like

I got too much confident and I went to secure the domain, I followed the steps in the jicofo repo, but I got an error at the creation of an account

root@dappnodelbh:/etc/jitsi/jicofo# prosodyctl register alex $JITSI_DOMAIN XXXXXXXX
Enter new password: 
Retype new password: 
The given hostname does not exist in the config
root@dappnodelbh:/etc/jitsi/jicofo# export JITSI_DOMAIN="seeya.noncentralconf.com"
root@dappnodelbh:/etc/jitsi/jicofo# prosodyctl register alex $JITSI_DOMAIN XXXXXXXXXX
Error: Account creation/modification not supported.
root@dappnodelbh:/etc/jitsi/jicofo# prosodyctl register alex seeya.noncentralconf.com XXXXXXXXX
Error: Account creation/modification not supported.
root@dappnodelbh:/etc/jitsi/jicofo# prosodyctl register ncc seeya.noncentralconf.com XXXXXXXX
Error: Account creation/modification not supported.
root@dappnodelbh:/etc/jitsi/jicofo# service jicofo restart
root@dappnodelbh:/etc/jitsi/jicofo# service jitsi-videobridge2 restart
root@dappnodelbh:/etc/jitsi/jicofo# service prosody restart

When i tried to enter i saw a grey screen and no way of accessing or creating rooms, just a grey screen, so reverted the changes made in /etc/prosody/conf.avail/[your-hostname].cfg.lua) and /etc/jitsi/meet/[your-hostname]-config.js) and got to access again to the interface but now it is asking me for a password not only to create the rooms but also to access them. I tried the account that I tried to create previously and it thrown “incorrect password” and now I can`t enter the rooms I created before trying to secure the domain nor create new ones, as no password is being accepted. :see_no_evil:

How could I revert the changes and leave it opened again?

I promise it is the last time i bother you, I will just leave it open without password and stop being awake until 4 AM trying to setup things that I do not really control :slight_smile:

Also if you accept donations in cryptocurrency I would like to send you a small contribution as a way of appreciation for your work and support. Thanks a lot!!

Hi!! anyone else than @damencho knows how to revert the securing of the domain please :pray: ? I guess he is tired of supporting me (and I completely understand :smiley:).

Now I have a so secure domain that not even myself is capable of using it… :see_no_evil: I reverted all the changes made in /etc/prosody/conf.avail/[your-hostname].cfg.lua and /etc/jitsi/meet/[your-hostname]-config.js but it still asks me for a password. Thanks a lot!!

I found it!!! , when reverting the changes I did not changed “internal:plain” to anonymous , problems of the night … forget about it @damencho , thanks a lot !! and please let me know if you have any crypto address to send some love

I have a similar issue! It all started after the latest update. It was working perfectly fine until now. I have setup prosody and internal:plain no issues with authentication. My problem is that not more than 2 people can join. As soon as the third person joins everyone loses audio and video. I was thinking it has something to do with the authentication so I went in and reverted changes to /etc/prosody/conf.avail/[your-hostname].cfg.lua and /etc/jitsi/meet/[your-hostname]-config.js and set the authentication to anonymous but it still asks me for a password

can anyone help please!?

Here’s the config on /etc/prosody/conf.avail/meet.jitsi.test.com.cfg.lua

plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

– domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = “meet.jitsi.test.com”;

turncredentials_secret = “haUXwk4iZAwB3wcD1123122131231231”;

turncredentials = {
{ type = “stun”, host = “meet.jitsi.test.com”, port = “4446” },
{ type = “turn”, host = “meet.jitsi.test.com”, port = “4446”, transport = “udp” },
{ type = “turns”, host = “meet.jitsi.test.com”, port = “443”, transport = “tcp” }
};

cross_domain_bosh = false;
consider_bosh_secure = true;

– we are going to be proxying the BOSH connection anyway, so there is no need to $
https_ports = { }

VirtualHost “meet.jitsi.test.com
– enabled = false – Remove this line to enable this host
authentication = “anonymous”
– Properties below are modified by jitsi-meet-tokens package config
– and authentication above is switched to “token”
–app_id=“example_app_id”
–app_secret=“example_app_secret”
– Assign this host a certificate for TLS, otherwise it would use the one
– set in the global section (if any).
– Note that old-style SSL on port 5223 only supports one certificate, and$
– use the global one.
ssl = {
key = “/etc/prosody/certs/meet.jitsi.test.com.key”;
certificate = “/etc/prosody/certs/meet.jitsi.test.com.crt”;
}
speakerstats_component = “speakerstats.meet.jitsi.test.com
conference_duration_component = “conferenceduration.meet.jitsi.test.com
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping`

my etc/jitsi/jicofo/sip-communicator.properties

org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.meet.jitsi.test.com
org.jitsi.jicofo.auth.URL=XMPP:meet.jitsi.test.com

my /etc/jitsi/videobridge/sip-communicator.properties

org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=10.2.219.219
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=x.x.x.x
#org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.meet.jitsi.test.com
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=Y8F9Bgwv
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.meet.jitsi.test.com
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=fc391dc2-6abe-4a78-b144-fa557d8aa0b5

I had same issue and it took me 4 days and real help from @damencho to get it sorted. I promised @damencho that I will return the favour in the community, so here I am.

You need to make sure that port 1000 on UDP is open and it does not matter if you have opened it or not, you need to confirm if it is actually open and working as expected.

So here is a small test - do the following and let me know how it went for you:

On the main server (where jitsi is hosted) type following commands:
sudo service jitsi-videobridge2 stop
nc -l 10000 -u

While you are waiting for the cursor to return, after the 2nd command, go on to another facing which is not within the same network and is internet facing (think this machine as a client who will use your service from outside your network) and here type this command:

echo “Test” | nc -u 10000

this should show a message “Test” on your server…

If you don’t get Test message on the Server, your port is NOT open. So get that sorted first before we troubleshoot anything else any further. 90% chances are this fix will fix your core issue - be able to get 3 way video chat

Now if you are struggling with the port forwarding to work, let me know which firewall you are using and how you do the port forwarding and we can take it from there.

Hope this helps.

Many Thanks,
Rav