After Quick install "You have been disconnected." "Rejoin now" ~2 minute loop

I did an install of nginx

I did an exact quick install like in the tutorial, used the recommended ubuntu lts version. Also put my ip and hostname in /etc/hosts

‘local’ access to the meet website results in this loop, remote access via nat results in this loop.

cat jicofo.log |grep -v INFO

Only shows
SEVERE: [16] org.jitsi.jicofo.discovery.DiscoveryUtil.discoverVersion().200 Failed to discover version
WARNING: [16] org.jitsi.jicofo.BridgeSelector.log() No pub-sub node mapped for

videobrdige logs show
WARNING: [13] org.jitsi.videobridge.EndpointMessageTransport.log() No available transport channel, can’t send a message
WARNING: [13] org.jitsi.videobridge.EndpointMessageTransport.log() SCTP connection with e8b19a5afed66d8b not ready yet.

Interesting is:

  • when both clients access the same /test room, they show only one member.
  • Nat client reloads every ~2 min
  • Internal client reload every ~35 s

Exact same issue, exact same logs…

Maybe check the javascript console

I have this: (you should be able to disable cors in ff, but it is still listed)
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://xx.xx.xx/http-bind?room=test. (Reason: CORS disabled).

Yes that is it. I am doing port forwarding into the test environment if you do something like this it is not going to work
–dport 444 -j DNAT --to-destination 192.168.122.74:443
(unless of course when you change the configs, I assume)

Your are right: changing -dport for 443 and it works.
What changes do I have to do to use 444 instead of 443 ?

Just add
listen 444 ssl;
To your nginx config in /etc/nginx/sites-enabled/

And maybe this change too:
add the 444 port to the bosh url in your config.js at
/etc/jitsi/meet/

I’m not unsing nginx or apache. So I guess, it’s using prosody, right ?
Actually, I changed every 443 values in /etc/jitsi/videobridge/sip-communicator.properties + the bosh url, I’m now able to connect with 444 port, but I can’t start video, same behavior as before. I did a capture in client side, it’s still trying to reach port 443.