After putting the password and username to create a meeting, i am getting reconnecting error

Hi Zaman,

Welcome to the community.

Could you please provide a bit more detail. For example is this on your own hosted Jitsi sever installation? Or on a Jitsi server hosted by others?

If it is your own hosted Jitsi sever installation, please let us know more about what instructions you followed and what you have checked. For example firewalls and opened ports.

Check the js console for errors.

I am using my own digital ocean server. and here is the instruction link i followed.

Here are the both screens before and after putting the username and password

!)

Check your jicofo logs for errors.

A few thoughts which may help you:

  1. What type of SSL certificate did you use? The link you provided, in " Step 4 — Obtaining a Signed TLS Certificate", uses a LetsEncrypt certificate, but the image you posted indicates that your web site is unsecured? If you installation was successful in using a LetsEncrypt certificate, your web site should be secured.

  2. are you using a registered Internet domain name? As far as I know LetsEncrypt will not work without one.
    I do not know if your using Apache2 or Nginx. I use Apache2, and to get LetsEncrypt to work for me I needed to add this to my apache2 jitsi.mydomain.com conf file.

    AliasMatch /.well-known/acme-challenge/(.*)$ /usr/share/jitsi-meet/.well-known/acme-challenge/$1
    <Directory /usr/share/jitsi-meet/.well-known/acme-challenge>
       AllowOverride None
       Require all granted
    </Directory>

FYI: My configuration also required the following for Websockets to work correctly.

    ProxyPreserveHost on
    ProxyPass /http-bind http://localhost:5280/http-bind/
    ProxyPassReverse /http-bind http://localhost:5280/http-bind/
    ProxyPass /xmpp-websocket ws://localhost:5280/xmpp-websocket
    ProxyPassReverse /xmpp-websocket ws://localhost:5280/xmpp-websocket
    ProxyPass /colibri-ws/default-id ws://localhost:9090/colibri-ws/default-id
    ProxyPassReverse /colibri-ws/default-id ws://localhost:9090/colibri-ws/default-id
  1. I noticed the site you linked had different ports for the firewall.
    Please review the below instructions and see if you may have missed any important steps. I recommend following the firewall instructions from the below link.
    Self-Hosting Guide - Debian/Ubuntu server · Jitsi Meet Handbook

I am using the domain name not the IP address.
I am using the let’s encrypt and that’s the issue as well. But will resolve that. The main query is the password and username issue.
I am using Nginx.
The port is the same as i have provided you the link for setup.

if you are using a recent version of Jitsi-meet, it’s better to use an up-to-date install instruction such as this one as external guides tend to not be updated while software changes. If you don’t use an existing setup (existing web server) it’s better to scratch everything with something like:

sudo apt purge jitsi-meet jitsi-meet-web jitsi-meet-prosody jitsi-meet-web-config ca-certificates-java java-common openjdk-8-jre-headless openjdk-11-jre-headless jitsi-videobridge2 jicofo coturn jitsi-meet-turnserver prosody certbot
sudo apt autoremove
and reboot

and start again from the one true book ™
Once it’s done test your connectivity using this:

(server)
sudo systemctl stop jitsi-videobridge2
nc -l 10000 -u
(workstation)
echo "123" | nc -u (your public address) 10000

if all this works, your basic server should work. All that will remain is to upgrade Prosody to use latest functionality.

Hi zaman,

The others should be able to help you far me than I can, but I wanted to let you know these things:

  1. I needed the following instructions to help me, and some parts are either confusing or missing detail.
    Debian 10, Apache2 web server jitsi-meet installed using:
    Ubuntu/Debian Installation Instructions & Repository
    Self-Hosting Guide - Debian/Ubuntu server · Jitsi Meet Handbook
    jitsi-meet/jitsi-meet.example-apache at master · jitsi/jitsi-meet · GitHub

  2. I found the apache2 jitsi-meet installation script did not add to jitsi’s apache2 jitsi.mydomain.com.conf file the needed letsencrypt and websockets sections. Though I think you have worked this out yourself. I would recommend comparing your equivalent of jitsi.mydomain.com.conf with the jitsi-meet.example-apache example above. For me, this example was important for websockets and Letsencrypt to work.

  3. Letsencrypt only worked for me if port 80 (and of course port 443) were available to my jitsi instance. At first I did not realise that port 80 was required by Letsencrypt.

  4. Ensuring these ports are open and are available is very important (and they are the only ports I needed to be open, I say this because I kept getting confused about 4443, which is not needed if you are using port 443):

22/tcp  (for your access to the server only, not required by Jitsi)
80/tcp
443/tcp
10000/udp
3478/udp
5349/tcp
  1. because I was behind a NAT firewall [and/or] my jitsi servers internal IP was different to the external IP, I needed the following:

The following extra lines need to be added to the file /etc/jitsi/videobridge/sip-communicator.properties :

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>

And comment the existing org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES .