After latest update, video not stable

Hello!

I am running Jitisi on a debian server (v10). I recently installed the latest jitsi update and since, I have trouble with the video. During a video conference, we are losing the video for few seconds (black screen) and it comes back. It’s the same behavior whatever the browser / pc/mac/smartphone / different network connection.
Any idea of what could be the issue? Any help would be appreciated :slight_smile:

Thx!

Your problems may come from the bandwidth estimation; this has been enhanced but configuration has been made more complex and with upgrades some parts may need manual update. First make sure that JVB websockets are working correctly (you should see the dominant speaker change in the participants pane). If they don’t work, it’s your priority; see here (although it seems that the troubleshooting section may not be up-to-date) and here

If websockets are all right, make sure that bandwidth estimation is set in config.js:
enableTcc: true,

if your jvb.conf has a bwe line, make sure that it’s set to true.

Thx for your reply.

It looks like the websocket are not working. In console, I see the following when I launched a new video conference:

2021-11-22T14:05:27.695Z [modules/xmpp/XmppConnection.js] <u._maybeEnableStreamResume>: Stream resume enabled, but WebSockets are not enabled

My configuration:

  • in jvb.conf:
videobridge {
    http-servers {
        public {
            port = 9090
        }
    }
    websockets {
        enabled = true
        domain = "mydomain.com:443"
        tls = true
    }
}

Port 9090 and 443 opened in my firewall.

For the FAQ link, you sent, it’s related to nginx. I am using Apache so not sure it’s relevant? I checked the /etc/prosody/conf.avail/your-conf.cfg.lua and the turns port is set to 443.

Any advice?
Thx!

irrelevant, not the same type of websockets. I have given you an easy way of testing if they are working, you can as wel use it I think.

obviously it’s not the same configuration for Apache but websockets are necessary in all cases. Your configuration should take inspiration from this instead.

Irrelevant.

@gpatel-fr,

Thx for your help. I was missing proxy entries for wss in the apache config and I had to enable the proxy_wstunel module. After restarting apache, this seems to better work :slight_smile:

Finally it did not solved the problem. I found other topics on the forum about the same issue and this was also present on the meet.jit.si. No solution yet. I have finally reverted to the previous version of jitsi I had, which is working correctly.

Pitty :frowning: