After intallation of jitsi, i still see the nginx homepage

Hi i have installed the jitsi with cloudflare dns and universal ssl and server in nginx with ubuntu. and i try navigation to the url with https still it shows the nginx homepage

Use https instead of http…

yup im using https but still its redirecting to nginx homepage

Ok. Are all services up and running?
Firewall open according to quick install guide?

Try restarting nginx once, if not done already.

jitsi service will be jitsi-videobridge2 and jicofo both of its up and i have restarted the nginx also. but in the services will there be something jitsi-meet ? because i cannot find it in the services

i have disable the firewall already will that cause a problem? because this server is just for testing and dev process only so security wont be a matter for now

nginx needs to be installed before jitsi. Yes, there should be jitsi-meet running too.

You need to reinstall. You may give it a try using below script or do it manually. And firewall disabling shouldn’t be an issue .

thank you @Prashanth i will try this solution and will let you know in the comment.

Mention that your setup is different, nginx is not doing ssl termination and your config is wrong, all jitsi-meet logic is in the ssl part where you use the http one

Reinstall will not help, you need either revert ssl termination to the nginx or configure nginx according to your customization