After installing jitsi-meet-tokens No audio - No Video

Hello, Firstly let me thank everyone for being so supportive around here there have been many useful posts! Unfortunately my specific situation has not come up. I hope that someone is able to help me as I am loosing my mind over this, its been three days trying to resolve the issue.

The Issue
I am able to install jitsi-meet no issues everything works as expected - However I require that I can restrict access and pass in profile data. After installing jitsi-meet-tokens I am able to pass in the profile deatils in the JWT as described here, this poplutaes the profile data when passed as ?jwt=eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJjb250ZXh0Ijp7InVzZXIiOnsiYXZhdGFyIjoiaHR0cHM6Ly9jZG4xLnZlY3RvcnN0b2NrLmNvbS9pLzEwMDB4MTAwMC81MS8wNS9tYWxlLXByb2ZpbGUtYXZhdGFyLXdpdGgtYnJvd24taGFpci12ZWN0b3ItMTIwNTUxMDUuanBnIiwibmFtZSI6IkpvaG4gRG9lIiwiZW1haWwiOiJqZG9lQGV4YW1wbGUuY29tIiwiaWQiOiJhYmNkOmExYjJjMy1kNGU1ZjYtMGFiYzEtMjNkZS1hYmNkZWYwMWZlZGNiYSJ9LCJncm91cCI6ImExMjMtMTIzLTQ1Ni03ODkifSwiYXVkIjoiaml0c2kiLCJpc3MiOiJrOEQzVU00UzJKZ0UiLCJzdWIiOiJob3RjYW1zLmhvdHdpZmluZy5jby51ayIsInJvb20iOiIqIiwiZXhwIjoxNTAwMDA2OTIzfQ.ur4uv2Ea98uhUExQo8YdmolEcPAyDPKC9grG0r2Ov74

However the video and audio now no longer work at all! There are no console errors upon pressing the video and audio buttons.

I have tried to install on;
UBUNTU 18.04
UBUNTU 16
DEBIAN 9

With prosody-trunk_1nightly747

Now I am clearly doing something wrong however I cannot see what. Below are the error logs;

Error jvb.log

   org.jivesoftware.smack.sasl.SASLErrorException: SASLError using SCRAM-SHA-1: not-authorized
at org.jivesoftware.smack.SASLAuthentication.authenticationFailed(SASLAuthentication.java:292)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1100)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.lang.Thread.run(Thread.java:748)

Error prosody.err

ar 29 21:36:13 c2s55e6ad7f1bf0 error Traceback[c2s]: /usr/lib/prosody/modules/mod_posix.lua:123: bad argument #3 to ‘format’ (string expected, got nil)
stack traceback:
[C]: in function ‘format’
/usr/lib/prosody/modules/mod_posix.lua:123: in function ‘?’
/usr/lib/prosody/util/logger.lua:46: in function </usr/lib/prosody/util/logger.lua:44>
(tail call): ?
(tail call): ?
…jitsi-meet/prosody-plugins/mod_muc_domain_mapper.lua:90: in function ‘?’
/usr/lib/prosody/util/filters.lua:24: in function ‘filter’
/usr/lib/prosody/core/sessionmanager.lua:35: in function ‘send’
/usr/lib/prosody/modules/mod_saslauth.lua:295: in function ‘?’
/usr/lib/prosody/util/events.lua:78: in function </usr/lib/prosody/util/events.lua:74>
(tail call): ?
/usr/lib/prosody/core/stanza_router.lua:149: in function ‘core_process_stanza’
/usr/lib/prosody/modules/mod_c2s.lua:254: in function ‘func’
/usr/lib/prosody/util/async.lua:90: in function </usr/lib/prosody/util/async.lua:88>

Error prosody.log

Mar 29 21:37:13 c2s55e6ad81f5c0 error Traceback[c2s]: /usr/lib/prosody/modules/mod_posix.lua:123: bad argument #3 to ‘format’ (string expected, got nil)
stack traceback:
[C]: in function ‘format’
/usr/lib/prosody/modules/mod_posix.lua:123: in function ‘?’
/usr/lib/prosody/util/logger.lua:46: in function </usr/lib/prosody/util/logger.lua:44>
(tail call): ?
(tail call): ?
…jitsi-meet/prosody-plugins/mod_muc_domain_mapper.lua:90: in function ‘?’
/usr/lib/prosody/util/filters.lua:24: in function ‘filter’
/usr/lib/prosody/core/sessionmanager.lua:35: in function ‘send’
/usr/lib/prosody/modules/mod_saslauth.lua:295: in function ‘?’
/usr/lib/prosody/util/events.lua:78: in function </usr/lib/prosody/util/events.lua:74>
(tail call): ?
/usr/lib/prosody/core/stanza_router.lua:149: in function ‘core_process_stanza’
/usr/lib/prosody/modules/mod_c2s.lua:254: in function ‘func’
/usr/lib/prosody/util/async.lua:90: in function </usr/lib/prosody/util/async.lua:88>

If there is anyone who can please offer any advice I would be externally grateful - This is the last peice of my puzzle once JWT is working I will be able to use jitsi meet. I thank you in advance for you help.

Many thanks

1 Like

Same issue here! If you find a solution please post it!!!

Hey, yeah I sure will do. Same applies, good luck.

I think I’ve fixed it. Take a look here.

i see below errors after setting up jwt token authentication on ubuntu 18.04 , no audio and vedio and the jitsi services getting restart frequently though followed above step.

May 14 14:07:02 c2s55cefad20ab0 error Traceback[c2s]: /usr/lib/prosody/modules/mod_posix.lua:123: bad argument #3 to ‘format’ (string expected, got nil)
stack traceback:
[C]: in function ‘format’
/usr/lib/prosody/modules/mod_posix.lua:123: in function ‘?’
/usr/lib/prosody/util/logger.lua:46: in function </usr/lib/prosody/util/logger.lua:44>
(tail call): ?
(tail call): ?
…jitsi-meet/prosody-plugins/mod_muc_domain_mapper.lua:90: in function ‘?’
/usr/lib/prosody/util/filters.lua:24: in function ‘filter’
/usr/lib/prosody/core/sessionmanager.lua:35: in function ‘send’
/usr/lib/prosody/modules/mod_saslauth.lua:295: in function ‘?’
/usr/lib/prosody/util/events.lua:78: in function </usr/lib/prosody/util/events.lua:74>
(tail call): ?
/usr/lib/prosody/core/stanza_router.lua:149: in function ‘core_process_stanza’
/usr/lib/prosody/modules/mod_c2s.lua:254: in function ‘func’
/usr/lib/prosody/util/async.lua:90: in function </usr/lib/prosody/util/async.lua:88>
May 14 14:07:17 c2s55cefad20ab0 info Client disconnected: connection closed
May 14 14:07:22 conference.intraedge.awsmsdemo.intraedge.net:muc_domain_mapper warn Session filters applied
May 14 14:07:22 c2s55cefa68ea10 info Client connected
May 14 14:07:23 c2s55cefa68ea10 info Stream encrypted (TLSv1.2 with ECDHE-RSA-AES256-GCM-SHA384)
May 14 14:07:23 c2s55cefa68ea10 info Authenticated as focus@auth.intraedge.awsmsdemo.intraedge.net
May 14 14:07:23 c2s55cefa68ea10 error Traceback[c2s]: /usr/lib/prosody/modules/mod_posix.lua:123: bad argument #3 to ‘format’ (string expected, got nil)
stack traceback:

Installed below listed package versions

jitsi-meet-tokens/stable,now 1.0.4074-1 all [residual-config]
prosody/bionic,now 0.10.0-1build1 amd64 [residual-config]
prosody-trunk/now 1nightly747-1~xenial amd64 [installed,local]
jitsi/stable 2.10.5550-1 amd64