After install: Uncaught SyntaxError: Unexpected token '<'

Hello
hopefully someone is willing pointing me into the right direction.
I followed official instructions to install jitsi meet

I used this example file to integrate jitsi into my nginx configuration:

Everything seems to run fine, but when accessing the jitsi domain I’m only getting a grey screen. This is the console output:

(index):141 Uncaught SyntaxError: Unexpected token '<'

Logger.js:125 [modules/browser/BrowserCapabilities.js] : This appears to be chrome, ver: 78.0
LocalStatsCollector.js:22 The AudioContext was not allowed to start. It must be resumed (or created) after a user gesture on the page. https://goo.gl/7K7WLu
(anonymous) @ LocalStatsCollector.js:22
n @ bootstrap:19
(anonymous) @ index.js:122
(anonymous) @ statistics.js:766
n @ bootstrap:19
(anonymous) @ JitsiConferenceEventManager.js:1
(anonymous) @ JitsiConferenceEventManager.js:664
n @ bootstrap:19
(anonymous) @ JitsiConnection.js:164
(anonymous) @ JitsiConference.js:3177
n @ bootstrap:19
(anonymous) @ JitsiConnection.js:1
n @ bootstrap:19
(anonymous) @ index.js:3
(anonymous) @ JitsiMeetJS.js:123
n @ bootstrap:19
(anonymous) @ index.js:3
n @ bootstrap:19
(anonymous) @ bootstrap:83
(anonymous) @ bootstrap:83
(anonymous) @ universalModuleDefinition:9
(anonymous) @ universalModuleDefinition:1
AuthHandler.js:18 Uncaught ReferenceError: config is not defined
at Object. (AuthHandler.js:18)
at Object. (AuthHandler.js:229)
at n (bootstrap:19)
at Object. (connection.js:1)
at Object. (connection.js:189)
at n (bootstrap:19)
at Object. (conference.js:1)
at Object. (conference.js:2833)
at n (bootstrap:19)
at Module. (DropdownItemGroup.js:36)
at n (bootstrap:19)
at bootstrap:83
at bootstrap:83
(anonymous) @ AuthHandler.js:18
(anonymous) @ AuthHandler.js:229
n @ bootstrap:19
(anonymous) @ connection.js:1
(anonymous) @ connection.js:189
n @ bootstrap:19
(anonymous) @ conference.js:1
(anonymous) @ conference.js:2833
n @ bootstrap:19
(anonymous) @ DropdownItemGroup.js:36
n @ bootstrap:19
(anonymous) @ bootstrap:83
(anonymous) @ bootstrap:83
configLanguageDetector.js:22 Uncaught ReferenceError: config is not defined
at Object.lookup (configLanguageDetector.js:22)
at index.js:111
at Array.forEach ()
at e.value (index.js:109)
at t.value (i18next.js:2016)
at u (i18next.js:1868)

I saw some similar reports, but it looks like this is a different problem than reported before?
This is Ubuntu 18.04.

I suspect you don’t have ssi(server side includes) turned on.

in the example nginx configuration I adopted, there is:
ssi = on;

So it should be enabled?

the config file is here
/etc/jitsi/meet/jitsi.mydomain.biz-config.js

I didn’t touch it at all yet.

So you still think it’s about ssi? I’m running Cloudflare in front of it should be mentioned.

Do you see config.js included in the result index.html? Or you see the ssi directive there?

sorry I’m quite new to this. Would you please mind to elaborate what you mean by the “result index.html”?

Best regards

When you open the html source of the page in Chrome it is View -> Developer -> View Source.
It should not look like the source file https://github.com/jitsi/jitsi-meet/blob/master/index.html#L141

hmm it doesn’t look like the source file starting at line 141. But I’m not sure whether it looks correct, either.

This is my source starting from line 141
https://pastebin.com/wDWdCGCU

Is it expected that there’s no config.js in /usr/share/jitsi-meet/ ?
The other .js files mentioned in index.html are there.

Your index.html is not correct, look lines 15-21.
Apparently the webserver cannot find config.js to include it:

<script><!--#include virtual="/config.js" --></script><!-- adapt to your needs, i.e. set hosts and bosh path -->

Do you have this definition in your nginx config?

The debian packages put the config.js in /etc/jitsi/meet/

ahh that’s it!
I didn’t realize I have to change the filename in nginx.
Thank you very much!!!