After disconnects immediately when opening through android os 11

Jitsi meet is working in andorid os 10 but not 11. While opening through android 11 it is saying below , my android error in 11

I am using jitsi sdk version is 2.8.2

E/JitsiMeetSDK: [features/base/lib-jitsi-meet] Failed to load config from https://myserver.com/config.js Error(TypeError){“message”:“Network request failed”,“stack”:“TypeError: Network request failed\n at anonymous (index.android.bundle:135:7285)\n at call (native)\n at dispatchEvent (index.android.bundle:126:5676)\n at value (index.android.bundle:121:6095)\n at value (index.android.bundle:121:2835)\n at apply (native)\n at anonymous (index.android.bundle:121:5024)\n at apply (native)\n at value (index.android.bundle:50:1280)\n at apply (native)\n at value (index.android.bundle:37:3685)\n at anonymous (index.android.bundle:37:841)\n at value (index.android.bundle:37:2939)\n at value (index.android.bundle:37:813)”}
2021-04-30 12:11:37.892 27124-27302/ E/JitsiMeetSDK: [features/analytics] Error(Error){“message”:“No analytics handlers created!”,“stack”:“Error: No analytics handlers created!\n at anonymous (index.android.bundle:394:1131)\n at f (index.android.bundle:109:155)\n at anonymous (index.android.bundle:109:882)\n at apply (native)\n at anonymous (index.android.bundle:115:1783)\n at y (index.android.bundle:115:661)\n at C (index.android.bundle:115:1025)\n at callImmediates (index.android.bundle:115:3100)\n at value (native)\n at anonymous (index.android.bundle:37:1283)\n at value (index.android.bundle:37:2939)\n at value (index.android.bundle:37:1253)\n at value (native)”}

Can you please any one help me on this!

@saghul, how to resolve this problem, I checked my certificate it is correct only. Still I am facing same issue in android

Hi,

I am facing the same issue.
After upgrading my Oneplus 7T from Android 10 to Android 11 yesterday, i cannot join meetings anymore. It immediately shows a “disconnect” message asking me to cancel or rejoin.

Tried reinstalling, checked permissions, opting for beta (did not work via play store). Certificate is valid. Via the browser (on my phone) i can join the meeting just fine.

Think this probably is a more of a Android 11 issue, but just in case:
Jitsi: Version 21.1.0 build 7280253.

Phone:
Android 11, security update 2021-03-01
Build Oxygen OS11.0.0.2.HD65BA

Hi,

I solved this problem.

Solution is

  1. Please remove this file /etc/nginx/modules-enabled/60-jitsi-meet.conf
  2. Change the nginx config file /etc/nginx/sites-available/you-domain.conf - change the port no to 443 instead of 4444.

Same here. Thanks Marikannan!