After changes ui title and run build && make changes not rendered on jitsi

I follow this tutorial to custom changes in Ui
https://community.jitsi.org/t/how-to-how-to-build-jitsi-meet-from-source-a-developers-guide/75422

after changing Ui title and run

cd ~/lib-jitsi-meet/ && npm run build
cd ~/jitsi-meet/ && make

changes not affected on jitsi Ui
I get the following warning when running make command

./node_modules/.bin/webpack
Browserslist: caniuse-lite is outdated. Please run:
  npx browserslist@latest --update-db
  Why you should do it regularly: https://github.com/browserslist/browserslist#browsers-data-updating
[BABEL] Note: The code generator has deoptimised the styling of /home/cic2/jitsi-meet/node_modules/lodash/lodash.js as it exceeds the max of 500KB.
[BABEL] Note: The code generator has deoptimised the styling of /home/cic2/jitsi-meet/node_modules/@vladmandic/human/dist/human.esm.js as it exceeds the max of 500KB.
[BABEL] Note: The code generator has deoptimised the styling of /home/cic2/jitsi-meet/node_modules/lodash/lodash.js as it exceeds the max of 500KB.
[BABEL] Note: The code generator has deoptimised the styling of /home/cic2/jitsi-meet/node_modules/lodash/lodash.js as it exceeds the max of 500KB.
[BABEL] Note: The code generator has deoptimised the styling of /home/cic2/jitsi-meet/node_modules/zxcvbn/lib/frequency_lists.js as it exceeds the max of 500KB.
asset app.bundle.min.js 3.81 MiB [emitted] [minimized] (name: app.bundle) 2 related assets
orphan modules 6.78 MiB [orphan] 2660 modules
runtime modules 2.73 KiB 9 modules
cacheable modules 9.51 MiB
  modules by path ./node_modules/ 4.15 MiB
    javascript modules 4.09 MiB 350 modules
    json modules 59 KiB
      modules by path ./node_modules/@giphy/ 4.31 KiB 2 modules
      2 modules
  modules by path ./react/features/ 59.4 KiB
    modules by path ./react/features/base/ 56 bytes 4 modules
    modules by path ./react/features/stream-effects/ 57.9 KiB 2 modules
    ./react/features/screenshot-capture/createImageBitmap.js 705 bytes [built] [code generated]
    ./react/features/face-landmarks/createImageBitmap.js 786 bytes [built] [code generated]
    ./react/features/invite/components/callee-info/styles.web.js 1 bytes [built] [code generated]

WARNING in ./node_modules/@atlaskit/button/dist/esm/shared/button-base.js 80:17-28
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/button/dist/esm/custom-theme-button/custom-theme-button.js 42:0-47 217:46-56
 @ ./node_modules/@atlaskit/button/dist/esm/custom-theme-button/index.js 1:0-48 1:0-48
 @ ./node_modules/@atlaskit/button/dist/esm/entry-points/custom-theme-button.js 1:0-56 1:0-56 1:0-56
 @ ./node_modules/@atlaskit/flag/dist/esm/flag-actions.js 36:0-58 65:25-31
 @ ./node_modules/@atlaskit/flag/dist/esm/flag.js 104:0-37 260:25-32
 @ ./node_modules/@atlaskit/flag/dist/esm/index.js 1:0-33 1:0-33
 @ ./react/features/notifications/components/web/Notification.js 1:0-34 49:44-48
 @ ./react/features/notifications/components/web/index.js 1:0-57 1:0-57
 @ ./react/features/notifications/components/index.web.js 1:0-22 1:0-22
 @ ./react/features/notifications/index.js 3:0-29 3:0-29
 @ ./conference.js 34:0-128 263:29-45 266:13-44 629:25-41 632:9-39 835:11-44 2223:27-43 2226:11-42
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/button/dist/esm/shared/button-base.js 81:20-34
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/button/dist/esm/custom-theme-button/custom-theme-button.js 42:0-47 217:46-56
 @ ./node_modules/@atlaskit/button/dist/esm/custom-theme-button/index.js 1:0-48 1:0-48
 @ ./node_modules/@atlaskit/button/dist/esm/entry-points/custom-theme-button.js 1:0-56 1:0-56 1:0-56
 @ ./node_modules/@atlaskit/flag/dist/esm/flag-actions.js 36:0-58 65:25-31
 @ ./node_modules/@atlaskit/flag/dist/esm/flag.js 104:0-37 260:25-32
 @ ./node_modules/@atlaskit/flag/dist/esm/index.js 1:0-33 1:0-33
 @ ./react/features/notifications/components/web/Notification.js 1:0-34 49:44-48
 @ ./react/features/notifications/components/web/index.js 1:0-57 1:0-57
 @ ./react/features/notifications/components/index.web.js 1:0-22 1:0-22
 @ ./react/features/notifications/index.js 3:0-29 3:0-29
 @ ./conference.js 34:0-128 263:29-45 266:13-44 629:25-41 632:9-39 835:11-44 2223:27-43 2226:11-42
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/dropdown-menu/dist/esm/components/DropdownMenuStateless.js 498:23-34
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/dropdown-menu/dist/esm/index.js 3:0-86 3:0-86
 @ ./react/features/device-selection/components/DeviceSelector.web.js 1:0-88 84:44-56 122:40-52 130:40-57
 @ ./react/features/device-selection/components/DeviceSelection.js 8:0-46 231:82-96
 @ ./react/features/device-selection/components/index.js 1:0-63 1:0-63
 @ ./react/features/device-selection/index.js 2:0-29 2:0-29
 @ ./react/features/base/devices/middleware.js 3:0-70 211:4-32
 @ ./react/features/app/middlewares.web.js 3:0-36
 @ ./react/features/app/components/App.web.js 9:0-24
 @ ./react/features/app/components/index.js 1:0-22 1:0-22
 @ ./react/index.web.js 4:0-48 39:7-10
 @ ./app.js 50:0-17

WARNING in ./node_modules/@atlaskit/dropdown-menu/dist/esm/components/DropdownMenuStateless.js 499:26-40
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/dropdown-menu/dist/esm/index.js 3:0-86 3:0-86
 @ ./react/features/device-selection/components/DeviceSelector.web.js 1:0-88 84:44-56 122:40-52 130:40-57
 @ ./react/features/device-selection/components/DeviceSelection.js 8:0-46 231:82-96
 @ ./react/features/device-selection/components/index.js 1:0-63 1:0-63
 @ ./react/features/device-selection/index.js 2:0-29 2:0-29
 @ ./react/features/base/devices/middleware.js 3:0-70 211:4-32
 @ ./react/features/app/middlewares.web.js 3:0-36
 @ ./react/features/app/components/App.web.js 9:0-24
 @ ./react/features/app/components/index.js 1:0-22 1:0-22
 @ ./react/index.web.js 4:0-48 39:7-10
 @ ./app.js 50:0-17

WARNING in ./node_modules/@atlaskit/dropdown-menu/dist/esm/components/DropdownMenuStateless.js 541:15-26
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/dropdown-menu/dist/esm/index.js 3:0-86 3:0-86
 @ ./react/features/device-selection/components/DeviceSelector.web.js 1:0-88 84:44-56 122:40-52 130:40-57
 @ ./react/features/device-selection/components/DeviceSelection.js 8:0-46 231:82-96
 @ ./react/features/device-selection/components/index.js 1:0-63 1:0-63
 @ ./react/features/device-selection/index.js 2:0-29 2:0-29
 @ ./react/features/base/devices/middleware.js 3:0-70 211:4-32
 @ ./react/features/app/middlewares.web.js 3:0-36
 @ ./react/features/app/components/App.web.js 9:0-24
 @ ./react/features/app/components/index.js 1:0-22 1:0-22
 @ ./react/index.web.js 4:0-48 39:7-10
 @ ./app.js 50:0-17

WARNING in ./node_modules/@atlaskit/dropdown-menu/dist/esm/components/DropdownMenuStateless.js 542:18-32
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/dropdown-menu/dist/esm/index.js 3:0-86 3:0-86
 @ ./react/features/device-selection/components/DeviceSelector.web.js 1:0-88 84:44-56 122:40-52 130:40-57
 @ ./react/features/device-selection/components/DeviceSelection.js 8:0-46 231:82-96
 @ ./react/features/device-selection/components/index.js 1:0-63 1:0-63
 @ ./react/features/device-selection/index.js 2:0-29 2:0-29
 @ ./react/features/base/devices/middleware.js 3:0-70 211:4-32
 @ ./react/features/app/middlewares.web.js 3:0-36
 @ ./react/features/app/components/App.web.js 9:0-24
 @ ./react/features/app/components/index.js 1:0-22 1:0-22
 @ ./react/index.web.js 4:0-48 39:7-10
 @ ./app.js 50:0-17

WARNING in ./node_modules/@atlaskit/dropdown-menu/dist/esm/components/DropdownMenuStateless.js 549:19-30
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/dropdown-menu/dist/esm/index.js 3:0-86 3:0-86
 @ ./react/features/device-selection/components/DeviceSelector.web.js 1:0-88 84:44-56 122:40-52 130:40-57
 @ ./react/features/device-selection/components/DeviceSelection.js 8:0-46 231:82-96
 @ ./react/features/device-selection/components/index.js 1:0-63 1:0-63
 @ ./react/features/device-selection/index.js 2:0-29 2:0-29
 @ ./react/features/base/devices/middleware.js 3:0-70 211:4-32
 @ ./react/features/app/middlewares.web.js 3:0-36
 @ ./react/features/app/components/App.web.js 9:0-24
 @ ./react/features/app/components/index.js 1:0-22 1:0-22
 @ ./react/index.web.js 4:0-48 39:7-10
 @ ./app.js 50:0-17

WARNING in ./node_modules/@atlaskit/dropdown-menu/dist/esm/components/DropdownMenuStateless.js 550:22-36
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/dropdown-menu/dist/esm/index.js 3:0-86 3:0-86
 @ ./react/features/device-selection/components/DeviceSelector.web.js 1:0-88 84:44-56 122:40-52 130:40-57
 @ ./react/features/device-selection/components/DeviceSelection.js 8:0-46 231:82-96
 @ ./react/features/device-selection/components/index.js 1:0-63 1:0-63
 @ ./react/features/device-selection/index.js 2:0-29 2:0-29
 @ ./react/features/base/devices/middleware.js 3:0-70 211:4-32
 @ ./react/features/app/middlewares.web.js 3:0-36
 @ ./react/features/app/components/App.web.js 9:0-24
 @ ./react/features/app/components/index.js 1:0-22 1:0-22
 @ ./react/index.web.js 4:0-48 39:7-10
 @ ./app.js 50:0-17

WARNING in ./node_modules/@atlaskit/field-text-area/dist/esm/FieldTextAreaStateless.js 173:15-26
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/field-text-area/dist/esm/index.js 2:0-62 4:0-34
 @ ./react/features/feedback/components/FeedbackDialog.web.js 3:0-67 184:40-62
 @ ./react/features/feedback/components/index.js 2:0-61 2:0-61
 @ ./react/features/feedback/index.js 3:0-29 3:0-29
 @ ./conference.js 31:0-84 2710:50-73 2934:25-39
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/field-text-area/dist/esm/FieldTextAreaStateless.js 174:18-32
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/field-text-area/dist/esm/index.js 2:0-62 4:0-34
 @ ./react/features/feedback/components/FeedbackDialog.web.js 3:0-67 184:40-62
 @ ./react/features/feedback/components/index.js 2:0-61 2:0-61
 @ ./react/features/feedback/index.js 3:0-29 3:0-29
 @ ./conference.js 31:0-84 2710:50-73 2934:25-39
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/field-text-area/dist/esm/FieldTextAreaStateless.js 181:19-30
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/field-text-area/dist/esm/index.js 2:0-62 4:0-34
 @ ./react/features/feedback/components/FeedbackDialog.web.js 3:0-67 184:40-62
 @ ./react/features/feedback/components/index.js 2:0-61 2:0-61
 @ ./react/features/feedback/index.js 3:0-29 3:0-29
 @ ./conference.js 31:0-84 2710:50-73 2934:25-39
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/field-text-area/dist/esm/FieldTextAreaStateless.js 182:22-36
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/field-text-area/dist/esm/index.js 2:0-62 4:0-34
 @ ./react/features/feedback/components/FeedbackDialog.web.js 3:0-67 184:40-62
 @ ./react/features/feedback/components/index.js 2:0-61 2:0-61
 @ ./react/features/feedback/index.js 3:0-29 3:0-29
 @ ./conference.js 31:0-84 2710:50-73 2934:25-39
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/field-text-area/dist/esm/FieldTextAreaStateless.js 190:19-30
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/field-text-area/dist/esm/index.js 2:0-62 4:0-34
 @ ./react/features/feedback/components/FeedbackDialog.web.js 3:0-67 184:40-62
 @ ./react/features/feedback/components/index.js 2:0-61 2:0-61
 @ ./react/features/feedback/index.js 3:0-29 3:0-29
 @ ./conference.js 31:0-84 2710:50-73 2934:25-39
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/field-text-area/dist/esm/FieldTextAreaStateless.js 191:22-36
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/field-text-area/dist/esm/index.js 2:0-62 4:0-34
 @ ./react/features/feedback/components/FeedbackDialog.web.js 3:0-67 184:40-62
 @ ./react/features/feedback/components/index.js 2:0-61 2:0-61
 @ ./react/features/feedback/index.js 3:0-29 3:0-29
 @ ./conference.js 31:0-84 2710:50-73 2934:25-39
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/flag/dist/esm/auto-dismiss-flag.js 28:17-28
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/flag/dist/esm/index.js 2:0-65 2:0-65
 @ ./react/features/notifications/components/web/Notification.js 1:0-34 49:44-48
 @ ./react/features/notifications/components/web/index.js 1:0-57 1:0-57
 @ ./react/features/notifications/components/index.web.js 1:0-22 1:0-22
 @ ./react/features/notifications/index.js 3:0-29 3:0-29
 @ ./conference.js 34:0-128 263:29-45 266:13-44 629:25-41 632:9-39 835:11-44 2223:27-43 2226:11-42
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/flag/dist/esm/auto-dismiss-flag.js 29:20-34
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/flag/dist/esm/index.js 2:0-65 2:0-65
 @ ./react/features/notifications/components/web/Notification.js 1:0-34 49:44-48
 @ ./react/features/notifications/components/web/index.js 1:0-57 1:0-57
 @ ./react/features/notifications/components/index.web.js 1:0-22 1:0-22
 @ ./react/features/notifications/index.js 3:0-29 3:0-29
 @ ./conference.js 34:0-128 263:29-45 266:13-44 629:25-41 632:9-39 835:11-44 2223:27-43 2226:11-42
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/flag/dist/esm/flag.js 111:15-26
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/flag/dist/esm/index.js 1:0-33 1:0-33
 @ ./react/features/notifications/components/web/Notification.js 1:0-34 49:44-48
 @ ./react/features/notifications/components/web/index.js 1:0-57 1:0-57
 @ ./react/features/notifications/components/index.web.js 1:0-22 1:0-22
 @ ./react/features/notifications/index.js 3:0-29 3:0-29
 @ ./conference.js 34:0-128 263:29-45 266:13-44 629:25-41 632:9-39 835:11-44 2223:27-43 2226:11-42
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/flag/dist/esm/flag.js 112:18-32
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/flag/dist/esm/index.js 1:0-33 1:0-33
 @ ./react/features/notifications/components/web/Notification.js 1:0-34 49:44-48
 @ ./react/features/notifications/components/web/index.js 1:0-57 1:0-57
 @ ./react/features/notifications/components/index.web.js 1:0-22 1:0-22
 @ ./react/features/notifications/index.js 3:0-29 3:0-29
 @ ./conference.js 34:0-128 263:29-45 266:13-44 629:25-41 632:9-39 835:11-44 2223:27-43 2226:11-42
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/inline-dialog/dist/esm/InlineDialog/index.js 195:15-26
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/inline-dialog/dist/esm/index.js 1:0-41 1:0-41
 @ ./react/features/prejoin/components/Prejoin.web.js 3:0-51 282:40-52
 @ ./react/features/prejoin/index.js 3:0-58 3:0-58
 @ ./conference.js 37:0-116 687:8-28 701:25-40 712:10-30 713:34-45 767:25-45
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/inline-dialog/dist/esm/InlineDialog/index.js 196:18-32
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/inline-dialog/dist/esm/index.js 1:0-41 1:0-41
 @ ./react/features/prejoin/components/Prejoin.web.js 3:0-51 282:40-52
 @ ./react/features/prejoin/index.js 3:0-58 3:0-58
 @ ./conference.js 37:0-116 687:8-28 701:25-40 712:10-30 713:34-45 767:25-45
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/inline-dialog/dist/esm/InlineDialog/index.js 203:19-30
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/inline-dialog/dist/esm/index.js 1:0-41 1:0-41
 @ ./react/features/prejoin/components/Prejoin.web.js 3:0-51 282:40-52
 @ ./react/features/prejoin/index.js 3:0-58 3:0-58
 @ ./conference.js 37:0-116 687:8-28 701:25-40 712:10-30 713:34-45 767:25-45
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/inline-dialog/dist/esm/InlineDialog/index.js 204:22-36
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/inline-dialog/dist/esm/index.js 1:0-41 1:0-41
 @ ./react/features/prejoin/components/Prejoin.web.js 3:0-51 282:40-52
 @ ./react/features/prejoin/index.js 3:0-58 3:0-58
 @ ./conference.js 37:0-116 687:8-28 701:25-40 712:10-30 713:34-45 767:25-45
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/modal-dialog/dist/esm/components/Modal.js 228:15-26
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/modal-dialog/dist/esm/components/ModalWrapper.js 45:0-28 93:50-55
 @ ./node_modules/@atlaskit/modal-dialog/dist/esm/index.js 1:0-52 1:0-52
 @ ./react/features/base/dialog/components/web/DialogContainer.js 1:0-57 20:44-59
 @ ./react/features/base/dialog/components/web/index.js 3:0-63 3:0-63
 @ ./react/features/base/dialog/components/_.web.js 1:0-22 1:0-22
 @ ./react/features/base/dialog/components/index.js 1:0-20 1:0-20
 @ ./react/features/base/dialog/index.js 3:0-29 3:0-29
 @ ./modules/keyboardshortcut/keyboardshortcut.js 5:0-64 112:23-35 236:25-37
 @ ./app.js 13:0-75 40:2-18

WARNING in ./node_modules/@atlaskit/modal-dialog/dist/esm/components/Modal.js 229:18-32
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/modal-dialog/dist/esm/components/ModalWrapper.js 45:0-28 93:50-55
 @ ./node_modules/@atlaskit/modal-dialog/dist/esm/index.js 1:0-52 1:0-52
 @ ./react/features/base/dialog/components/web/DialogContainer.js 1:0-57 20:44-59
 @ ./react/features/base/dialog/components/web/index.js 3:0-63 3:0-63
 @ ./react/features/base/dialog/components/_.web.js 1:0-22 1:0-22
 @ ./react/features/base/dialog/components/index.js 1:0-20 1:0-20
 @ ./react/features/base/dialog/index.js 3:0-29 3:0-29
 @ ./modules/keyboardshortcut/keyboardshortcut.js 5:0-64 112:23-35 236:25-37
 @ ./app.js 13:0-75 40:2-18

WARNING in ./node_modules/@atlaskit/modal-dialog/dist/esm/components/Modal.js 236:19-30
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/modal-dialog/dist/esm/components/ModalWrapper.js 45:0-28 93:50-55
 @ ./node_modules/@atlaskit/modal-dialog/dist/esm/index.js 1:0-52 1:0-52
 @ ./react/features/base/dialog/components/web/DialogContainer.js 1:0-57 20:44-59
 @ ./react/features/base/dialog/components/web/index.js 3:0-63 3:0-63
 @ ./react/features/base/dialog/components/_.web.js 1:0-22 1:0-22
 @ ./react/features/base/dialog/components/index.js 1:0-20 1:0-20
 @ ./react/features/base/dialog/index.js 3:0-29 3:0-29
 @ ./modules/keyboardshortcut/keyboardshortcut.js 5:0-64 112:23-35 236:25-37
 @ ./app.js 13:0-75 40:2-18

WARNING in ./node_modules/@atlaskit/modal-dialog/dist/esm/components/Modal.js 237:22-36
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/modal-dialog/dist/esm/components/ModalWrapper.js 45:0-28 93:50-55
 @ ./node_modules/@atlaskit/modal-dialog/dist/esm/index.js 1:0-52 1:0-52
 @ ./react/features/base/dialog/components/web/DialogContainer.js 1:0-57 20:44-59
 @ ./react/features/base/dialog/components/web/index.js 3:0-63 3:0-63
 @ ./react/features/base/dialog/components/_.web.js 1:0-22 1:0-22
 @ ./react/features/base/dialog/components/index.js 1:0-20 1:0-20
 @ ./react/features/base/dialog/index.js 3:0-29 3:0-29
 @ ./modules/keyboardshortcut/keyboardshortcut.js 5:0-64 112:23-35 236:25-37
 @ ./app.js 13:0-75 40:2-18

WARNING in ./node_modules/@atlaskit/modal-dialog/dist/esm/components/Positioner.js 15:24-39
export 'PositionerFixed' (imported as 'PositionerFixed') was not found in '../styled/Modal' (possible exports: Dialog, FillScreen, PositionerAbsolute, PositionerRelative, dialogHeight, dialogWidth)
 @ ./node_modules/@atlaskit/modal-dialog/dist/esm/components/Modal.js 52:0-38 171:45-55
 @ ./node_modules/@atlaskit/modal-dialog/dist/esm/components/ModalWrapper.js 45:0-28 93:50-55
 @ ./node_modules/@atlaskit/modal-dialog/dist/esm/index.js 1:0-52 1:0-52
 @ ./react/features/base/dialog/components/web/DialogContainer.js 1:0-57 20:44-59
 @ ./react/features/base/dialog/components/web/index.js 3:0-63 3:0-63
 @ ./react/features/base/dialog/components/_.web.js 1:0-22 1:0-22
 @ ./react/features/base/dialog/components/index.js 1:0-20 1:0-20
 @ ./react/features/base/dialog/index.js 3:0-29 3:0-29
 @ ./modules/keyboardshortcut/keyboardshortcut.js 5:0-64 112:23-35 236:25-37
 @ ./app.js 13:0-75 40:2-18

WARNING in ./node_modules/@atlaskit/tabs/dist/esm/components/Tabs.js 236:15-26
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/tabs/dist/esm/index.js 1:0-44 1:0-44
 @ ./react/features/desktop-picker/components/DesktopPicker.js 3:0-34 311:44-48
 @ ./react/features/desktop-picker/components/index.js 1:0-59 1:0-59
 @ ./react/features/desktop-picker/index.js 2:0-29 2:0-29
 @ ./conference.js 29:0-68 89:23-40
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/tabs/dist/esm/components/Tabs.js 237:18-32
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/tabs/dist/esm/index.js 1:0-44 1:0-44
 @ ./react/features/desktop-picker/components/DesktopPicker.js 3:0-34 311:44-48
 @ ./react/features/desktop-picker/components/index.js 1:0-59 1:0-59
 @ ./react/features/desktop-picker/index.js 2:0-29 2:0-29
 @ ./conference.js 29:0-68 89:23-40
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/tabs/dist/esm/components/Tabs.js 244:19-30
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/tabs/dist/esm/index.js 1:0-44 1:0-44
 @ ./react/features/desktop-picker/components/DesktopPicker.js 3:0-34 311:44-48
 @ ./react/features/desktop-picker/components/index.js 1:0-59 1:0-59
 @ ./react/features/desktop-picker/index.js 2:0-29 2:0-29
 @ ./conference.js 29:0-68 89:23-40
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/tabs/dist/esm/components/Tabs.js 245:22-36
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/tabs/dist/esm/index.js 1:0-44 1:0-44
 @ ./react/features/desktop-picker/components/DesktopPicker.js 3:0-34 311:44-48
 @ ./react/features/desktop-picker/components/index.js 1:0-59 1:0-59
 @ ./react/features/desktop-picker/index.js 2:0-29 2:0-29
 @ ./conference.js 29:0-68 89:23-40
 @ ./app.js 10:0-38 25:2-12

WARNING in ./node_modules/@atlaskit/tooltip/dist/esm/Tooltip.js 55:15-26
Should not import the named export 'name' (imported as 'packageName') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/tooltip/dist/esm/index.js 1:0-36 1:0-36
 @ ./react/features/base/tooltip/components/TooltipWrapper.js 1:0-40 21:42-49
 @ ./react/features/base/tooltip/components/index.js 1:0-54 1:0-54
 @ ./react/features/base/tooltip/index.js 1:0-29 1:0-29
 @ ./react/features/virtual-background/components/VirtualBackgroundDialog.js 17:0-45 476:38-45 489:69-76 502:75-82 515:111-118 532:62-69
 @ ./modules/API/API.js 44:0-113 628:38-61
 @ ./modules/API/index.js 1:0-29 2:0-31
 @ ./app.js 11:0-32 24:2-5

WARNING in ./node_modules/@atlaskit/tooltip/dist/esm/Tooltip.js 56:18-32
Should not import the named export 'version' (imported as 'packageVersion') from default-exporting module (only default export is available soon)
 @ ./node_modules/@atlaskit/tooltip/dist/esm/index.js 1:0-36 1:0-36
 @ ./react/features/base/tooltip/components/TooltipWrapper.js 1:0-40 21:42-49
 @ ./react/features/base/tooltip/components/index.js 1:0-54 1:0-54
 @ ./react/features/base/tooltip/index.js 1:0-29 1:0-29
 @ ./react/features/virtual-background/components/VirtualBackgroundDialog.js 17:0-45 476:38-45 489:69-76 502:75-82 515:111-118 532:62-69
 @ ./modules/API/API.js 44:0-113 628:38-61
 @ ./modules/API/index.js 1:0-29 2:0-31
 @ ./app.js 11:0-32 24:2-5

WARNING in ./react/features/participants-pane/components/web/LobbyParticipantItem.js 108:10-34
export 'BUTTON_TYPES' (imported as 'BUTTON_TYPES') was not found in '../../../base/react/constants' (possible exports: OVERLAY_Z_INDEX)
 @ ./react/features/participants-pane/components/web/index.js 2:0-39 2:0-39
 @ ./react/features/conference/components/web/Conference.js 16:0-77 162:275-291
 @ ./react/features/filmstrip/components/web/ScreenshareFilmstrip.js 5:0-82 11:13-30
 @ ./react/features/filmstrip/components/web/index.js 6:0-73 6:0-73
 @ ./react/features/filmstrip/components/_.web.js 1:0-22 1:0-22
 @ ./react/features/filmstrip/components/index.js 1:0-20 1:0-20
 @ ./react/features/filmstrip/index.js 3:0-29 3:0-29
 @ ./modules/UI/UI.js 8:0-69 210:21-40
 @ ./app.js 12:0-33 42:2-4

webpack 5.57.1 compiled with 34 warnings in 202346 ms

asset alwaysontop.min.js 292 KiB [emitted] [minimized] (name: alwaysontop) 2 related assets
orphan modules 434 KiB [orphan] 308 modules
runtime modules 1010 bytes 5 modules
cacheable modules 1.14 MiB
  modules by path ./node_modules/hoist-non-react-statics/ 6.19 KiB 3 modules
  modules by path ./node_modules/react/ 8.5 KiB
    ./node_modules/react/index.js 189 bytes [built] [code generated]
    ./node_modules/react/cjs/react.production.min.js 8.32 KiB [built] [code generated]
  modules by path ./node_modules/react-dom/ 175 KiB
    ./node_modules/react-dom/index.js 1.32 KiB [built] [code generated]
    ./node_modules/react-dom/cjs/react-dom.production.min.js 173 KiB [built] [code generated]
  modules by path ./node_modules/scheduler/ 6.84 KiB
    ./node_modules/scheduler/index.js 197 bytes [built] [code generated]
    ./node_modules/scheduler/cjs/scheduler.production.min.js 6.65 KiB [built] [code generated]
  4 modules
webpack 5.57.1 compiled successfully in 128743 ms

asset dial_in_info_bundle.min.js 484 KiB [emitted] [minimized] (name: dial_in_info_bundle) 2 related assets
orphan modules 415 KiB [orphan] 232 modules
runtime modules 1010 bytes 5 modules
cacheable modules 1.43 MiB
  modules by path ./node_modules/moment/ 316 KiB 52 modules
  modules by path ./node_modules/i18next-browser-languagedetector/ 11.6 KiB 10 modules
  modules by path ./node_modules/html-parse-stringify2/ 4.75 KiB 4 modules
  modules by path ./react/features/ 413 KiB 2 modules
  modules by path ./node_modules/react/ 8.5 KiB 2 modules
  modules by path ./node_modules/react-dom/ 175 KiB
    ./node_modules/react-dom/index.js 1.32 KiB [built] [code generated]
    ./node_modules/react-dom/cjs/react-dom.production.min.js 173 KiB [built] [code generated]
  modules by path ./node_modules/scheduler/ 6.84 KiB
    ./node_modules/scheduler/index.js 197 bytes [built] [code generated]
    ./node_modules/scheduler/cjs/scheduler.production.min.js 6.65 KiB [built] [code generated]
webpack 5.57.1 compiled successfully in 119646 ms

asset do_external_connect.min.js 3.55 KiB [emitted] [minimized] (name: do_external_connect) 2 related assets
orphan modules 29.3 KiB [orphan] 10 modules
cacheable modules 32.2 KiB
  ./connection_optimization/do_external_connect.js + 6 modules 28.5 KiB [built] [code generated]
  ./node_modules/@hapi/bourne/lib/index.js 2.02 KiB [built] [code generated]
  ./node_modules/clipboard-copy/index.js 1.62 KiB [built] [code generated]
webpack 5.57.1 compiled successfully in 61790 ms

asset analytics-ga.min.js 4.24 KiB [emitted] [minimized] (name: analytics-ga) 2 related assets
orphan modules 31.4 KiB [orphan] 10 modules
cacheable modules 35.5 KiB
  ./react/features/analytics/handlers/GoogleAnalyticsHandler.js + 5 modules 31.8 KiB [built] [code generated]
  ./node_modules/clipboard-copy/index.js 1.62 KiB [built] [code generated]
  ./node_modules/@hapi/bourne/lib/index.js 2.02 KiB [built] [code generated]
webpack 5.57.1 compiled successfully in 76315 ms

asset close3.min.js 0 bytes [emitted] [minimized] (name: close3)
./static/close3.js 1 bytes [built] [code generated]
webpack 5.57.1 compiled successfully in 10566 ms

asset external_api.min.js 33.8 KiB [emitted] [minimized] (name: external_api) 2 related assets
orphan modules 53.9 KiB [orphan] 18 modules
runtime modules 663 bytes 3 modules
cacheable modules 127 KiB
  modules by path ./node_modules/ 36.7 KiB
    modules by path ./node_modules/@jitsi/ 19.1 KiB
      ./node_modules/@jitsi/logger/lib/index.js 3.74 KiB [built] [code generated]
      ./node_modules/@jitsi/logger/lib/Logger.js 5.41 KiB [built] [code generated]
      ./node_modules/@jitsi/logger/lib/LogCollector.js 9.92 KiB [built] [code generated]
    ./node_modules/events/events.js 14 KiB [built] [code generated]
    ./node_modules/@hapi/bourne/lib/index.js 2.02 KiB [built] [code generated]
    ./node_modules/clipboard-copy/index.js 1.62 KiB [built] [code generated]
  modules by path ./modules/API/external/ 90 KiB
    ./modules/API/external/index.js 171 bytes [built] [code generated]
    ./modules/API/external/external_api.js + 13 modules 89.8 KiB [built] [code generated]
webpack 5.57.1 compiled successfully in 76262 ms

asset face-landmarks-worker.min.js 1.81 MiB [emitted] [minimized] (name: face-landmarks-worker) 2 related assets
orphan modules 3.01 MiB [orphan] 508 modules
runtime modules 914 bytes 5 modules
cacheable modules 2.69 MiB
  modules by path ./ 2.69 MiB
    modules by path ./node_modules/@tensorflow/tfjs-backend-wasm/ 138 KiB
      ./node_modules/@tensorflow/tfjs-backend-wasm/wasm-out/tfjs-backend-wasm-threaded-simd.js 95.5 KiB [built] [code generated]
      ./node_modules/@tensorflow/tfjs-backend-wasm/wasm-out/tfjs-backend-wasm.js 42.5 KiB [built] [code generated]
    ./react/features/face-landmarks/faceLandmarksWorker.ts + 293 modules 2.52 MiB [built] [code generated]
    ./node_modules/long/src/long.js 36 KiB [built] [code generated]
  7 modules
webpack 5.57.1 compiled successfully in 129878 ms

asset noise-suppressor-worklet.min.js 154 KiB [emitted] [minimized] (name: noise-suppressor-worklet) 1 related asset
orphan modules 182 KiB [orphan] 5 modules
./react/features/stream-effects/noise-suppression/NoiseSuppressorWorklet.ts + 5 modules 189 KiB [built] [code generated]
webpack 5.57.1 compiled successfully in 62647 ms
rm -fr libs
mkdir -p libs
cp \
        build/app.bundle.min.js \
        build/app.bundle.min.js.map \
        build/do_external_connect.min.js \
        build/do_external_connect.min.js.map \
        build/external_api.min.js \
        build/external_api.min.js.map \
        build/dial_in_info_bundle.min.js \
        build/dial_in_info_bundle.min.js.map \
        build/alwaysontop.min.js \
        build/alwaysontop.min.js.map \
        ./analytics-ga.js \
        build/analytics-ga.min.js \
        build/analytics-ga.min.js.map \
        build/face-landmarks-worker.min.js \
        build/face-landmarks-worker.min.js.map \
        build/noise-suppressor-worklet.min.js \
        build/noise-suppressor-worklet.min.js.map \
        libs
cp \
        build/close3.min.js \
        build/close3.min.js.map \
        libs || true
cp: cannot stat 'build/close3.min.js.map': No such file or directory
cp \
        node_modules/@jitsi/rnnoise-wasm/dist/rnnoise.wasm \
        libs
cp \
        react/features/stream-effects/virtual-background/vendor/tflite/*.wasm \
        libs
cp \
        react/features/stream-effects/virtual-background/vendor/models/*.tflite \
        libs
cp \
        node_modules/lib-jitsi-meet/dist/umd/lib-jitsi-meet.min.js \
        node_modules/lib-jitsi-meet/dist/umd/lib-jitsi-meet.min.map \
        node_modules/lib-jitsi-meet/dist/umd/lib-jitsi-meet.e2ee-worker.js \
        node_modules/lib-jitsi-meet/connection_optimization/external_connect.js \
        node_modules/lib-jitsi-meet/modules/browser/capabilities.json \
        libs
cp \
        node_modules/@matrix-org/olm/olm.wasm \
        libs
cp \
        node_modules/@tensorflow/tfjs-backend-wasm/dist//*.wasm \
        libs
./node_modules/.bin/sass css/main.scss css/all.bundle.css && \
./node_modules/.bin/cleancss --skip-rebase css/all.bundle.css > css/all.css && \
rm css/all.bundle.css
([ ! -x deploy-local.sh ] || ./deploy-local.sh)
cp \
        node_modules/@vladmandic/human-models/models/blazeface-front.bin \
        node_modules/@vladmandic/human-models/models/blazeface-front.json \
        node_modules/@vladmandic/human-models/models/emotion.bin \
        node_modules/@vladmandic/human-models/models/emotion.json \
        libs
rm -fr build

if this warning prevents changes from rendered

Are you sure you configured nginx correctly?

yes I comment on the default root and add my own root

    # ensure all static content can always be found first
    location ~ ^/(libs|css|static|images|fonts|lang|sounds|connection_optimization|.well-known)/(.*)$
    {
        add_header 'Access-Control-Allow-Origin' '*';
        alias /home/cic2/jitsi-meet/$1/$2;

I replace all relevant occurrences of /usr/share/jitsi-meet wirh /home/cic2/jitsi-meet
in this conf file , but still changes not rendered.

@emrah

server_names_hash_bucket_size 64;

types {
# nginx's default mime.types doesn't include a mapping for wasm or wav.
    application/wasm     wasm;
    audio/wav            wav;
}
upstream prosody {
    zone upstreams 64K;
    server 127.0.0.1:5280;
    keepalive 2;
}
upstream jvb1 {
    zone upstreams 64K;
    server 127.0.0.1:9090;
    keepalive 2;
}
server {
    listen 80;
    listen [::]:80;
    server_name meet.elemental-tech.com;

    location ^~ /.well-known/acme-challenge/ {
        default_type "text/plain";
        #root         /usr/share/jitsi-meet;
        root          /home/cic2/jitsi-meet;
    }
    location = /.well-known/acme-challenge/ {
        return 404;
    }
    location / {
        return 301 https://$host$request_uri;
    }
}
server {
    listen 443 ssl;
    listen [::]:443 ssl;
    server_name meet.elemental-tech.com;

    # Mozilla Guideline v5.4, nginx 1.17.7, OpenSSL 1.1.1d, intermediate configuration
    ssl_protocols TLSv1.2 TLSv1.3;
    ssl_ciphers ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384;
    ssl_prefer_server_ciphers off;

    ssl_session_timeout 1d;
    ssl_session_cache shared:SSL:10m;  # about 40000 sessions
    ssl_session_tickets off;

    add_header Strict-Transport-Security "max-age=63072000" always;
    set $prefix "";

    ssl_certificate /etc/letsencrypt/live/meet.elemental-tech.com/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/meet.elemental-tech.com/privkey.pem;

    # root /usr/share/jitsi-meet;

    # Add this new line below
    root /home/cic2/jitsi-meet;

    # ssi on with javascript for multidomain variables in config.js
    ssi on;
    ssi_types application/x-javascript application/javascript;

    index index.html index.htm;
    error_page 404 /static/404.html;

    gzip on;
    gzip_types text/plain text/css application/javascript application/json image/x-icon application/octet-stream application/wasm;
    gzip_vary on;
    gzip_proxied no-cache no-store private expired auth;
    gzip_min_length 512;

    location = /config.js {
        alias /etc/jitsi/meet/meet.elemental-tech.com-config.js;
    }

    location = /external_api.js {
       # alias /usr/share/jitsi-meet/libs/external_api.min.js;
        alias  /home/cic2/jitsi-meet/libs/external_api.min.js;
    }

    location = /_api/room-info {
        proxy_pass http://prosody/room-info?prefix=$prefix&$args;
        proxy_http_version 1.1;
        proxy_set_header X-Forwarded-For $remote_addr;
        proxy_set_header Host $http_host;
    }

    # ensure all static content can always be found first
    location ~ ^/(libs|css|static|images|fonts|lang|sounds|connection_optimization|.well-known)/(.*)$
    {
        add_header 'Access-Control-Allow-Origin' '*';
        #alias /usr/share/jitsi-meet/$1/$2;
        alias /home/cic2/jitsi-meet/$1/$2;

        # cache all versioned files
        if ($arg_v) {
            expires 1y;
        }
    }

    # BOSH
    location = /http-bind {
        proxy_pass http://prosody/http-bind?prefix=$prefix&$args;
        proxy_http_version 1.1;
        proxy_set_header X-Forwarded-For $remote_addr;
        proxy_set_header Host $http_host;
        proxy_set_header Connection "";
    }

    # xmpp websockets
    location = /xmpp-websocket {
        proxy_pass http://prosody/xmpp-websocket?prefix=$prefix&$args;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
        proxy_set_header Host $http_host;
        tcp_nodelay on;
    }

    # colibri (JVB) websockets for jvb1
    location ~ ^/colibri-ws/default-id/(.*) {
        proxy_pass http://jvb1/colibri-ws/default-id/$1$is_args$args;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
        tcp_nodelay on;
    }

    # load test minimal client, uncomment when used
    #location ~ ^/_load-test/([^/?&:'"]+)$ {
    #    rewrite ^/_load-test/(.*)$ /load-test/index.html break;
    #}
    #location ~ ^/_load-test/libs/(.*)$ {
    #    add_header 'Access-Control-Allow-Origin' '*';
    #    alias /usr/share/jitsi-meet/load-test/libs/$1;
    #}

    location ~ ^/([^/?&:'"]+)$ {
        try_files $uri @root_path;
    }

    location @root_path {
        rewrite ^/(.*)$ / break;
    }

    location ~ ^/([^/?&:'"]+)/config.js$
    {
        set $subdomain "$1.";
        set $subdir "$1/";

        alias /etc/jitsi/meet/meet.elemental-tech.com-config.js;
    }

    # BOSH for subdomains
    location ~ ^/([^/?&:'"]+)/http-bind {
        set $subdomain "$1.";
        set $subdir "$1/";
        set $prefix "$1";

        rewrite ^/(.*)$ /http-bind;
    }

    # websockets for subdomains
    location ~ ^/([^/?&:'"]+)/xmpp-websocket {
        set $subdomain "$1.";
        set $subdir "$1/";
        set $prefix "$1";

        rewrite ^/(.*)$ /xmpp-websocket;
    }

    location ~ ^/([^/?&:'"]+)/_api/room-info {
        set $subdomain "$1.";
        set $subdir "$1/";
        set $prefix "$1";

        rewrite ^/(.*)$ /_api/room-info;
    }

    # Anything that didn't match above, and isn't a real file, assume it's a room name and redirect to /
    location ~ ^/([^/?&:'"]+)/(.*)$ {
        set $subdomain "$1.";
        set $subdir "$1/";
        rewrite ^/([^/?&:'"]+)/(.*)$ /$2;
    }
}

solved with clear cash

1 Like