After 20 seconds: Oops, something went wront

Some months ago I tried installing Jitsi Meet on my server. I encountered a number of issues after which I sort of gave up.

Today my enthusiasm won, and I tried installing Jitsi Meet again on my server. Normally I would only use the installation instruction of the developers, but due to my failure from a few months ago, I decided to use the installation instructions from the website below.

I only did step 1, 2 and 3, because I have my own certificate already, which I have succesfully installed on my Jitsi server.

It is working better now than it was before. I can now browse to jitsi.mydomain.com, create a room or connect to an existing room.

However, I still have a problem:

When a second person is in the room, after 20 seconds I get a message ‘something went wrong, we’re trying to fix the issue…’

I have the following configuration:

  • pfSense

  • HAProxy (reverse proxy)

    • With a Frontend that runs the certificate I bought.
    • A backend that directs to Jitsi. At this point, the Jitsi server itself, runs the certificate as well. While I’m typing this I imagine this might not be such a good idea. I will change that later on.
  • I have no port forwarding because I use HAProxy as a reverse proxy. I figured that this webserver should serve everything from the webserver.

  • I have tried using port forwarding port 443 (TCP) and 10000 (UDP) and 4443 (TCP) but no luck in that so I disabled that again.