Advanced moderation in jitsi

Good morning to all, sorry for my noob question but anyway i need to know about advanced moderation introduced with the latest stable version of jitsi. What is it and how can i activate it? i have a test lab with latest version. Thanks in advance on helping me.

it’s supposed to block reactivation of sound and mic when the moderator has disabled it.

just like speakerstats. But don’t bother because it’s not working correctly even on unstable.

Thanks @gpatel-fr for your quick response! I’ll wait the stable version of the av-moderation. Thanks.

What do you mean, I’m not aware of any problems with it.

tried it, asked to block mic for the guest, on the other station (not moderator) enabled it back and tested it, it could be heard by the moderator. That counts as ‘not working’ for me.

Yes i can confirm that! reading your sugestion “… it’s like speakerstats…” i have enabled the module in prosody lua conf adding “av_moderation”; in the section regarding secure-domain. Tried to mute evryone not moderator but the guests can activate mic and video

All right, I updated to latest unstable - I did not feel that it was really necessary since there is no patch related for a few weeks, but anyway my test server is now at 6476. This is secure domain with no code change, only configuration.
Start a meeting. Click the … button near the ‘cut mic to everyone’. There is a menu with this (incoherently translated but that’s the least of the problems)::

allow participants to:

  • unmute themselves
  • start their video

there is a check mark besides these 2 lines but clicking these checkmarks do nothing (it certainly does not uncheck them)

click on the button above, cut all cams. There is a popup with a confirmation question and an option ‘authorize participants to start their video’. I un-check this option. It’s on by default. Then I click on the button ‘cut cam’. If I click again on the … button, I see again the two lines with each its heck mark (F1)

At this point I’m still the only user connected to the room. My cam has been cut by the previous move (F2). I enable it again.

Then I connect from my laptop. On the laptop I see myself as moderator (that is, the cam on my main computer) and the laptop’s cam is cut so in the tile mode there is a black image and a moving image. On the laptop, I click on the (disabled) cam button in the toolbar and now see myself in 2 different angles (the two computers are near). On the main computer the same. (F3).

Now I stop the meeting on the 2 computers and I restart the same meeting on my main computer exactly in the same way I did. But I now connect on the laptop. I have now an basic meeting going on with 2 users, me as moderator on the main computer and me as guest on the laptop, both see each other.
Now as the moderator I do the same thing as I did.

On the laptop the screen is cut as before. On the laptop I can click the disabled video button, and my video displays again on the laptop. That is on the laptop I see myself in 2 different angles. But on the main computer the image is not displayed (F4)

At this point the video from the laptop seems to have been cut for other users, so it’s a half success even if I see no obvious way to undo this and allow me to see again the laptop video (F5): but when I try to confirm it and join the meeting from a third computer (as guest), now the 3 screens are displayed again on all 3 computers (F6).

IMO, F1- F6 are all problems - and I did not even try audio.
I do realize all the work that has been put into this, and all this work is beyond my own imited programming skills, but from an user point of view it’s not enough. Sorry but that’s how it is.

Exactly same problems here! Very useful feature but waiting for the correction!

This means the serverside is not working.

Are you testing without fixing the server-side, the first problem you mention (when you click and the check doesn’t change in the menu)?

You can reproduce the same steps on meet.jit.si using moderated.jitsi.net links?

Do you have these in your prosody config:

Thanks @damencho i’m testing it right now!

I have tested (with the configurations mentioned i am able to activate av-moderation) but the problem is that moderator is unable to reactivate is microphone after mute all. It seem that moderator is treated like other users (normal user) If i reactivate microphone other participants dont ear nothing from me nevertheless i have reactivated my mic.

@damencho
yes I had these parameters. The problem was that websockets is not working correctly on my system - I was unaware that websockets could work partly (because they were working, I could connect with bosh disabled), but disabling websockets and enabling bosh fixed it. The symptom was that the routine was exiting at

 if not session or not session.jitsi_web_query_room then

because session.jitsi_web_query_room was nil. Yet lobby was working without problem and it relies on this variable to be set. I have not finished investigating but wanted to give you a quick update.

And… after finally unchecking the darn checkmarks, and disabling all cams for good measure, the guest is still able to enable video. Oh well. I tried to set in parameters ‘everyone is staring without mic and cam’ before the guest connect instead, and it works, but guest can still enable the cam, but in this case the video don’t come to the moderator - same symptom I had in my previous post, no obvious way to enable back the video.

Edit: after upgrading Prosody to 11.10, same thing, except that when I unckeck the marks and ask for everyone to start with mic and cam disabled, the guest can enable back the video and this time it comes fine to the moderator. That’s progress I guess :wink:

Edt 2: with Prosody upgraded to latest, websockets are no longer blocking changing the checkmarks, so Prosody of Ubuntu 20.04 (that is, 11.4.1) is clearly NOT compatible with av_moderation.

Edit 3: with websockets finally re-enabled and bosh disabled, it begins to work as it should. Unchecking the marks cut the cam to everyone including moderator, but moderator can enable the cam back but not the guest. That’s real progress. So: @malviven7 make sure that you have upgraded Prosody and if it still does not work, try to enable websockets and disable bosh. Pfff… I will pause this party for the evening.

getting back to this this morning a bit more fresh, I have restored the faulty configuration (Prosody 11.4) and I can establish these points:

  • with Prosody 11.4 and websockets, nothing works (can’t uncheck the marks).
    I have looked the lobby matter and it works with this config, but session.jitsi_web_query_room is not set; however, this value is only tested in relation with a feature making optional the fact of not having a display name before joining a lobby-enabled room, and after setting this option, that is, asking for it to be false, the display name is required anyway. So everything seem to work correctly if one keeps to the default option.
    Edit: I remember now that to get websockets to work on vanilla Ubuntu 20.04 I had fixed Prosody by patching the websockets module and some Ubuntu upgrade had restored the default version, so it’s to be expected that nothing work with Websockets and Prosody 11.4 in the av_moderation module, since Websockets are not working at all with Jitsi-meet in this case.

  • with Prosody 11.4 and bosh, unchecking the marks do work (I probably forgot to test this particular point yesterday), but overall av_moderation do NOT work, the problem being that the guest can enable back the video after being ‘forbidden’ to do so.
    I think that I will take a look at this, because if there is no way to make it work in this config, it would be a good thing that the module’s code gives a warning along the lines of ‘update Prosody to 11.x minimum’.
    Edit: oh well. It seems that as of now, just enabling anonymous access is making everyone a moderator. I had done that do eliminate the ‘secure domain’ part, but it had an impact as it’s logical that a mod can unmask the cam. Has the allowners module gone obsolete now ? I don’t have it enabled yet it seems to be how Jitsi-meet operates…
    In short:
    with Prosody 11.4, bosh, and secure domain, basically it works.
    with Prosody 11.4, bosh, and anonymous access everyone is a mod (???) so of course it does not work.

1 Like

I have in my instyallation, the official repo of prosody so it’s at the 11.10 version, so far so good but seem that moderator can mute all but reactivating it’s mic other participants can’t ear; at the end the mechanism of the av-moderation it’s correct, the problem remain in reactivating mic of the moderator. I suspect that same problem happen for cam (in my installation of course)

No I don’t see that; once Prosody is at 11.10, with secure domain (and websockets but I don’t think it’s relevant) unchecking ‘allow unmute themselves’ don’t even cut the moderator’s mic and it works for a guest that connect afterwards.
If after the guest is allowed with mic enabled, the moderator mutes everyone, the moderator can umute own mic and it’s operational, the guest can hear it.

:man_facepalming:
My initial problem was coming from old Prosody version, believing (from past experience) that it could come from secure domain I switched on anonymous not realizing that I had never tested it after switching the Jicofo configuration to new format. I had translated the authentication part in sip-communicator.properties into the equivalent in jicofo.conf, not realizing that it was useless in secure domain and actually very bad in anonymous mode. So every user in anonymous domain was promoted to moderator. After removing this grievous mistake it’s working in anonymous mode. Thanks @damencho.

@gpatel-fr could you share your prosody config? I must see wich differences there are between yours and mine 'coz i am unable to see what is my problem

here it is. meet.example.com.cfg.lua.txt (4.9 KB)

Actually none of my problems were coming of anything in this file, so it’s not sure it’s the case for you.
After starting an initial meeting with only the moderator, when unchecking the marks in the menu to the bottom of the participants panel, do you have the moderator’s mic and cam disabled ? if yes, maybe it could be a problem with stable version. I use unstable on my test server. With this version, the moderator is blocking own mic and cam only when using the specific buttons ‘disallow all mics’ and ‘disallow all cams’
.