Admin login .htpasswd

Hello,

I would like admin to be able to log in with accounts in a .htpassword file, is this possible?
Thank you

No, there is no such option at the moment.

Hello,

Would that be possible?
Because I wish that only people with access from another site can launch conferences.

cordially

Try configure nginx to use .htpasswd it will make the website stop working for non authenticated users, however nothing stops users to connect to the videobride or prosody server directly using a mobile client.

general advanced jicofo/prosody configuration to secure a jitsi-meet instance: https://github.com/jitsi/jicofo#secure-domain

passwords in jitsi-meet are handled by the prosody xmpp server, you need to extend it using a lua module plugin to make it use authentication from your system files or pick up options from the .htpasswd file, we are clearly beyond the general advanced section of jicofo/prosody configuration by writing new modules.

Hello,
I tried to use the module https://modules.prosody.im/mod_auth_imap.html
My code is as follows
VirtualHost “meet.jitsi”
authentication = “mod_auth_imap”
config = {
“imap_auth_host” = test
“imap_auth_port” = 143
}
ssl = {
key = “/config/certs/meet.jitsi.key”;
certificate = “/config/certs/meet.jitsi.crt”;
}
modules_enabled = {
“displays”;
“pubsub”;
“ping”;
“auth_imap”;
}
c2s_require_encryption = false

But this does not ask me for identification anymore, comment the corrected?

1 Like

I tried configuring nginx to add htpasswd without success.

Steps taken were in line with Nginx manual:

Code that I have right now:

location / {

   auth_basic "Restricted Content";
   auth_basic_user_file /path/to/the/folder/.htpasswd;
   #return 301 $scheme://host$request_uri;   

}

Generated htpasswd in line with the manual. Any thoughts on what could be the reason that htpasswd is not working?