Adjust port 10000 UDP

I would like to have a second Jitsi server on my network. I completed the installation behind a proxy so port 443 is forwarded correctly but now I have the issue that port 10000 UDP can only be used for one server.

Is it possible to adjust the default port 10000 UDP so I can use multiple Jitsi instances?

Hello

try to set this

org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT=10001

in your /etc/jitsi/videobridge/sip-communicator.properties

warning: this is undocumented

1 Like

interesting… what reverse proxy do you use? cause i’ve been unsuccessful to reverse proxy UDP ports

err… none, it’s a direct connection, port UDP is open and there is no turn server (the OP asked for that if I understand correctly). No idea if it works also with turn server.

sorry, it was a question for the OP., as OP mentioned that the server is behind a proxy

That’s the trouble with not using quoting…
anyway, I’m also proxying port 443 and I use nginx. In fact my host nginx proxies the nginx in my jitsi container and the UDP port is natted directly to the container.

got it

thanks

try to set this
org.jitsi.videobridge.SINGLE_PORT_HARVESTER_PORT=10001
in your /etc/jitsi/videobridge/sip-communicator.properties

Hi
Is there a similar config parameter for setting the 4443 TCP port as well? As far as I understand, either one can be used.

Thank you. It works for now!