Additional videobridge fails

Hello,
I tried to install a second videobridge on an external server. Checking /var/log/jitsi/jvb.log it brings up:

root@Server5:~# tail -f /var/log/jitsi/jvb.log
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:174)
… 10 more
2020-06-01 07:56:22.336 INFO: [31] [hostname=webkonferenz-mz-as.de id=shard] MucClient.lambda$getConnectAndLoginCallable$7#648: Logging in.
2020-06-01 07:56:22.337 SEVERE: [31] RetryStrategy$TaskRunner.run#198: org.jivesoftware.smack.sasl.SASLErrorException: SASLError using SCRAM-SHA-1: not-authorized
org.jivesoftware.smack.sasl.SASLErrorException: SASLError using SCRAM-SHA-1: not-authorized
at org.jivesoftware.smack.SASLAuthentication.authenticationFailed(SASLAuthentication.java:292)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1100)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.base/java.lang.Thread.run(Thread.java:834)

Can anyone help please? Whats going wrong?

Here’s sip-communicator.properties (mydomain is the JMS-server):

org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.jitsi.videobridge.DISABLE_TCP_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.jicofo.ALWAYS_TRUST_MODE_ENABLED=true
org.jitsi.videobridge.ENABLE_REST_SHUTDOWN=true
org.jitsi.videobridge.STATISTICS_INTERVAL=5000
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub,muc,colibri,rest
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=mydomain
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.mydomain
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=very_secret :slight_smile:
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.mydomain
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=e499eed5-d7fe-458a-8d65-7dd2b31b9d72
org.jitsi.videobridge.xmpp.user.shard.DISABLE_CERTIFICATE_VERIFICATION=true
org.jitsi.videobridge.PUBSUB_SERVICE=mydomain
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode
org.jitsi.videobridge.xmpp.user.shard.DISABLE_CERTIFICATE_VERIFICATION=true

And here’s /etc/jitsi/videobridge/config

Jitsi Videobridge settings

sets the XMPP domain (default: none)

JVB_HOSTNAME=mydomain

sets the hostname of the XMPP server (default: domain if set, localhost otherwise)

JVB_HOST=mydomain

sets the port of the XMPP server (default: 5275)

JVB_PORT=5347

sets the shared secret used to authenticate to the XMPP server

JVB_SECRET=very_secret :slight_smile:

extra options to pass to the JVB daemon

JVB_OPTS="–apis=rest,xmpp --subdomain=mydomain"

adds java system props that are passed to jvb (default are for home and logging config file)

JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.comm$

Thanks a lot
Werner

Double check these. The error is wrong username or password.

Maybe the reason is another problem:
In /etc/prosody/prosody.cfg.lua I added:
component_ports = { 5347 }
component_interface = “my.server.ip.com

After this entry noone can join or start a meeting. “Unfortunately, something went wrong”

When I changed to “0.0.0.0”

component_interface = “0.0.0.0” joining and starting a meeting is no problem.

And: Though I stopped the service jitsi-videobridge2 I can create a meeting with a video-stream.

Werner

Can I change and choose the password in “org.jitsi.videobridge.xmpp.user.shard.PASSWORD=” freely?
Where do I use this password?