Adding video bridge OK but media fails

hi folks,
new video biridge has been added with no problem (I see the logs on the jicofo)
When I stop jvb on jms and the start jvb2 on the second server, calls fail with error message.
all the jms and jvr are behind the NAT and Fw.
accoding to search on the Google I faced something
disable org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
and add
#org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=private ip of jms
#org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=public ip of jms

however on the jvb2 which IP will I add? public of jms?
Because I have only one public IP address.
By the way if needed I can provide a new Puplic IP for jvb2

on jms:
org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.fqdn
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=Vx2R2#mz
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.fqdn
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=jvb1
org.jitsi.videobridge.DISABLE_TCP_HARVESTER=true
org.jitsi.videobridge.xmpp.user.shard.DISABLE_CERTIFICATE_VERIFICATION=true

on jvb:
org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=public_ip_of_jms
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.fqdn
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=Vx2R2#mz
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.fqdn
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=jvb2
org.jitsi.videobridge.DISABLE_TCP_HARVESTER=true
org.jitsi.videobridge.xmpp.user.shard.DISABLE_CERTIFICATE_VERIFICATION=true

thanks

You need a new public IP for the second bridge or change the port it uses and do the appropriate port forwarding.
Basically the clients receive from jicofo bridge public ip and port where to send media so the same public address and port for two jvbs will not work.

hi Damencho,
thank you for your reply.
just give an new public ip for jvb2 and nat config is enough?
Should I make some config on /etc/jitsi/videobridge/sip-communicator.properties or somewhere?

regards.

Yes, if that jvb uses that public ip to reach the internet the stun you have configured will do its job.

Thank you Damecho,
It is working now.
The guides on the web should be updated.

again thank you.