Adding 2FA to jitsi via mod_auth_custom_http

I just added authentication to my jitsi instance using this description.
It worked great. A user can, after authenticating with the internal password, start a room and other users can join the room anonymously. Just what I was looking for.

But now I would like to authenticate users against an extern 2FA system via mod_auth_custom_http.
See https://modules.prosody.im/mod_auth_custom_http.html

I installed the file to /usr/lib/prosody/modules and change my config:

VirtualHost "jitsi-meet.example.com"
    authentication = "custom_http"

When I now try to authenticate, after the login I am hanging with “Connecting”.

The prosody log tells me:

Mar 16 18:50:01 bosh3584c2c3-ba18-4552-a19b-4b7066dcab58	warn	All available authentication mechanisms are either disabled or not suitable for an insecure connection

So what does this tell me? Is the http_custom not suitable for “insecure connection”? Which insecure connection?
Thanks for any hint!

I took the mod_auth_custom_http (Thanks!) and modified and extended it to work with our 2FA management system privacyidea. So now we can authenticate with two factors to create a new root in jitsi. Looks cool!

The new auth module can be found here