Add sound for participant knocking not working

From the version 2.0.6293 there is a feature about “Add sound for participant knocking”

I currently have this version

ii jitsi-meet 2.0.6433-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.5415-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-turnserver 1.0.5415-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.5415-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.5415-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-570-gb802be83-1 all WebRTC compatible Selective Forwarding Unit (SFU)

And I still don’t get the sound working. How should I enable this feature?

I made the custom to autoenable lobby mode that is quoted in this thread

Thank you

There is nothing to enable … when someone knocks the moderator will hear a sound notification for it.
Do you hear it on meet.jit.si?

No, I don’t hear anything, and neither do the people in my team (they are in other states using different SO, linux, windows, macos, using firefox and chrome, so no cache and browser issues related)

We retried and the knock-knock is only once, it really can be lost during the chat. We thought it was a lot more notorious; but anyway, in our meet it doesn’t even sound like in the meet that you suggested using, also, we don’t see the pop-up window

image

I think something is missing of failing in the settings of our meeting system, but I don’t have an idea of how to fix it or find it

So basically lobby is not working for you. Check your prosody logs, are you moderator when you are expecting to see/hear it?

Well, the lobby is working, because if I click on the Participants icon, I can see my partner request

But in the log there is nothing wrong, look what I got from

/var/log/prosody/prosody.log

Oct 12 16:28:28 meet.treebes.com:muc_lobby_rooms info Set room jid = forthelog@conference.meet.treebes.com as members only
Oct 12 16:28:47 mod_bosh info New BOSH session, assigned it sid ‘2b37d613-3857-4a23-b0e0-50782e28f390’
Oct 12 16:28:47 bosh2b37d613-3857-4a23-b0e0-50782e28f390 info Authenticated as z5qxyogsw2hvghhu@guest.meet.treebes.com
Oct 12 16:30:30 bosh2b37d613-3857-4a23-b0e0-50782e28f390 info BOSH client disconnected: session close
Oct 12 16:30:33 speakerstats.meet.treebes.com:speakerstats_component warn A module has been configured that triggers external events.
Oct 12 16:30:33 speakerstats.meet.treebes.com:speakerstats_component warn Implement this lib to trigger external events.
Oct 12 16:30:33 boshf896d3f9-0e23-4c16-b07c-47408795431b info BOSH client disconnected: session close

You cannot see the popup when participants pane is open, as the notification moves into participants pane. Close participants pane and you will see the notification.

In fact, it was closed all the time, I just opened it to see if it was really in the lobby waiting for access

well, I seem to remember vaguely that this is a classic problem when using internal authentication. Are you using secure domain ?

Yes, using https certified SSL by letsencrypt (my language is spanish)
image

Sorry that’s not what I was meaning.

Aaah, ok
I looked at the setup, the authentication was “internal_plain”, replaced by “internal_hashed”

Also, the link says that in this file

/etc/jitsi/jicofo/jicofo.conf

I should check for this
image

But I don’t get it at all, if I must add something new or edit my current

jicofo {
xmpp: {
client: {
client-proxy: focus.meet.treebes.com
}
trusted-domains: [ “recorder.meet.treebes.com” ]
}
}

That is all that is in my file

possibly you have the ancient file format configuration in sip-communicator.properties

never mind, your problem is lobby. I’m not sure but I remember it’s a problem in Prosody config, maybe that you did set the lobby module in both authenticated and anonymous domains. It should be only in the authenticated domain.

But the lobby knocking people are shown in the screenshot, so lobby is working.

@ArturoRejon do you have any modifications in the client? I don’t see how this will be half working on your side. Do you see any errors in the js console?

The only changes are in the HTML in an aesthetic way, not functional

My lua (sounded like I’m summoning a voodoo spirit in Spanish, hehehe) looks like this
image
and
image

I restarted all services and still nothing

About the js console, I found three errors and 7 warnings, I paste only the errors here

styled.js:302 Failed to initialize Olm, E2EE will be disabled LinkError: WebAssembly.instantiate(): Import #2 module=“a” function=“c” error: function import requires a callable
(anonymous) @ styled.js:302

Logger.js:154 2021-10-13T14:37:06.408Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: abort(LinkError: WebAssembly.instantiate(): Import #2 module=“a” function=“c” error: function import requires a callable). Build with -s ASSERTIONS=1 for more info. Script: null Line: null Column: null StackTrace: RuntimeError: abort(LinkError: WebAssembly.instantiate(): Import #2 module=“a” function=“c” error: function import requires a callable). Build with -s ASSERTIONS=1 for more info.
at ie (https://meet.treebes.com/libs/app.bundle.min.js?v=5415:234:182824)
at https://meet.treebes.com/libs/app.bundle.min.js?v=5415:234:184059
o @ Logger.js:154

popper.js:1 Uncaught (in promise) RuntimeError: abort(LinkError: WebAssembly.instantiate(): Import #2 module=“a” function=“c” error: function import requires a callable). Build with -s ASSERTIONS=1 for more info.
at ie (popper.js:1)
at popper.js:1

After 15 posts it’s still not clear what is not working…

I think I will let this version be like this, and wait for a new one, install it, and check the feature in a clean new version (ignoring my custom changes). I think it would be the easiest way to figure out what in my server is breaking the functionality

Thank you all for your help, if someone has another idea to try in the current version, feel free to share it