Activating public interface for colibri/stats

Dear all,
After updating the jvb to 2.1-416-g2f43d1b4-1, I lost the colibri/stats link to the public IP of the JVB. With the private one it is still working (but if I replace localhost:8080/colibri/stats with [local IP]:8080/colibri/stats, I got Connection refused ).
if I try with the port 9090 (specified for the public interface in the config jvb.json) then I got “Error 404 Not Found”
Please help me to reactivate the statistic feature
Many thanks

org.jitsi.videobridge.rest.private.jetty.port=8080
org.jitsi.videobridge.rest.private.jetty.host=0.0.0.0

in /etc/jitsi/videobridge/sip-communicator.properties

Dear @emrah ,
Thank you for your response. But it doesnot help with those 2 lines. In my previous version (no jvb.json) without these lines, I could access the colibri/stats from the public interface.
Please give me another hints for this configuration
Many thanks

Dear @emrah
Sorry for the previous post. Indeed the two lines you showed me made the difference. The colibri/stats reworks right now. Many thanks.
So why it did work without these lines in the previous version?
Have a nice we.

I’d recommend putting these settings in jvb.conf instead of sip-communicator.properties, as eventually that file will go away. See jitsi-videobridge/rest.md at master · jitsi/jitsi-videobridge · GitHub.

1 Like

because it’s the private interface, it’s not supposed to be exposed to the internet by default. Doc has been updated in 2019 to say just that and using it directly was relying on a deprecated feature.

Use it at least in a more secure way.

keytool -genkeypair -alias myjitsi -keyalg RSA -validity 3600 -keystore /etc/jitsi/videobridge/ssl.store -storepass mypasswd

then in jvb.conf

      private {
          port = 8080
          host = 0.0.0.0
          tls-port = 8443 
          key-store-path = /etc/jitsi/videobridge/ssl.store
          key-store-password = mypasswd
      }