About the compilation problem pod install jitsi-meet-ios-sdk-2.5.3 reported an error

michan@michan-MC ios % pod install

[!] Invalid Podfile file: cannot load such file – /Users/michan/Desktop/jitsi-meet-ios-sdk-2.5.3 2/node_modules/@react-native-community/cli-platform-ios/native_modules.

from /Users/michan/Desktop/jitsi-meet-ios-sdk-2.5.3 2/ios/Podfile:3

-------------------------------------------

workspace ‘jitsi-meet’

require_relative ‘…/node_modules/@react-native-community/cli-platform-ios/native_modules’

-------------------------------------------

Not even according to the https://github.com/jitsi/jitsi-meet/blob/master/doc/mobile.md document.

Xcode operation error:
error: /Users/michan/Desktop/jitsi-meet-ios-sdk-2.5.3 2/ios/Pods/Target Support Files/Pods-jitsi-meet/Pods-jitsi-meet.debug.xcconfig: unable to open file (in target “jitsi-meet” in project “app”) (in target ‘jitsi-meet’ from project ‘app’)

error: /Users/michan/Desktop/jitsi-meet-ios-sdk-2.5.3 2/ios/Pods/Target Support Files/Pods-jitsi-meet/Pods-jitsi-meet.debug.xcconfig: unable to open file (in target “jitsi-meet” in project “app”) (in target ‘jitsi-meet’ from project ‘app’)

error: /Users/michan/Desktop/jitsi-meet-ios-sdk-2.5.3 2/ios/Pods/Target Support Files/Pods-jitsi-meet/Pods-jitsi-meet.debug.xcconfig: unable to open file (in target “jitsi-meet” in project “app”) (in target ‘jitsi-meet’ from project ‘app’)

Have you run npm install ?

Thank you. I just found out why. Since my system is above 10.11, I need to add-- unsafe-perm=true.

Npm install-unsafe-perm=true

1 Like