Ability to Disable Private Chat in Jitsi Meet


I joined the community meeting yesterday and wasn’t sure if unanswered questions were reviewed and replied to so thought I would post it here.

I’m a CoderDojo champion and am trying to find the right tool to support our Dojo that has moved online for the foreseeable future. I have been trying a number of free products and I cant find one that has the multi screen sharing I understand Jisti can do. So we don’t see pictures we see screen miniatures and then zoom in to see what the young people are doing.

One thing, especially with working with young people is to be able to make sure that the safeguarding policies are adhered to. In this instance the ability for anyone to meet privately with a young person needs to be dis encouraged. Is this a feature that is possible and I have just not seen that setting, or would that involve development? Is it something you could implement, if so how does it get onto the development list (Which I am sure is big anyway!) Love what I have seen so far.

Thanks for reading this


You can disable with a style sheet trick in all.css (or implement a 2nd CSS for customisations so your changes don’t get overwritten on upgrades.


thanks, it’s an interesting idea but how can you implement a second Css without changing the index.html file… that would itself be overwritten on upgrade ?

Several ways. You can use a different default file for the site that replicates or customizes the functionality of index.html & use redirects & matching to get round, or you can have a 2nd customized home directory structure (copy /usr/share/jitsi-meet to say /usr/share/jitsi-meet-custom) as the default that won’t get overwritten (change apache or nginx conf files accordingly for directories and aliases to .js files) & you can manually apply changes on update doing a diff between the 2 directory structures.

I tried a few combinations and came up with the squared root of nothing. Where exactly are you inserting this css magic instruction ?

sorry - I edited the post earlier -


works except all items on the moderator menu too goes… just working it so just the last item not displayed - will post full solution tomorrow

Awful :slight_smile:
In this case I will steal your thunder:


I don’t understand why it works yet. From my understanding of CSS it should not work. It means that I don’t understand CSS, really. Edit: I saw it work and now it don’t. I must have dreamed.

yes. This is less useless:
*[id^=‘privmsglink_’] {display:none}
not perfect, though.