A disconnect loop after I try to screenshare on my own instance

Hey guys I just installed jitsi. but whenever I try to screenshare, it puts it in a constant loop “you have been disconnected” and everytime it happens I see three/four of me for a sec. idk what to do.

Does it work if you just open 3 tabs, ignore the screensharing for now?
If it doesn’t work for 3 tabs, it is firewall, port forwarding or jvb not announcing its public address issue, check https://jitsi.org/qi advanced section for more info.

The JS console gave this:
XML Parsing Error: mismatched tag. Expected: . Location: https://jitsi.example.com/http-bind?room=room1 Line Number 6, Column 3: http-bind:6:3

Error: Not connected lib-jitsi-meet.min.js:1:168718

AbortError: The fetching process for the media resource was aborted by the user agent at the user’s request.

Is this the first error you see? Maybe show to complete log …

[Exception… “Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIAppStartup.secondsSinceLastOSRestart]” nsresult: “0x80004001 (NS_ERROR_NOT_IMPLEMENTED)” location: “JS frame :: resource:///modules/BrowserGlue.jsm :: _collectStartupConditionsTelemetry :: line 1510” data: no] BrowserGlue.jsm:1510:9
uncaught exception: 2147746065 SessionStore.jsm:1325:22
Loading failed for the with source “moz-extension://672b51bd-9888-42be-8ea2-50ab13b1e605/background.js”. _generated_background_page.html:5:1
Loading failed for the with source “moz-extension://5f1a095c-21e0-4d6f-be7e-9ae2926dc11a/background.js”. _generated_background_page.html:5:1
Loading failed for the with source “moz-extension://c1fca92c-1ac8-45da-b4eb-9b4b6319c6ed/lib/module_shim.js”. _generated_background_page.html:5:1
Loading failed for the with source “moz-extension://c1fca92c-1ac8-45da-b4eb-9b4b6319c6ed/lib/intervention_helpers.js”. _generated_background_page.html:6:1
Loading failed for the with source “moz-extension://c1fca92c-1ac8-45da-b4eb-9b4b6319c6ed/data/injections.js”. _generated_background_page.html:7:1
Loading failed for the with source “moz-extension://c1fca92c-1ac8-45da-b4eb-9b4b6319c6ed/data/picture_in_picture_overrides.js”. _generated_background_page.html:8:1
Loading failed for the with source “moz-extension://c1fca92c-1ac8-45da-b4eb-9b4b6319c6ed/data/ua_overrides.js”. _generated_background_page.html:9:1
Loading failed for the with source “moz-extension://c1fca92c-1ac8-45da-b4eb-9b4b6319c6ed/lib/about_compat_broker.js”. _generated_background_page.html:10:1
Loading failed for the with source “moz-extension://c1fca92c-1ac8-45da-b4eb-9b4b6319c6ed/lib/custom_functions.js”. _generated_background_page.html:11:1
Loading failed for the with source “moz-extension://c1fca92c-1ac8-45da-b4eb-9b4b6319c6ed/lib/injections.js”. _generated_background_page.html:12:1
Loading failed for the with source “moz-extension://c1fca92c-1ac8-45da-b4eb-9b4b6319c6ed/lib/picture_in_picture_overrides.js”. _generated_background_page.html:13:1
Loading failed for the with source “moz-extension://c1fca92c-1ac8-45da-b4eb-9b4b6319c6ed/lib/ua_overrides.js”. _generated_background_page.html:14:1
Loading failed for the with source “moz-extension://c1fca92c-1ac8-45da-b4eb-9b4b6319c6ed/run.js”. _generated_background_page.html:15:1
Loading failed for the with source “moz-extension://22878b29-1a59-4c34-8e85-98cc94904175/build/buildSettings.js”. _generated_background_page.html:5:1
Loading failed for the with source “moz-extension://22878b29-1a59-4c34-8e85-98cc94904175/background/startBackground.js”. _generated_background_page.html:6:1
Key event not available on some keyboard layouts: key=“r” modifiers=“accel,alt” id=“key_toggleReaderMode” browser.xul
Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox” browser.xul
Loading failed for the with source “https://get.s-onetag.com/f31b0467-497f-4b91-86b5-6219f9a80f5e/tag.min.js”. table.php:1:1
Loading failed for the with source “https://contextual.media.net/dmedianet.js?cid=8CUK7Z630”. table.php:24:1
Loading failed for the with source “https://www.googletagmanager.com/gtag/js?id=UA-95786-1”. table.php:26:1
Loading failed for the with source “https://get.s-onetag.com/f31b0467-497f-4b91-86b5-6219f9a80f5e/tag.min.js”. table.php:35:1
Loading failed for the with source “https://get.s-onetag.com/f31b0467-497f-4b91-86b5-6219f9a80f5e/tag.min.js”. table.php:37:1
Loading failed for the with source “https://contextual.media.net/nmedianet.js?cid=8CUK7Z630&https=1”. table.php:403:1
Loading failed for the with source “https://contextual.media.net/nmedianet.js?cid=8CUK7Z630&https=1”. table.php:425:1
Loading failed for the with source “https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js”. table.php:1917:1
PopupNotifications._onButtonEvent: Button click happened before the window was focused
2020-09-13T16:23:16.008Z [modules/RTC/RTCUtils.js] <_newGetUserMediaWithConstraints/</<>: onUserMediaSuccess lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.012Z [modules/RTC/JitsiLocalTrack.js] <_setStream>: Setting new MSID: {699b3600-ec93-47a7-aa79-da2787285caa} {59416dc9-5f12-42ef-bd3c-c0c669d94d8c} on LocalTrack[undefined,audio] lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.013Z [modules/RTC/JitsiLocalTrack.js] <_setStream>: Setting new MSID: {25ac5bc3-db77-48a2-a159-40749ff63a1e} {5a1b70a0-699c-480d-8d11-da01e5c6c62c} on LocalTrack[undefined,video] lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.044Z [conference.js] : Initialized with 2 local tracks app.bundle.min.js:81:11920
2020-09-13T16:23:16.067Z [modules/xmpp/xmpp.js] : JID lfoe0dzzdxz4d8zf@jitsi.example.com/CspJL3s9 using MUC nickname 2665820d lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.069Z [modules/xmpp/ChatRoom.js] Joined MUC as room1@conference.jitsi.example.com/2665820d lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.070Z [modules/e2eping/e2eping.js] Initializing e2e ping; pingInterval=10000, analyticsInterval=60000. lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.071Z [modules/connectivity/ParticipantConnectionStatus.js] RtcMuteTimeout set to: 10000 lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.075Z [modules/statistics/AvgRTPStatsReporter.js] Avg RTP stats will be calculated every 15 samples lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.077Z [JitsiConference.js] : backToP2PDelay: 5 lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.077Z [modules/videosipgw/VideoSIPGW.js] creating VideoSIPGW lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.082Z [modules/UI/videolayout/SmallVideo.js] : Displaying avatar-with-name for 2665820d, data: [{“isCurrentlyOnLargeVideo”:true,“isHovered”:false,“isAudioOnly”:false,“tileViewActive”:false,“isVideoPlayable”:null,“hasVideo”:true,“connectionStatus”:null,“videoStream”:false,“isVideoMuted”:false,“videoStreamMuted”:“no stream”}] app.bundle.min.js:81:11920
2020-09-13T16:23:16.115Z [features/base/lastn] There is no active conference, not updating last N app.bundle.min.js:81:11920
2020-09-13T16:23:16.132Z [JitsiConference.js] <ie.prototype._doReplaceTrack>: _doReplaceTrack - no JVB JingleSession lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.132Z [JitsiConference.js] <ie.prototype._doReplaceTrack>: _doReplaceTrack - no P2P JingleSession lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.132Z [JitsiConference.js] <ie.prototype._doReplaceTrack>: _doReplaceTrack - no JVB JingleSession lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.133Z [JitsiConference.js] <ie.prototype._doReplaceTrack>: _doReplaceTrack - no P2P JingleSession lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.134Z [modules/remotecontrol/RemoteControl.js] : Initializing remote control. app.bundle.min.js:81:11920
2020-09-13T16:23:16.135Z [modules/xmpp/moderator.js] <l.prototype.setFocusUserJid>: Focus jid set to: undefined lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.136Z [modules/xmpp/moderator.js] <l.prototype.createConferenceIq>: Session ID: null machine UID: 61d30a3c37712dede9b29b13bd94d64b lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.142Z [features/base/tracks] <g/</</</<>: Replace audio track - unmuted app.bundle.min.js:81:11920
2020-09-13T16:23:16.146Z [features/base/tracks] <g/</</</<>: Replace video track - unmuted app.bundle.min.js:81:11920
2020-09-13T16:23:16.204Z [modules/UI/videolayout/VideoLayout.js] : Enforcing large video update for stream change app.bundle.min.js:81:11920
2020-09-13T16:23:16.207Z [modules/UI/videolayout/SmallVideo.js] : Displaying blackness-with-name for 2665820d, data: [{“isCurrentlyOnLargeVideo”:true,“isHovered”:false,“isAudioOnly”:false,“tileViewActive”:false,“isVideoPlayable”:true,“hasVideo”:true,“connectionStatus”:null,“videoStream”:true,“isVideoMuted”:false,“videoStreamMuted”:false}] app.bundle.min.js:81:11920
2020-09-13T16:23:16.333Z [features/base/devices] Device list updated:
audioInput:
Built-in Audio Analog Stereo[VfAJauNdy30x3y/MYOMBXQtt/NCd3b2SFkrcgyipxu4=]
Monitor of Built-in Audio Analog Stereo[xZD+/kTMJiMVgL/NZJ2ly6py6NgwaubGfIHDgiGXnNw=]
audioOutput:

videoInput:
HP Truevision HD: HP Truevision[2oE0DOT8Q8wmgZKCdRWnt6ZEWGy/RoySaBmnqEdmD7c=]
HP Truevision HD: HP Truevision[2oE0DOT8Q8wmgZKCdRWnt6ZEWGy/RoySaBmnqEdmD7c=] app.bundle.min.js:81:11920
2020-09-13T16:23:16.381Z [features/base/devices] Device list updated:
audioInput:
Built-in Audio Analog Stereo[VfAJauNdy30x3y/MYOMBXQtt/NCd3b2SFkrcgyipxu4=]
Monitor of Built-in Audio Analog Stereo[xZD+/kTMJiMVgL/NZJ2ly6py6NgwaubGfIHDgiGXnNw=]
audioOutput:

videoInput:
HP Truevision HD: HP Truevision[2oE0DOT8Q8wmgZKCdRWnt6ZEWGy/RoySaBmnqEdmD7c=]
HP Truevision HD: HP Truevision[2oE0DOT8Q8wmgZKCdRWnt6ZEWGy/RoySaBmnqEdmD7c=] app.bundle.min.js:81:11920
2020-09-13T16:23:16.385Z [features/base/devices] Device list updated:
audioInput:
Built-in Audio Analog Stereo[VfAJauNdy30x3y/MYOMBXQtt/NCd3b2SFkrcgyipxu4=]
Monitor of Built-in Audio Analog Stereo[xZD+/kTMJiMVgL/NZJ2ly6py6NgwaubGfIHDgiGXnNw=]
audioOutput:

videoInput:
HP Truevision HD: HP Truevision[2oE0DOT8Q8wmgZKCdRWnt6ZEWGy/RoySaBmnqEdmD7c=]
HP Truevision HD: HP Truevision[2oE0DOT8Q8wmgZKCdRWnt6ZEWGy/RoySaBmnqEdmD7c=] app.bundle.min.js:81:11920
2020-09-13T16:23:16.409Z [modules/UI/videolayout/LargeVideoManager.js] <scheduleLargeVideoUpdate/<>: hover in 2665820d app.bundle.min.js:81:11920
wasm streaming compile failed: TypeError: Response has unsupported MIME type rnnoise-processor.min.js:1:4949
falling back to ArrayBuffer instantiation rnnoise-processor.min.js:1:4988
2020-09-13T16:23:16.857Z [modules/RTC/RTCUtils.js] : Using the new gUM flow lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.858Z [modules/RTC/RTCUtils.js] <newObtainAudioAndVideoPermissions/i<>: Got media constraints: lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.873Z [modules/RTC/RTCUtils.js] <_newGetUserMediaWithConstraints/</<>: onUserMediaSuccess lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.873Z [modules/RTC/JitsiLocalTrack.js] <_setStream>: Setting new MSID: {093e1001-20cf-46ad-86a9-67e882a94834} {f79b0dc8-83be-4c5e-93d5-e52808998543} on LocalTrack[undefined,audio] lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.875Z [modules/detection/VADAudioAnalyser.js] <_trackAdded/this._vadInitTracker<>: Created VAD emitter for track: Built-in Audio Analog Stereo lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.985Z [modules/xmpp/moderator.js] <l.prototype.setFocusUserJid>: Focus jid set to: focus@auth.jitsi.example.com lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.987Z [modules/xmpp/moderator.js] <l.prototype.parseConfigOptions>: Authentication enabled: false lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.987Z [modules/xmpp/moderator.js] <l.prototype.parseConfigOptions>: External authentication enabled: false lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:16.992Z [modules/xmpp/moderator.js] <l.prototype.parseConfigOptions>: Sip gateway enabled: false lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:17.173Z [modules/xmpp/ChatRoom.js] : entered room1@conference.jitsi.example.com/focus lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:17.173Z [modules/xmpp/ChatRoom.js] <_initFocus>: Ignore focus: room1@conference.jitsi.example.com/focus, real JID: focus@auth.jitsi.example.com/focus14234056033 lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:17.178Z [modules/version/ComponentsVersions.js] <s.prototype.processVersions/<>: Got xmpp version: Prosody(0.11.2,Linux) lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:17.178Z [modules/version/ComponentsVersions.js] <s.prototype.processVersions/<>: Got focus version: JiCoFo(1.0.626,Linux) lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:17.179Z [conference.js] <_setupListeners/<>: My role changed, new role: none app.bundle.min.js:81:11920
2020-09-13T16:23:17.184Z [modules/xmpp/ChatRoom.js] : (TIME) MUC joined: 15896 lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:17.190Z [features/base/conference] : setReceiverVideoConstraint: 720 app.bundle.min.js:81:11920
2020-09-13T16:23:17.242Z [modules/xmpp/ChatRoom.js] : Subject is changed to lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:17.530Z [conference.js] <_setupListeners/<>: My role changed, new role: moderator app.bundle.min.js:81:11920
2020-09-13T16:23:17.575Z [modules/xmpp/ChatRoom.js] <_initFocus>: Ignore focus: room1@conference.jitsi.example.com/focus, real JID: focus@auth.jitsi.example.com/focus14234056033 lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:49.497Z [modules/RTC/RTCUtils.js] : Using the new gUM flow lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:49.497Z [modules/RTC/ScreenObtainer.js] : Using getDisplayMedia for screen sharing lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.408Z [modules/RTC/JitsiLocalTrack.js] <_setStream>: Setting new MSID: {e418f11d-f42b-4335-a17c-fd2bb9111d3d} {e013ea7e-7b82-45e6-b519-816f1c1e593d} on LocalTrack[undefined,video] lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.410Z [JitsiMeetJS.js] : MediaStreamTrack contentHint attribute not supported lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.412Z [JitsiConference.js] <ie.prototype._doReplaceTrack>: _doReplaceTrack - no JVB JingleSession lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.412Z [JitsiConference.js] <ie.prototype._doReplaceTrack>: _doReplaceTrack - no P2P JingleSession lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.431Z [features/base/tracks] <g/</</</<>: Replace video track - unmuted app.bundle.min.js:81:11920
2020-09-13T16:23:54.451Z [modules/UI/videolayout/VideoLayout.js] : Enforcing large video update for stream change app.bundle.min.js:81:11920
2020-09-13T16:23:54.451Z [modules/UI/videolayout/SmallVideo.js] : Displaying avatar-with-name for 2665820d, data: [{“isCurrentlyOnLargeVideo”:true,“isHovered”:false,“isAudioOnly”:false,“tileViewActive”:false,“isVideoPlayable”:false,“hasVideo”:true,“connectionStatus”:null,“videoStream”:true,“isVideoMuted”:true,“videoStreamMuted”:false}] app.bundle.min.js:81:11920
2020-09-13T16:23:54.459Z [modules/UI/videolayout/LargeVideoManager.js] <scheduleLargeVideoUpdate/<>: hover in 2665820d app.bundle.min.js:81:11920
2020-09-13T16:23:54.468Z [conference.js] <_switchToScreenSharing/<>: Screen sharing started app.bundle.min.js:81:11920
2020-09-13T16:23:54.488Z [modules/UI/videolayout/SmallVideo.js] : Displaying blackness-with-name for 2665820d, data: [{“isCurrentlyOnLargeVideo”:true,“isHovered”:false,“isAudioOnly”:false,“tileViewActive”:false,“isVideoPlayable”:true,“hasVideo”:true,“connectionStatus”:null,“videoStream”:true,“isVideoMuted”:false,“videoStreamMuted”:false}] app.bundle.min.js:81:11920
2020-09-13T16:23:54.546Z [features/base/devices] Device list updated:
audioInput:
Built-in Audio Analog Stereo[VfAJauNdy30x3y/MYOMBXQtt/NCd3b2SFkrcgyipxu4=]
Monitor of Built-in Audio Analog Stereo[xZD+/kTMJiMVgL/NZJ2ly6py6NgwaubGfIHDgiGXnNw=]
audioOutput:

videoInput:
HP Truevision HD: HP Truevision[2oE0DOT8Q8wmgZKCdRWnt6ZEWGy/RoySaBmnqEdmD7c=]
HP Truevision HD: HP Truevision[2oE0DOT8Q8wmgZKCdRWnt6ZEWGy/RoySaBmnqEdmD7c=] app.bundle.min.js:81:11920
2020-09-13T16:23:54.752Z [JitsiMeetJS.js] : UnhandledError: null Script: null Line: null Column: null StackTrace: lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.754Z [modules/xmpp/strophe.util.js] <t.a/r.Strophe.log>: Strophe: request id 17.1 error 413 happened lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.754Z [modules/xmpp/strophe.util.js] <t.a/r.Strophe.log>: Strophe: request errored, status: 413, number of errors: 1 lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.755Z [modules/xmpp/xmpp.js] : (TIME) Strophe disconnecting: 53466 lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.758Z [modules/xmpp/xmpp.js] : (TIME) Strophe disconnected: 53469 lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.759Z [modules/xmpp/strophe.ping.js] : Ping interval cleared lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.759Z [modules/xmpp/xmpp.js] : XMPP connection dropped! lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.760Z [modules/statistics/statistics.js] <b.sendAnalyticsAndLog>: {“type”:“operational”,“action”:“connection.failed”,“attributes”:{“error_type”:“connection.droppedError”,“error_message”:“connection-dropped-error”,“suspend_time”:6,“time_since_last_success”:6861}} lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.768Z [features/overlay] : The conference will be reloaded after 27 seconds. app.bundle.min.js:81:11920
2020-09-13T16:23:54.777Z [modules/UI/videolayout/SmallVideo.js] : Displaying video for 2665820d, data: [{“isCurrentlyOnLargeVideo”:false,“isHovered”:false,“isAudioOnly”:false,“tileViewActive”:false,“isVideoPlayable”:true,“hasVideo”:true,“connectionStatus”:null,“videoStream”:true,“isVideoMuted”:false,“videoStreamMuted”:false}] app.bundle.min.js:81:11920
2020-09-13T16:23:54.787Z [features/base/lastn] There is no active conference, not updating last N app.bundle.min.js:81:11920
2020-09-13T16:23:54.794Z [modules/UI/videolayout/VideoLayout.js] : Missed avatar update - no small video yet for local app.bundle.min.js:81:11920
2020-09-13T16:23:54.800Z [modules/UI/videolayout/VideoLayout.js] : Missed avatar update - no small video yet for local app.bundle.min.js:81:11920
2020-09-13T16:23:54.805Z [modules/UI/videolayout/SmallVideo.js] : Remove thumbnail 2665820d app.bundle.min.js:81:11920
2020-09-13T16:23:54.815Z [modules/e2eping/e2eping.js] : Stopping e2eping lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.818Z [modules/xmpp/ChatRoom.js] : do leave room1@conference.jitsi.example.com/2665820d lib-jitsi-meet.min.js:10:26474
2020-09-13T16:23:54.819Z [modules/detection/VADAudioAnalyser.js] <_trackRemoved/this._vadInitTracker<>: Removing track from VAD detection - Built-in Audio Analog Stereo lib-jitsi-meet.min.js:10:26474
XML Parsing Error: mismatched tag. Expected: .
Location: https://jitsi.example.com/http-bind?room=room1
Line Number 6, Column 3: http-bind:6:3
Error: Not connected lib-jitsi-meet.min.js:1:168718
2020-09-13T16:23:55.140Z [modules/UI/videolayout/LargeVideoManager.js] <scheduleLargeVideoUpdate/<>: hover in local app.bundle.min.js:81:11920
2020-09-13T16:23:56.378Z [features/base/redux] : redux state persisted. 349bce375e20c84a520982dd2ebc6ebe -> 8e2e623d18c2fad41d5d9ae59efcc39b app.bundle.min.js:81:11920
2020-09-13T16:24:22.784Z [features/app] <v/<>: Reloading the conference using URL: https://jitsi.example.com/room1 app.bundle.min.js:81:11920
2020-09-13T16:24:22.790Z [modules/xmpp/xmpp.js] : (TIME) Strophe disconnecting: 81503 lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:22.792Z [modules/xmpp/strophe.util.js] <t.a/r.Strophe.log>: Strophe: Disconnect was called because: undefined lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:22.794Z [modules/xmpp/strophe.util.js] <t.a/r.Strophe.log>: Strophe: Disconnect was called before Strophe connected to the server lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:22.795Z [modules/xmpp/xmpp.js] : (TIME) Strophe disconnected: 81506 lib-jitsi-meet.min.js:10:26474
(TIME) index.html loaded: 1301 room1:32:17
2020-09-13T16:24:24.790Z [modules/browser/BrowserCapabilities.js] This appears to be firefox, ver: 68.0 lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:26.643Z [features/base/lastn] There is no active conference, not updating last N app.bundle.min.js:81:11920
2020-09-13T16:24:26.645Z [modules/UI/videolayout/VideoLayout.js] : Missed avatar update - no small video yet for undefined app.bundle.min.js:81:11920
2020-09-13T16:24:26.645Z [features/base/lastn] There is no active conference, not updating last N app.bundle.min.js:81:11920
2020-09-13T16:24:26.671Z [features/base/config] <f/<>: Extending config with: {“startWithAudioMuted”:false,“startWithVideoMuted”:true} app.bundle.min.js:81:11920
2020-09-13T16:24:26.678Z [modules/connectivity/NetworkInfo.js] : updateNetworkInfo lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:26.684Z [features/base/media] Start muted: video app.bundle.min.js:81:11920
2020-09-13T16:24:26.687Z [features/base/media] Start audio only set to false app.bundle.min.js:81:11920
2020-09-13T16:24:26.692Z [features/analytics] <k/</<>: Loaded 0 analytics handlers app.bundle.min.js:81:11920
2020-09-13T16:24:26.692Z [modules/statistics/AnalyticsAdapter.js] : Disposing of analytics adapter. lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:26.838Z [features/base/devices] setAudioOutputDevice: undefined[default] app.bundle.min.js:81:11920
2020-09-13T16:24:26.853Z [features/base/devices] <u/</</<>: Failed to set audio output device.
Default audio output device will be used instead Error: Audio output device change is not supported app.bundle.min.js:81:11920
2020-09-13T16:24:26.854Z [index.web] (TIME) document ready: 4067 app.bundle.min.js:81:11920
2020-09-13T16:24:27.116Z [modules/RTC/RTCUtils.js] <init/<>: Available devices: lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:27.117Z [features/base/devices] Device list updated:
audioInput:
[VfAJauNdy30x3y/MYOMBXQtt/NCd3b2SFkrcgyipxu4=]
[xZD+/kTMJiMVgL/NZJ2ly6py6NgwaubGfIHDgiGXnNw=]
audioOutput:

videoInput:
[2oE0DOT8Q8wmgZKCdRWnt6ZEWGy/RoySaBmnqEdmD7c=]
[2oE0DOT8Q8wmgZKCdRWnt6ZEWGy/RoySaBmnqEdmD7c=] app.bundle.min.js:81:11920
2020-09-13T16:24:27.132Z [modules/xmpp/xmpp.js] <_initStrophePlugins>: P2P STUN servers: lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:27.138Z [modules/xmpp/xmpp.js] : (TIME) Strophe connecting: 4351 lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:27.142Z [modules/RTC/RTCUtils.js] : Using the new gUM flow lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:27.143Z [modules/RTC/RTCUtils.js] <newObtainAudioAndVideoPermissions/i<>: Got media constraints: lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:28.534Z [modules/xmpp/XmppConnection.js] <_maybeEnableStreamResume>: Stream resume enabled, but WebSockets are not enabled lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:28.535Z [modules/xmpp/xmpp.js] : (TIME) Strophe connected: 5748 lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:28.535Z [modules/xmpp/xmpp.js] : My Jabber ID: glp0noa4zeo8pqz2@jitsi.example.com/ZQmmIQxt lib-jitsi-meet.min.js:10:26474
2020-09-13T16:24:28.586Z [features/base/redux] : redux state persisted. 8e2e623d18c2fad41d5d9ae59efcc39b -> 769409f01249d73c1f1c3330f2ecaba6 app.bundle.min.js:81:11920
2020-09-13T16:24:28.871Z [modules/xmpp/strophe.ping.js] : XMPP pings will be sent every 10000 ms lib-jitsi-meet.min.js:10:26474

bosh returned 413 error. Try opening your bosh URL needs to look like: https://meet.jit.si/http-bind Check prosody error logs what is the problem.

Ok, I’ve got the error. It is “portmanager error Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281”. I’ll look into my firewall settings/prosody config.

It also spams the connection error loop if the room starts off with the camera disabled and I enable it. But it doesn’t do the connection error when I start out the the camera enabled.

Here is the entire log:

Sep 13 17:51:46 startup info Hello and welcome to Prosody version 0.11.2
Sep 13 17:51:46 startup info Prosody is using the select backend for connection handling
Sep 13 17:51:46 portmanager info Activated service ‘c2s’ on [::]:5222, [*]:5222
Sep 13 17:51:46 portmanager info Activated service ‘legacy_ssl’ on no ports
Sep 13 17:51:46 portmanager info Activated service ‘http’ on [::]:5280, [*]:5280
Sep 13 17:51:46 portmanager error Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281
Sep 13 17:51:46 portmanager error Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281
Sep 13 17:51:46 portmanager info Activated service ‘https’ on no ports
Sep 13 17:51:46 portmanager info Activated service ‘s2s’ on [::]:5269, [*]:5269
Sep 13 17:51:46 general info Starting conference duration timer for conference.jitsi.example.com
Sep 13 17:51:46 conferenceduration.jitsi.example.com:conference_duration_component info No muc component found, will listen for it: conference.jitsi.example.com
Sep 13 17:51:47 general info Starting speakerstats for conference.jitsi.example.com
Sep 13 17:51:47 speakerstats.jitsi.example.com:speakerstats_component info No muc component found, will listen for it: conference.jitsi.example.com
Sep 13 17:51:47 hostmanager warn localhost: Option ‘https_ports’ has no effect for virtual hosts - put it in the server-wide section instead
Sep 13 17:51:47 portmanager info Activated service ‘component’ on [127.0.0.1]:5347, [::1]:5347
Sep 13 17:51:47 jitsi.example.com:muc_lobby_rooms info Lobby component loaded lobby.jitsi.example.com
Sep 13 17:51:47 speakerstats.jitsi.example.com:speakerstats_component info Hook to muc events on conference.jitsi.example.com
Sep 13 17:51:47 conference.jitsi.example.com:muc_domain_mapper info Loading mod_muc_domain_mapper for host jitsi.example.com!
Sep 13 17:51:47 conference.jitsi.example.com:muc_domain_mapper info Loading mod_muc_domain_mapper for host conferenceduration.jitsi.example.com!
Sep 13 17:51:47 conference.jitsi.example.com:muc_domain_mapper info Loading mod_muc_domain_mapper for host internal.auth.jitsi.example.com!
Sep 13 17:51:47 conference.jitsi.example.com:muc_domain_mapper info Loading mod_muc_domain_mapper for host speakerstats.jitsi.example.com!
Sep 13 17:51:47 conference.jitsi.example.com:muc_domain_mapper info Loading mod_muc_domain_mapper for host localhost!
Sep 13 17:51:47 conference.jitsi.example.com:muc_domain_mapper info Loading mod_muc_domain_mapper for host auth.jitsi.example.com!
Sep 13 17:51:47 conference.jitsi.example.com:muc_domain_mapper info Loading mod_muc_domain_mapper for host focus.jitsi.example.com!
Sep 13 17:51:47 conference.jitsi.example.com:muc_domain_mapper info Loading mod_muc_domain_mapper for host conference.jitsi.example.com!
Sep 13 17:51:47 conference.jitsi.example.com:muc_domain_mapper info Loading mod_muc_domain_mapper for host lobby.jitsi.example.com!
Sep 13 17:51:47 conferenceduration.jitsi.example.com:conference_duration_component info Hook to muc events on conference.jitsi.example.com
Sep 13 17:51:56 conference.jitsi.example.com:muc_domain_mapper warn Session filters applied
Sep 13 17:51:56 c2s55926a40e440 info Client connected
Sep 13 17:51:56 conference.jitsi.example.com:muc_domain_mapper warn Session filters applied
Sep 13 17:51:56 c2s55926a421d00 info Client connected
Sep 13 17:52:02 c2s55926a40e440 info Stream encrypted (TLSv1.3 with TLS_AES_256_GCM_SHA384)
Sep 13 17:52:02 c2s55926a421d00 info Stream encrypted (TLSv1.3 with TLS_AES_256_GCM_SHA384)
Sep 13 17:52:02 c2s55926a421d00 info Authenticated as focus@auth.jitsi.example.com
Sep 13 17:52:03 focus.jitsi.example.com:component warn Component not connected, bouncing error for:
Sep 13 17:52:06 conference.jitsi.example.com:muc_domain_mapper warn Session filters applied
Sep 13 17:52:06 c2s55926a492c70 info Client connected
Sep 13 17:52:06 c2s55926a492c70 info Stream encrypted (TLSv1.3 with TLS_AES_256_GCM_SHA384)
Sep 13 17:52:07 jcp55926a4aaa10 info Incoming Jabber component connection
Sep 13 17:52:07 c2s55926a492c70 info Authenticated as jvb@auth.jitsi.example.com
Sep 13 17:52:07 focus.jitsi.example.com:component info External component successfully authenticated
Sep 13 17:53:27 conference.jitsi.example.com:muc_domain_mapper warn Session filters applied
Sep 13 17:53:27 mod_bosh info New BOSH session, assigned it sid ‘3bfb3a8a-76e3-4633-89a5-b27185c8c290’
Sep 13 17:53:28 bosh3bfb3a8a-76e3-4633-89a5-b27185c8c290 info Authenticated as rrpesr1vzmfiqpal@jitsi.example.com

No this is not used. Your web server should be proxing to port 5280, that is what is used

I don’t know what the issue might be then, I posted the prosody logs

I purged every debian package the jitsi pulled in
entered the hostname of the url
manually entered the the location of the certs/privkey
rebooted
and the error still persists. Is this most likely a configuration problem or is this a bug?

You are installing from stable, right? Os version and prosody version?

Jitsi-meet version: 2.0.4966-1
prosody version: 0.11.2-1
Debian version: Buster

Hum, have you checked nginx logs for errors? Maybe there are some errors about the certificates …

1 Like

There wasn’t any errors in my nginx logs that I can see
EDIT: You solved it!
I entered “client_max_body_size 20M;” in my /etc/nginx/sites-enabled/jitsi
:slight_smile: Thank you!