5280 port only listening on 127.0.0.1 instead of 0.0.0.0

Hello,

I have nginx proxy server on a different server, and it is supposed to pass traffic to Jitsi server running on 192.168.1.2 using the following config

    server {
        listen       443 ssl http2;
        server_name  meet.mydomain.com;


    # You can increase the limit if your need to.
            client_max_body_size 200M;

            location / {
                ssi on;
                proxy_pass https://192.168.1.2/;
                proxy_set_header X-Forwarded-For $remote_addr;
                proxy_set_header Host $http_host;
            }
            # BOSH
            location /http-bind {
                proxy_pass http://192.168.1.2:5280/http-bind/;
                proxy_set_header X-Forwarded-For $remote_addr;
                proxy_set_header Host $http_host;
            }

            # xmpp websockets
            location /xmpp-websocket {
                proxy_pass              http://192.168.1.2:5280/xmpp-websocket;
                proxy_http_version      1.1;
                proxy_set_header        Upgrade $http_upgrade;
                proxy_set_header        Connection "upgrade";
                proxy_set_header        Host $host;
                tcp_nodelay             on;
            }



    ssl_certificate /etc/letsencrypt/live/mydomain.com/fullchain.pem; 
    ssl_certificate_key /etc/letsencrypt/live/mydomain.com/privkey.pem;

}

However when i ssh into the Jitsi server and look at listening ports I see 5280 is only listening at 127.0.0.1

root@jitsi:~# ss -atn|grep 5280
LISTEN 0      128             127.0.0.1:5280             0.0.0.0:*           
LISTEN 0      128                 [::1]:5280        

How do i make Jisti listen on 0.0.0.0 (which will include 192.168.1.2)?

You may keep the local Nginx on Jitsi server and pass traffic to it.

I dont understand what you mean. I have a primary nginx server which proxies to different subdomains including jitsi. I posted its configuration above. This proxy is showing an error like so

022/07/05 11:02:27 [error] 2262#2262: *790355 connect() failed (111: Connection refused) while connecting to upstream, client: 116.106.13.93, server: meet.mydomain.com, request: "POST /http-bind?room=handydisappointmentsexceedpatiently HTTP/2.0", upstream: "http://192.168.1.2:5280/http-bind/?room=handydisappointmentsexceedpatiently", host: "meet.mydomain.com"

It is not able to connect with port 5280 on the jitsi server. I understand there is another local nginx server running on the jitsi server.

How do I make 5280 available to 0.0.0.0 so that my nginx proxy server can see it.

Prosody is the component that listens on port 5280. The relevant prosody config setting is http_interfaces.

1 Like

Thanks, I added the following to /etc/prosody/conf.d/meet.mydomain.cfg.lua,

http_interfaces = {"0.0.0.0"}

and now have it listening to all interfaces.

# ss -atn|grep 5280
LISTEN 0      128               0.0.0.0:5280             0.0.0.0:*