502 Proxy Error

I solved the problem by adding proxy_read_timeout 1800; to /http-bind location
But I’m not sure this solves everything

Hi hkhait! And thank you for your answer. Can you please tell me in wich config-file I have to add the line?

location /http-bind {
proxy_pass http://localhost:5280/http-bind;
proxy_set_header Host $http_host;
proxy_read_timeout 1800;

1 Like

or use websockets as mentionned here Sometime BOSH http-bind return 502

Tried the timeout setting - didn’t work :roll_eyes:

Hum well upgrade it to websockets then

I’m glad I found the reason of the 502 error. My jitsi server was configured to listen to port 4444 but in the WAF rule on the Sophos firewall port 443 was configured.
Thanks to @tomiboy78

Hi damencho, that fix worked on an SG Firewall. I´m not shrue that it will fix on a XG. and it was a different Problem.

Everything is fine, with an older instance of jitsi. with the latest released version i´m facing the same Problems.

i have the same problems with Sophos UTM. I installed jitsi yesterday, with the actual ubunu updates.
with the local ip works fine, but the external with the WAF and Port 443 is the same error “502 Proxy Error”.

have anyone a idea?

Hello matze-pe,

please have a look in your /etc/nginx/sites-enabled/server.example.local.conf.

Search this line to verify the port jitsi is listening:

server {
listen 4444 ssl http2;

hello chris,
yes i have check this port, here is my settings. The Port 4444 was default.

server {
listen 4444 ssl http2;
listen [::]:4444 ssl http2;
server_name meet.mydomain.de;

ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_prefer_server_ciphers on;

Ok. Since we have a XG I don’t know if it’s the same on UTM…
On the XG I have to create a webserver object for my internal jitsi-server. There I have to set port 4444. The default port 443 will result in the 502 proxy error.

It’s the same with UTM.
I created a real web server “internal IP with port 443 and https”, then a virtual web server with “HTTPS forwarding” and the letsencrpyt cert to a real web server

when changing the real webserver port from 443 to 4444 it runs in timeout, internal can not open the port https://local-IP:4444

its runs :slight_smile:
the realwebserver must have the Port 4444, and the jitsi / ngnix webserver have the UFW Firewall. Here must be allow the TCP Port 4444:

ufw allow 4444/tcp
ufw status (check if open)

Next Problem, i have no video or audio signal in my meeting room.
UDP Ports are open (10000-20000), and a DNAT-Rule too, to the Jitsi Server with UDP10000:20000.
In UFW Firewall on jitsi Server is UDP10000-2000 open too.

have you an idea?

FritzBox are “Exposed Host, all Ports open to Sophos”

Glad it works :grinning:

Don’t forget to edit your /etc/jitsi/videobridge/sip-communicator.properties:


yeeahhh…it works fine :slight_smile: thanks…

i have in my homelab an dynamic public ip. do you have a idea, who can fix it with a batch or a other trick :slight_smile: .?

best regards


You would have to insert a fqdn here and I don’t know if that’s possible :thinking:


Your UTM has to support dynamic ip also.

thanks, but FQDN not works.

I have build a Skript, and run it every day at 5 o’clock:

#clear config
sed -i ‘/NAT_HARVESTER_PUBLIC_ADDRESS/d’ /etc/jitsi/videobridge/sip-communicator.properties
#get IP and renew line
echo org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=$(host -tA meet.mydomain.de | grep address | cut -d " " -f4 ) >> /etc/jitsi/videobridge/sip-communicator.properties
#restart services
service jicofo restart
service jigasi restart
service jitsi-videobridge2 restart