4k webcam configuration

Hi ,

Is anybody already gets the 4k functionnality working with jisti ?
What is the optimal or best congifuration to use ?

I was expecting buying the [BRIO ULTRA HD PRO WEBCAM]
(https://www.logitech.fr/fr-fr/product/12726)

With my actual webcam in 720p I’m tryning to skip the VP8 codec and force the H264 by default.
But it’s result with a poor quality ( ie reslution blocked at 360p despite the resolution is force to 720p with min, max forced to 720 p )

Any suggestion or comments ?

Thanks by advance.

config.js
// Video

// Sets the preferred resolution (height) for local video. Defaults to 720.
//resolution: 720,
resolution: 720,

// How many participants while in the tile view mode, before the receiving video quality is reduced from HD to SD.
// Use -1 to disable.
// maxFullResolutionParticipants: 2,
maxFullResolutionParticipants: -1,


// w3c spec-compliant video constraints to use for video capture. Currently
// used by browsers that return true from lib-jitsi-meet's
// util#browser#usesNewGumFlow. The constraints are independent from
// this config's resolution value. Defaults to requesting an ideal
// resolution of 720p.
constraints: {
     video: {
     aspectRatio: 16 / 9,
     frameRate: {
             max: 30
     },
     height: {
             ideal: 720,
             max: 720,
             min: 720
         }
     }
 },

enableLayerSuspension: true,
preferH264: true,
channelLastN: 5,

// Specify the settings for video quality optimizations on the client.
videoQuality: {
preferredCodec: ‘H264’,
maxBitratesVideo: {
low: 200000,
standard: 500000,
high: 1500000
},
},

useStunTurn: true,
useIPv6: false,
openBridgeChannel: ‘websocket’,

p2p: {
// Enables peer to peer mode. When enabled the system will try to
// establish a direct connection when there are exactly 2 participants
// in the room. If that succeeds the conference will stop sending data
// through the JVB and use the peer to peer connection instead. When a
// 3rd participant joins the conference will be moved back to the JVB
// connection.
enabled: true,

    // Use XEP-0215 to fetch STUN and TURN servers.
    useStunTurn: true,

p2p
{
stunServers: [
{ urls: ‘stun:xxx.xxx.xx:4446’ }
// { urls: ‘stun:meet-jit-si-turnrelay.jitsi.net:443’ }
],

preferH264: true
}


sip-communicator.properties

org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=xxx.xxx.xx:4446
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.xxx.xxx.xx
org.jitsi.videobridge.xmpp.user.shard.USERNAME=xxx
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=xxx
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.xxx.xxx.xx
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=xxx

org.jitsi.service.neomedia.MediaService.ENABLE_H264_FORMAT=true
org.jitsi.service.neomedia.MediaService.ENABLE_FFMPEG_CODECS=true
org.ice4j.ipv6.DISABLED=true
org.jitsi.jicofo.ALWAYS_TRUST_MODE_ENABLED=true
#org.jitsi.jicofo.ENABLE_VP8=false

Can I join your group call can you send me the code of your meeting,
:grinning:

Before I buy the 4k webcam, I will make sure of the capabilities.
At the moment, the connection seems reduced and the HD cameras back to 640x360.
I can not find a way to force to keep the resolution and prevent resolution changes.

From what I’ve experienced, every time you restart the docker container to apply the new res settings, it reverts the config.js file back to the original format.

Have you found a solution to this yet?