.309 Failed to connect/login: undefined-condition

Hi there,
i am trying to set-up a jitsi-server.
I am using a sub-domain ,apache2 with virtualhost-config, Ubuntu 18.04.

i a getting an error in jicofo.log and try to search for it but can’t find anything about that:
org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect().309 Failed to connect/login: undefined-condition You can read more about the meaning of this stream error at
stream:errorNo stream features to proceed with</stream:error>
org.jivesoftware.smack.XMPPException$StreamErrorException: undefined-condition You can read more about the meaning of this stream error at
stream:errorNo stream features to proceed with</stream:error>

maybe somebody can help me and point me in the right direction

Hi, I’m having a similar issue.
Deb 10, nginx, let’s encrypt, dedicated domain.
But it looks like a following issue. Hope I’ve catched enough logs for you.

You should test your configuration at:
at org.jitsi.videobridge.health.Health.doRun(Health.java:266)
java.lang.NoClassDefFoundError: Could not initialize class javax.crypto.JceSecurity
at java.base/javax.crypto.Mac.getInstance(Mac.java:186)
at org.ice4j.stack.StunStack.(StunStack.java:391)
at org.ice4j.stack.StunStack.(StunStack.java:409)
at org.ice4j.ice.Agent.getStunStack(Agent.java:1328)
at org.ice4j.ice.ConnectivityCheckServer.(ConnectivityCheckServer.java:93)
at org.ice4j.ice.Agent.(Agent.java:379)
at org.jitsi.videobridge.ice.IceTransport.createIceAgent(IceTransport.java:252)
at org.jitsi.videobridge.ice.IceTransport.(IceTransport.java:157)
at org.jitsi.videobridge.DtlsTransport.(DtlsTransport.java:128)
at org.jitsi.videobridge.Endpoint.(Endpoint.java:269)
at org.jitsi.videobridge.Endpoint.(Endpoint.java:285)
at org.jitsi.videobridge.Conference.createLocalEndpoint(Conference.java:692)
at org.jitsi.videobridge.health.Health.check(Health.java:83)
at org.jitsi.videobridge.health.Health.doCheck(Health.java:161)
at org.jitsi.videobridge.health.Health.doRun(Health.java:266)
at org.jitsi.utils.concurrent.PeriodicRunnableWithObject.run(PeriodicRunnableWithObject.java:87)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.run(RecurringRunnableExecutor.java:216)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.runInThread(RecurringRunnableExecutor.java:292)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.access$000(RecurringRunnableExecutor.java:36)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor$1.run(RecurringRunnableExecutor.java:328)
2020-04-05 11:28:52.471 INFO: [12] OctoRelayService.start#62: Octo relay is disabled.
2020-04-05 11:28:52.791 WARNING: [57] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$7#643: [MucClient id=shard hostname=localhost] error connecting
org.jivesoftware.smack.XMPPException$StreamErrorException: undefined-condition You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
stream:errorNo stream features to proceed with</stream:error>
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1059)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.base/java.lang.Thread.run(Thread.java:834)

We just faced the same problem after a fresh install (on debain 10) right now. Having the jvb installed on a separate system, we’re getting this error in the jicofo log and in the log of the jvb:

SEVERE: [136] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect().315 Failed to connect/login: undefined-condition You can read more about the meaning of this stream erroro at […]
stream:errorNo stream features to proceed with</stream:error>

Full Error: https://pastebin.com/76aGZmrK

Do you have any suggestions?