2 users-OK, 3 users- one of the first two can't hear\see the third one

Hello.

I was conducting a small test with a friend and we had some issues.

My setup:

ubuntu 18.04, jitsi unstable, nginx, secure domain enabled, p2p disabled, no turn server (for now)
4 vcores, 8GB ram, 200Mbit in\out

User 1 (me,a host): PC, win 10, chrome browser, +audio+ screensharing

User 2( my friend, he lives in UAE, so firewalled) - macbook pro,chrome\safari (latest) audio enabled

=>
Audio and screensharing works

I added another user (user3) using my smartphone connected to my wifi

user3: android, jitsi app, audio+webcam enabled.

I could hear myself talking via a smartphone and see myself on my PC, but my friend didn’t see my webcam and didn’t hear me talking.

He tried then using a VPN but it didn’t help.

What could cause this? Is it because I don’t have a turn server?

Thank you.

3 participants are going through the bridge and you don’t need a turn server if you are not behind some restrictive enterprise network.

Have you followed the quick-install guide and its advanced section about ports opening/forwarding and public & private addresses?

Yes

If installation is on a machine behind NAT

My server is not behind NAT, so I didn’t do it.

  1. Open ports:

80 ALLOW Anywhere
443 ALLOW Anywhere
10000:20000/udp ALLOW Anywhere
22 ALLOW Anywhere
4443 ALLOW Anywhere

  1. /etc/systemd/system.conf modifed as in the guide

r if you are not behind some restrictive enterprise network.

He is behind a restrictive firewall (UAE, they block lots of ports and sometimes even vpn won’t work) but he could hear me and see screen shared from my home PC. He only had problems with the third user(my smartphone connected via my router’s wifi;)

That is interesting, thanks for sharing.
If you open 3 chrome tabs on your PC does it work (I suppose you are not in the local network of jvb)?
When you connect with him p2p what does the local connection information says, how are you connected is there (p2p) sign there?
Not sure how to debug this …
And if you both use meet.jit.si there is no problem, I suppose.

He is not available now (went to bed), I’ll try to make some tests tomorrow. :wink:

f you open 3 chrome tabs on your PC does it work (I suppose you are not in the local network of jvb)?

The server (or rather a VPS, it has got the whole jitsi package-meet, jvb, jicofo) is in a data center in Germany :wink: I connect to it from my home PC.

3 tabs on my PC, 1 smartphone (webcam), one tab is screensharing.
All tabs show the webcam and get the smartphone’s audio.
2 tabs + smartphone show screenshared stuff.

The rest I’ll have to check tomorrow when he is available. (I’ll check both meet.jit.si and my server).

Regards

Hey, demenco!

You know I’m not sure either coz we’ve just tested on my VPS again and it worked fine this time.

As far as I know nothing has changed. This time he could see and hear the third user(me on a smartphone).

I tried firefox and chrome, it worked fine. No idea what went wrong yesterday.

Ignore problems with Firefox. We known of such problems and we will be addressing them soon.

I don’t think I’ve had any problems with firefox though. Actually I prefer using firefox coz when sharing screen it doesn’t pop up a small browser instance,like chrome does, saying “sharing” that you can’t close , only hide, sort of

PS
Actually, I think I know what was different.

Today my smartphones was using mobile internet. Yesterday my smartphone was connected via wi-fi using the internet from my PC. So, I was essentially connected from the same IP address. Could it be the reason? I can’t test it now, but I’ll check it out later today

We tested it again, this time user3(me, smartphone) used wi-fi from my PC and it worked… really strange lol

On a side note, when he used opera I could hear him but he couldn’t hear me (chrome) =))

I think it’s oz he had this setting enabled in Opera - -disable non-proxied UDP. It messes up with webrtc