2 audio and video feeds per participant

I notice that I am receiving 2 audio and 2 video feeds whenever a remote participant joins the meet, one of these videos is empty and does not play anything. The other one plays the actual video of the said participant, why is that the case? And how will we be able to distinguish between the two?

image

Here video 2 is empty, and video 4 shows the actual feed of the joined participant

Screenshot_20220609_200325

Did you enable multi-stream support? Otherwise you should only be getting 1 video element per participant.

How would I check that? Also thanks for the quick response :slight_smile:

If you don’t know then you didn’t turn it on :wink:

Can you share a sample of the code you are using?

I tried running it on the example code as well, where I was still getting the same issue, the only lines changed from the original code were the following.

const options = {
    hosts: {
        domain: 'meet.jit.si',
        muc: 'conference.meet.jit.si'
    },
    serviceUrl:'wss://meet.jit.si/xmpp-websocket?room=roomname',
    deploymentInfo: {
        shard: 'meet-jit-si-ap-mumbai-1-s31',
    },
};

and

    room = connection.initJitsiConference('roomname', confOptions);

where confOptions is the default empty array.

This is the track object for the video that’s not working ( as in, shows nothing )


And this is the track object for the video that is working

if needed I can post the entire JSON objects to my github folder, and upload the link here as well. The only difference I noticed was that for the non-working video, it shows that stream.active is false whereas it is true for the working video. Also the isP2P field is false for the non working video, and is true for the working one. As mentioned before, I am not using multi stream support.

Ah wait. This is the P2P track vs the non-p2p track. As you can see one is disposed even. When in p2p you should use the p2p track, but monitor it for events because it may be removed and the new one will take its place.

Thanks a lot, I disabled p2p through the config and now I am getting only 1 audio and 1 video feed. Cheers!
So if I get this correctly, P2P would only work when there are exactly 2 participants in the video call, once there are 3 or more than 3 P2P stops working and the video bridge takes over right?

Yes

Alright, thanks a lot!

Extremely sorry for re-opening this issue again, but it seems like I actually didn’t fix it ( I must have probably not seen the feeds properly). I did try to disable p2p, but I am still getting two audio and video feeds for the 2nd participant that joins in, for the next participants, however, there is only 1 audio and video feed, therefore I feel like it still has to be some issue with p2p. Here is my config.

const options = {
            hosts: {
                domain: 'meet.jit.si',
                muc: 'conference.meet.jit.si'
            },
            serviceUrl:'wss://meet.jit.si/xmpp-websocket?room=testing123',
            deploymentInfo: {
                environment: 'meet-jit-si',
                envType: 'prod',
                releaseNumber: '2977',
                shard: 'meet-jit-si-ap-mumbai-1-s31',
                region: 'ap-south-1',
                userRegion: 'ap-south-1',
                crossRegion: (!'ap-south-1' || 'ap-south-1' === 'ap-south-1') ? 0 : 1
            },
            p2p: {
                enabled: false
            }

        }

Any suggestions?

Check if a track is disposed and ignore it.

Yeah that’s what I decided to do as well, cheers!