100% CPU on jicofo/java/org.jitsi.utils on fresh Debian Buster 10.3 4 core VM install

Dear community,

After a clean local install, on a VM with 3GB memory and 4 cores assigned, and testing two local clients, both clients are reporting low quality video. Looking into the server I noticed, that, even without clients connected, 100% CPU usage is reported on java | org.jitsi.utils running under the jicofo user:

256 jicofo 20 0 6945268 156772 26968 S 100.3 4.6 2:41.04 java
303 jvb 20 0 6854416 201712 27600 S 3.7 5.9 0:13.37 java

I’m a new user and love to test Jitso. Is this a known problem? Any ideas where to look?

Thanks in advance.

Regards,
Johan

1 Like

Downgrading jicofo to the previous version fixes things, it came with the update from today.

2 Likes

I did a apt-get full-grade command last night and I experience the same thing. How do I downgrade?

Same here

Download:

https://download.jitsi.org/stable/jicofo_1.0-549-1_all.deb

dpkg -i jicofo_1.0-549-1_all.deb

2 Likes

thank you thank you!! it worked and hopefully they will release a fix soon.

Thank you! This indeed worked.

Downgrade should no longer be required, see:

1 Like

Please let me know the steps to downgrade jicofo to jicofo_1.0-549-1

I’m getting the following error on the server after downgrade this package.

The following packages have unmet dependencies.
jitsi-meet : Depends: jicofo (= 1.0-566-1) but 1.0-549-1 is to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

Issue is fixed in the meantime!

We confirm the issue is fixed with Jicofo 1.0-567

1 Like

Verified: apt update installs latest version and doesn’t show the problem. Thanks!

# apt-get update
# apt --fix-broken install