1. More than 2 people cannot perform voice video (only personal video is displayed, no other people's video)

systemctl stop firewalld

Check your firewall. Make sure all required ports are open and accessible. Check port 10000/UDP in particular; make sure it’s open and properly forwarded, if behind a NAT.

● firewalld.service - firewalld - dynamic firewall daemon

● firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
Active: inactive (dead) since Fri 2021-06-11 02:53:39 CST; 12min ago
Process: 4362 ExecStart=/usr/sbin/firewalld --nofork --nopid $FIREWALLD_ARGS (code=exited, status=0/SUCCESS)
Main PID: 4362 (code=exited, status=0/SUCCESS)

Try this command, see if helps:

systemctl disable firewalld

if we command systemctl disable firewalld.service

then xmpp is not work

if we command systemctl disable firewalld.service

then xmpp is not work